- Use %global instead of %define - Automatically generate debuginfo subpackage - Merged various changes from the native Fedora package (up to 1.0.0-0.5.beta3) - Don't use the %{_mingw32_make} macro anymore as it's ugly and causes side-effects NOTE: Right now, this package doesn't provide versioned DLL's as the upstream defaults are used and I couldn't find the right spot in the build scripts to realize this (openssl's build system is really messy..).
12 lines
436 B
Diff
12 lines
436 B
Diff
--- openssl-1.0.0-beta3/Makefile.shared.orig 2009-08-29 17:02:27.496816550 +0200
|
|
+++ openssl-1.0.0-beta3/Makefile.shared 2009-08-29 17:04:54.897820373 +0200
|
|
@@ -250,7 +250,7 @@
|
|
base=-Wl,--enable-auto-image-base; \
|
|
deffile=; \
|
|
if expr $(PLATFORM) : 'mingw' > /dev/null; then \
|
|
- SHLIB=$(LIBNAME)eay32; base=; \
|
|
+ SHLIB=lib$(LIBNAME); base=; \
|
|
if test -f $(LIBNAME)eay32.def; then \
|
|
deffile=$(LIBNAME)eay32.def; \
|
|
fi; \
|