Simplified the lib renaming patch
This commit is contained in:
parent
faece3739a
commit
98504654ea
@ -24,20 +24,16 @@ diff -up openssl-1.0.0-beta3/Makefile.shared.mingw-libversion openssl-1.0.0-beta
|
||||
|
||||
# LIBCOMPATVERSIONS contains the compatibility versions (a list) of
|
||||
# the library. They MUST be in decreasing order.
|
||||
@@ -250,9 +250,9 @@ link_o.cygwin:
|
||||
@@ -250,7 +250,7 @@ link_o.cygwin:
|
||||
base=-Wl,--enable-auto-image-base; \
|
||||
deffile=; \
|
||||
if expr $(PLATFORM) : 'mingw' > /dev/null; then \
|
||||
- SHLIB=$(LIBNAME)eay32; base=; \
|
||||
- if test -f $(LIBNAME)eay32.def; then \
|
||||
- deffile=$(LIBNAME)eay32.def; \
|
||||
+ SHLIB=lib$(LIBNAME); base=; \
|
||||
+ if test -f $(LIBNAME).def; then \
|
||||
+ deffile=$(LIBNAME).def; \
|
||||
if test -f $(LIBNAME)eay32.def; then \
|
||||
deffile=$(LIBNAME)eay32.def; \
|
||||
fi; \
|
||||
fi; \
|
||||
SHLIB_SUFFIX=.dll; \
|
||||
@@ -270,13 +270,9 @@ link_a.cygwin:
|
||||
@@ -270,13 +270,7 @@ link_a.cygwin:
|
||||
dll_name=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX; extras=; \
|
||||
base=-Wl,--enable-auto-image-base; \
|
||||
if expr $(PLATFORM) : 'mingw' > /dev/null; then \
|
||||
@ -46,21 +42,9 @@ diff -up openssl-1.0.0-beta3/Makefile.shared.mingw-libversion openssl-1.0.0-beta
|
||||
- ssl) SHLIB=ssleay;; \
|
||||
- esac; \
|
||||
- SHLIB_SOVER=32; \
|
||||
+ SHLIB=lib$(LIBNAME); \
|
||||
extras="$(LIBNAME).def"; \
|
||||
- extras="$(LIBNAME).def"; \
|
||||
- $(PERL) util/mkdef.pl 32 $$SHLIB > $$extras; \
|
||||
+ $(PERL) util/mkdef.pl 32 $(LIBNAME) > $$extras; \
|
||||
+ SHLIB=lib$(LIBNAME); \
|
||||
base=; [ $(LIBNAME) = "crypto" ] && base=-Wl,--image-base,0x63000000; \
|
||||
fi; \
|
||||
dll_name=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX; \
|
||||
--- openssl-1.0.0-beta3/util/mkdef.pl.orig 2009-08-30 00:50:32.108820466 +0200
|
||||
+++ openssl-1.0.0-beta3/util/mkdef.pl 2009-08-30 00:51:00.032820656 +0200
|
||||
@@ -1244,7 +1244,7 @@
|
||||
my $description = "$what $version, $name - http://$http_vendor";
|
||||
|
||||
if ($W32)
|
||||
- { $libname.="32"; }
|
||||
+ { $libname="lib$libname-10.dll"; }
|
||||
elsif ($W16)
|
||||
{ $libname.="16"; }
|
||||
elsif ($OS2)
|
||||
|
@ -31,7 +31,7 @@
|
||||
|
||||
Name: mingw32-openssl
|
||||
Version: 1.0.0
|
||||
Release: 0.2.%{beta}%{?dist}
|
||||
Release: 0.3.%{beta}%{?dist}
|
||||
Summary: MinGW port of the OpenSSL toolkit
|
||||
|
||||
License: OpenSSL
|
||||
@ -347,6 +347,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 30 2009 Kalev Lember <kalev@smartlink.ee> - 1.0.0-0.3.beta3
|
||||
- Simplified the lib renaming patch
|
||||
|
||||
* Sun Aug 30 2009 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.0-0.2.beta3
|
||||
- Fixed invalid RPM Provides
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user