Rebased mingw32 specific patches
This commit is contained in:
parent
f943b6e544
commit
5eeb7effd2
@ -1,6 +1,7 @@
|
||||
--- util/libeay.num.orig 2009-08-29 15:41:45.207820734 +0200
|
||||
+++ util/libeay.num 2009-08-29 15:48:03.746817062 +0200
|
||||
@@ -1084,7 +1084,6 @@
|
||||
diff -up openssl-1.0.0a/util/libeay.num.mingw-linker-fix openssl-1.0.0a/util/libeay.num
|
||||
--- openssl-1.0.0a/util/libeay.num.mingw-linker-fix 2010-04-13 20:08:50.000000000 +0300
|
||||
+++ openssl-1.0.0a/util/libeay.num 2010-06-19 19:03:07.000000000 +0300
|
||||
@@ -1084,7 +1084,6 @@ BIO_s_socks4a_connect
|
||||
PROXY_set_connect_mode 1112 NOEXIST::FUNCTION:
|
||||
RAND_SSLeay 1113 EXIST::FUNCTION:
|
||||
RAND_set_rand_method 1114 EXIST::FUNCTION:
|
||||
@ -8,10 +9,10 @@
|
||||
bn_sub_words 1116 EXIST::FUNCTION:
|
||||
bn_mul_normal 1117 NOEXIST::FUNCTION:
|
||||
bn_mul_comba8 1118 NOEXIST::FUNCTION:
|
||||
@@ -2844,17 +2843,8 @@
|
||||
@@ -2844,17 +2843,8 @@ sk_is_sorted
|
||||
X509_check_ca 3286 EXIST::FUNCTION:
|
||||
private_idea_set_encrypt_key 3287 NOEXIST::FUNCTION:
|
||||
HMAC_CTX_set_flags 3288 NOEXIST::FUNCTION:
|
||||
HMAC_CTX_set_flags 3288 EXIST::FUNCTION:HMAC
|
||||
-private_SHA_Init 3289 NOEXIST::FUNCTION:
|
||||
-private_CAST_set_key 3290 NOEXIST::FUNCTION:
|
||||
-private_RIPEMD160_Init 3291 NOEXIST::FUNCTION:
|
||||
@ -26,7 +27,7 @@
|
||||
d2i_PROXY_CERT_INFO_EXTENSION 3300 EXIST::FUNCTION:
|
||||
PROXY_POLICY_it 3301 EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
|
||||
PROXY_POLICY_it 3301 EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
|
||||
@@ -3318,7 +3308,6 @@
|
||||
@@ -3318,7 +3308,6 @@ X509_policy_check
|
||||
EVP_PKEY_get_attr_by_NID 3721 EXIST::FUNCTION:
|
||||
STORE_set_ex_data 3722 NOEXIST::FUNCTION:
|
||||
ENGINE_get_ECDSA 3723 EXIST::FUNCTION:ENGINE
|
||||
@ -34,7 +35,7 @@
|
||||
BN_BLINDING_get_flags 3725 EXIST::FUNCTION:
|
||||
PKCS12_add_cert 3726 EXIST::FUNCTION:
|
||||
STORE_OBJECT_new 3727 NOEXIST::FUNCTION:
|
||||
@@ -3702,7 +3691,6 @@
|
||||
@@ -3702,7 +3691,6 @@ FIPS_rsa_free
|
||||
FIPS_dsa_sig_encode 4089 NOEXIST::FUNCTION:
|
||||
CRYPTO_dbg_remove_all_info 4090 NOEXIST::FUNCTION:
|
||||
OPENSSL_init 4091 NOEXIST::FUNCTION:
|
@ -1,7 +1,7 @@
|
||||
diff -up openssl-1.0.0-beta3/engines/Makefile.mingw-libversion openssl-1.0.0-beta3/engines/Makefile
|
||||
--- openssl-1.0.0-beta3/engines/Makefile.mingw-libversion 2009-08-29 22:33:22.000000000 +0300
|
||||
+++ openssl-1.0.0-beta3/engines/Makefile 2009-08-29 22:34:15.000000000 +0300
|
||||
@@ -110,7 +110,10 @@ install:
|
||||
diff -up openssl-1.0.0a/engines/Makefile.mingw-sfx openssl-1.0.0a/engines/Makefile
|
||||
--- openssl-1.0.0a/engines/Makefile.mingw-sfx 2010-06-19 21:52:59.000000000 +0300
|
||||
+++ openssl-1.0.0a/engines/Makefile 2010-06-19 21:53:34.000000000 +0300
|
||||
@@ -111,7 +111,10 @@ install:
|
||||
for l in $(LIBNAMES); do \
|
||||
( echo installing $$l; \
|
||||
pfx=lib; \
|
@ -84,10 +84,10 @@ Patch53: openssl-1.0.0-name-hash.patch
|
||||
# Rename *eay32.dll to lib*.dll
|
||||
Patch101: mingw32-openssl-1.0.0-beta3-libversion.patch
|
||||
# Fix engines/ install target after lib rename
|
||||
Patch102: mingw32-openssl-1.0.0-beta3-sfx.patch
|
||||
Patch102: mingw32-openssl-1.0.0a-sfx.patch
|
||||
# Ugly patch to fix a compilation error (the linker can't find
|
||||
# some symbols mentioned in an autogenerated .def file)
|
||||
Patch105: mingw32-openssl-1.0.0-beta3-linker-fix.patch
|
||||
Patch103: mingw32-openssl-1.0.0a-linker-fix.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -181,7 +181,7 @@ Static version of the MinGW port of the OpenSSL toolkit.
|
||||
|
||||
%patch101 -p1 -b .mingw-libversion
|
||||
%patch102 -p1 -b .mingw-sfx
|
||||
%patch105 -p0 -b .mingw-linker-fix
|
||||
%patch103 -p1 -b .mingw-linker-fix
|
||||
|
||||
# Use _mingw32_cflags instead of hardcoded ones
|
||||
sed -i -e '/^"mingw"/ s/-fomit-frame-pointer -O3 -march=i486 -Wall/%{_mingw32_cflags}/' Configure
|
||||
@ -346,6 +346,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
- Updated to openssl 1.0.0a
|
||||
- Synced patches with Fedora native openssl-1.0.0a-1
|
||||
- Use sed to fix up cflags instead of unmaintainable patch
|
||||
- Rebased mingw32 specific patches
|
||||
|
||||
* Thu Nov 26 2009 Kalev Lember <kalev@smartlink.ee> - 1.0.0-0.6.beta4
|
||||
- Merged patches from native Fedora openssl (up to 1.0.0-0.16.beta4)
|
||||
|
Loading…
Reference in New Issue
Block a user