Update to 1.4.2
This commit is contained in:
parent
fe5f90f747
commit
e839a929ea
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/libjpeg-turbo-1.2.90.tar.gz
|
||||
/libjpeg-turbo-1.3.0.tar.gz
|
||||
/libjpeg-turbo-1.3.1.tar.gz
|
||||
/libjpeg-turbo-1.4.2.tar.gz
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- a/jchuff.c
|
||||
+++ b/jchuff.c
|
||||
@@ -4,7 +4,7 @@
|
||||
* This file was part of the Independent JPEG Group's software:
|
||||
* Copyright (C) 1991-1997, Thomas G. Lane.
|
||||
* libjpeg-turbo Modifications:
|
||||
- * Copyright (C) 2009-2011, D. R. Commander.
|
||||
+ * Copyright (C) 2009-2011, 2014 D. R. Commander.
|
||||
* For conditions of distribution and use, see the accompanying README file.
|
||||
*
|
||||
* This file contains Huffman entropy encoding routines.
|
||||
@@ -426,7 +426,7 @@
|
||||
LOCAL(boolean)
|
||||
flush_bits (working_state * state)
|
||||
{
|
||||
- JOCTET _buffer[BUFSIZE], *buffer;
|
||||
+ JOCTET _buffer[BUFSIZE + 8], *buffer;
|
||||
size_t put_buffer; int put_bits;
|
||||
size_t bytes, bytestocopy; int localbuf = 0;
|
||||
|
||||
@@ -455,7 +455,7 @@
|
||||
int temp, temp2, temp3;
|
||||
int nbits;
|
||||
int r, code, size;
|
||||
- JOCTET _buffer[BUFSIZE], *buffer;
|
||||
+ JOCTET _buffer[BUFSIZE + 8], *buffer;
|
||||
size_t put_buffer; int put_bits;
|
||||
int code_0xf0 = actbl->ehufco[0xf0], size_0xf0 = actbl->ehufsi[0xf0];
|
||||
size_t bytes, bytestocopy; int localbuf = 0;
|
@ -1,29 +0,0 @@
|
||||
--- a/jchuff.c
|
||||
+++ b/jchuff.c
|
||||
@@ -408,7 +408,7 @@
|
||||
#endif
|
||||
|
||||
|
||||
-#define BUFSIZE (DCTSIZE2 * 2)
|
||||
+#define BUFSIZE (DCTSIZE2 * 2) + 8
|
||||
|
||||
#define LOAD_BUFFER() { \
|
||||
if (state->free_in_buffer < BUFSIZE) { \
|
||||
@@ -443,7 +443,7 @@
|
||||
LOCAL(boolean)
|
||||
flush_bits (working_state * state)
|
||||
{
|
||||
- JOCTET _buffer[BUFSIZE + 8], *buffer;
|
||||
+ JOCTET _buffer[BUFSIZE], *buffer;
|
||||
size_t put_buffer; int put_bits;
|
||||
size_t bytes, bytestocopy; int localbuf = 0;
|
||||
|
||||
@@ -472,7 +472,7 @@
|
||||
int temp, temp2, temp3;
|
||||
int nbits;
|
||||
int r, code, size;
|
||||
- JOCTET _buffer[BUFSIZE + 8], *buffer;
|
||||
+ JOCTET _buffer[BUFSIZE], *buffer;
|
||||
size_t put_buffer; int put_bits;
|
||||
int code_0xf0 = actbl->ehufco[0xf0], size_0xf0 = actbl->ehufsi[0xf0];
|
||||
size_t bytes, bytestocopy; int localbuf = 0;
|
@ -1,18 +1,16 @@
|
||||
--- libjpeg-turbo-1.3.0/win/jconfig.h.in.orig 2013-08-03 21:52:45.115856655 +0200
|
||||
+++ libjpeg-turbo-1.3.0/win/jconfig.h.in 2013-08-03 21:53:40.335912080 +0200
|
||||
@@ -7,14 +7,14 @@
|
||||
#cmakedefine D_ARITH_CODING_SUPPORTED
|
||||
#cmakedefine MEM_SRCDST_SUPPORTED
|
||||
--- libjpeg-turbo-1.4.2/win/jconfig.h.in.orig 2016-05-10 17:10:15.359564444 +0200
|
||||
+++ libjpeg-turbo-1.4.2/win/jconfig.h.in 2016-05-10 17:11:10.705555543 +0200
|
||||
@@ -18,13 +18,13 @@
|
||||
|
||||
#define BITS_IN_JSAMPLE @BITS_IN_JSAMPLE@ /* use 8 or 12 */
|
||||
|
||||
-#define HAVE_PROTOTYPES
|
||||
-#define HAVE_UNSIGNED_CHAR
|
||||
-#define HAVE_UNSIGNED_SHORT
|
||||
+#define HAVE_PROTOTYPES 1
|
||||
+#define HAVE_UNSIGNED_CHAR 1
|
||||
+#define HAVE_UNSIGNED_SHORT 1
|
||||
/* #define void char */
|
||||
/* #define const */
|
||||
#undef CHAR_IS_UNSIGNED
|
||||
#undef __CHAR_UNSIGNED__
|
||||
-#define HAVE_STDDEF_H
|
||||
-#define HAVE_STDLIB_H
|
||||
+#define HAVE_STDDEF_H 1
|
||||
@ -20,7 +18,7 @@
|
||||
#undef NEED_BSD_STRINGS
|
||||
#undef NEED_SYS_TYPES_H
|
||||
#undef NEED_FAR_POINTERS /* we presume a 32-bit flat memory model */
|
||||
@@ -25,7 +25,7 @@
|
||||
@@ -34,7 +34,7 @@
|
||||
#ifndef __RPCNDR_H__ /* don't conflict if rpcndr.h already read */
|
||||
typedef unsigned char boolean;
|
||||
#endif
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- libjpeg-turbo-1.3.1/CMakeLists.txt.orig 2014-05-29 17:00:31.775255437 +0200
|
||||
+++ libjpeg-turbo-1.3.1/CMakeLists.txt 2014-05-29 17:01:07.174824178 +0200
|
||||
@@ -3,7 +3,10 @@
|
||||
#
|
||||
|
||||
cmake_minimum_required(VERSION 2.8.8)
|
||||
-cmake_policy(SET CMP0022 OLD)
|
||||
+# Use LINK_INTERFACE_LIBRARIES instead of INTERFACE_LINK_LIBRARIES
|
||||
+if(POLICY CMP0022)
|
||||
+ cmake_policy(SET CMP0022 OLD)
|
||||
+endif()
|
||||
|
||||
project(libjpeg-turbo C)
|
||||
set(VERSION 1.3.1)
|
@ -5,8 +5,8 @@
|
||||
%global build_programs 0
|
||||
|
||||
Name: mingw-libjpeg-turbo
|
||||
Version: 1.3.1
|
||||
Release: 6%{?dist}
|
||||
Version: 1.4.2
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows Libjpeg-turbo library
|
||||
|
||||
License: wxWidgets
|
||||
@ -18,13 +18,6 @@ Source0: http://downloads.sourceforge.net/libjpeg-turbo/libjpeg-turbo-%{v
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=843193
|
||||
Patch0: libjpeg-turbo-match-autoconf-behavior.patch
|
||||
|
||||
# Fix compatibility with older CMake versions (as used on RHEL7)
|
||||
Patch1: libjpeg-turbo-r1237.patch
|
||||
|
||||
# Fix CVE-2014-9092 (RHBZ #1169851 #1169853)
|
||||
Patch2: libjpeg-turbo-commit-1365.patch
|
||||
Patch3: libjpeg-turbo-commit-1367.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 95
|
||||
@ -87,9 +80,6 @@ Static version of the MinGW Windows cross compiled Libjpeg-turbo library.
|
||||
%prep
|
||||
%setup -q -n libjpeg-turbo-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -160,6 +150,9 @@ chmod -x README-turbo.txt
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 10 2016 Kalev Lember <klember@redhat.com> - 1.4.2-1
|
||||
- Update to 1.4.2
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user