Prevent headers to be regenerated from IDL
Fixes build failure when the environment variable WIDL is set (which happens automatically when mingw-w64-tools is installed)
This commit is contained in:
parent
6758c0f0bf
commit
d6e410556f
22
mingw-headers-no-widl.patch
Normal file
22
mingw-headers-no-widl.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- mingw-w64-headers/configure.ac.orig 2014-03-30 15:23:08.248186613 +0200
|
||||||
|
+++ mingw-w64-headers/configure.ac 2014-03-30 15:24:15.775316204 +0200
|
||||||
|
@@ -27,7 +27,7 @@
|
||||||
|
[AS_VAR_SET([with_widl],[no])])
|
||||||
|
AC_MSG_RESULT([$with_widl])
|
||||||
|
|
||||||
|
-AS_VAR_IF([with_widl],[no],[],[
|
||||||
|
+AS_VAR_IF([with_widl],[no],[unset WIDL],[
|
||||||
|
AS_VAR_IF([srcdir],[.],[],
|
||||||
|
[AC_MSG_WARN([--with-widl used in out of the tree compilation. Existing generated files will not be modified.])])
|
||||||
|
AC_PATH_PROGS([WIDL], [$host-widl widl], [], [$with_widl])
|
||||||
|
--- mingw-w64-headers/configure.orig 2014-03-30 15:24:23.969453233 +0200
|
||||||
|
+++ mingw-w64-headers/configure 2014-03-30 15:24:26.479495205 +0200
|
||||||
|
@@ -2565,7 +2473,7 @@
|
||||||
|
$as_echo "$with_widl" >&6; }
|
||||||
|
|
||||||
|
if test "x$with_widl" = xno; then :
|
||||||
|
-
|
||||||
|
+ unset WIDL
|
||||||
|
else
|
||||||
|
|
||||||
|
if test "x$srcdir" = x.; then :
|
@ -37,6 +37,12 @@ Source0: http://sourceforge.net/code-snapshots/svn/m/mi/mingw-w64/code/mi
|
|||||||
Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}.tar.bz2
|
Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}.tar.bz2
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Our RPM macros automatically set the environment variable WIDL
|
||||||
|
# This confuses the mingw-headers configure scripts and causes various
|
||||||
|
# headers to be regenerated from their .idl source. Prevent this from
|
||||||
|
# happening as the .idl files shouldn't be used by default
|
||||||
|
Patch0: mingw-headers-no-widl.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: mingw32-filesystem >= 95
|
BuildRequires: mingw32-filesystem >= 95
|
||||||
@ -82,6 +88,8 @@ unzip %{S:0}
|
|||||||
%setup -q -n mingw-w64-v%{version}
|
%setup -q -n mingw-w64-v%{version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%patch0 -p0 -b .idl
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
pushd mingw-w64-headers
|
pushd mingw-w64-headers
|
||||||
@ -117,6 +125,9 @@ rm -f $RPM_BUILD_ROOT%{mingw64_includedir}/pthread_unistd.h
|
|||||||
%changelog
|
%changelog
|
||||||
* Sun Mar 30 2014 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.1.999-0.8.trunk.r6559.20140330
|
* Sun Mar 30 2014 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.1.999-0.8.trunk.r6559.20140330
|
||||||
- Update to r6559 (20140330 snapshot)
|
- Update to r6559 (20140330 snapshot)
|
||||||
|
- Prevent headers to be regenerated from IDL
|
||||||
|
Fixes build failure when the environment variable WIDL is set
|
||||||
|
(which happens automatically when mingw-w64-tools is installed)
|
||||||
|
|
||||||
* Mon Feb 24 2014 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.1.999-0.7.trunk.r6497.20140224
|
* Mon Feb 24 2014 Erik van Pienbroek <epienbro@fedoraproject.org> - 3.1.999-0.7.trunk.r6497.20140224
|
||||||
- Update to r6497 (20140224 snapshot)
|
- Update to r6497 (20140224 snapshot)
|
||||||
|
Loading…
Reference in New Issue
Block a user