Update to 6.0.0
This commit is contained in:
parent
4ccf2f626b
commit
88f02c400f
1
.gitignore
vendored
1
.gitignore
vendored
@ -66,3 +66,4 @@
|
||||
/mingw-w64-v5.0.2.tar.bz2
|
||||
/mingw-w64-v5.0.3.tar.bz2
|
||||
/mingw-w64-v5.0.4.tar.bz2
|
||||
/mingw-w64-v6.0.0.tar.bz2
|
||||
|
4286
commit-7de6266
4286
commit-7de6266
File diff suppressed because it is too large
Load Diff
@ -1,17 +1,7 @@
|
||||
--- mingw-w64-headers/configure.ac.orig 2014-03-30 15:23:08.248186613 +0200
|
||||
+++ mingw-w64-headers/configure.ac 2014-03-30 15:24:15.775316204 +0200
|
||||
@@ -27,7 +27,7 @@
|
||||
[AS_VAR_SET([with_widl],[no])])
|
||||
AC_MSG_RESULT([$with_widl])
|
||||
|
||||
-AS_VAR_IF([with_widl],[no],[],[
|
||||
+AS_VAR_IF([with_widl],[no],[unset WIDL],[
|
||||
AS_VAR_IF([srcdir],[.],[],
|
||||
[AC_MSG_WARN([--with-widl used in out of the tree compilation. Existing generated files will not be modified.])])
|
||||
AC_PATH_PROGS([WIDL], [$host-widl widl], [], [$with_widl])
|
||||
--- mingw-w64-headers/configure.orig 2014-03-30 15:24:23.969453233 +0200
|
||||
+++ mingw-w64-headers/configure 2014-03-30 15:24:26.479495205 +0200
|
||||
@@ -2565,7 +2473,7 @@
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-headers/configure mingw-w64-v6.0.0-new/mingw-w64-headers/configure
|
||||
--- mingw-w64-v6.0.0/mingw-w64-headers/configure 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-headers/configure 2019-05-07 17:04:47.100390886 +0200
|
||||
@@ -2576,7 +2576,7 @@ fi
|
||||
$as_echo "$with_widl" >&6; }
|
||||
|
||||
if test "x$with_widl" = xno; then :
|
||||
@ -20,3 +10,15 @@
|
||||
else
|
||||
|
||||
if test "x$srcdir" = x.; then :
|
||||
diff -rupN mingw-w64-v6.0.0/mingw-w64-headers/configure.ac mingw-w64-v6.0.0-new/mingw-w64-headers/configure.ac
|
||||
--- mingw-w64-v6.0.0/mingw-w64-headers/configure.ac 2018-09-14 16:16:43.000000000 +0200
|
||||
+++ mingw-w64-v6.0.0-new/mingw-w64-headers/configure.ac 2019-05-07 17:04:47.100390886 +0200
|
||||
@@ -27,7 +27,7 @@ AC_ARG_WITH([widl],
|
||||
[AS_VAR_SET([with_widl],[no])])
|
||||
AC_MSG_RESULT([$with_widl])
|
||||
|
||||
-AS_VAR_IF([with_widl],[no],[],[
|
||||
+AS_VAR_IF([with_widl],[no],[unset WIDL],[
|
||||
AS_VAR_IF([srcdir],[.],[],
|
||||
[AC_MSG_WARN([--with-widl used in out of the tree compilation. Existing generated files will not be modified.])])
|
||||
AC_PATH_PROGS([WIDL], [$host-widl widl], [], [$with_widl])
|
||||
|
@ -21,8 +21,8 @@
|
||||
%endif
|
||||
|
||||
Name: mingw-headers
|
||||
Version: 5.0.4
|
||||
Release: 3%{?dist}
|
||||
Version: 6.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Win32/Win64 header files
|
||||
|
||||
License: Public Domain and LGPLv2+ and ZPLv2.1
|
||||
@ -44,9 +44,6 @@ Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}
|
||||
# happening as the .idl files shouldn't be used by default
|
||||
Patch0: mingw-headers-no-widl.patch
|
||||
|
||||
# Backported patch needed by latest wine-gecko
|
||||
Patch1: commit-7de6266
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 95
|
||||
@ -87,14 +84,11 @@ rm -rf mingw-w64-v%{version}
|
||||
mkdir mingw-w64-v%{version}
|
||||
cd mingw-w64-v%{version}
|
||||
unzip %{S:0}
|
||||
%setup -q -D -T -n mingw-w64-v%{version}/mingw-w64-mingw-w64-%{snapshot_rev}
|
||||
%autosetup -p1 -D -T -n mingw-w64-v%{version}/mingw-w64-mingw-w64-%{snapshot_rev}
|
||||
%else
|
||||
%setup -q -n mingw-w64-v%{version}%{?pre:-%{pre}}
|
||||
%autosetup -p1 -n mingw-w64-v%{version}%{?pre:-%{pre}}
|
||||
%endif
|
||||
|
||||
%patch0 -p0 -b .idl
|
||||
%patch1 -p1 -b .gecko
|
||||
|
||||
|
||||
%build
|
||||
pushd mingw-w64-headers
|
||||
@ -104,17 +98,17 @@ popd
|
||||
|
||||
%install
|
||||
pushd mingw-w64-headers
|
||||
%mingw_make_install DESTDIR=$RPM_BUILD_ROOT
|
||||
%mingw_make_install DESTDIR=%{buildroot}
|
||||
popd
|
||||
|
||||
# Drop the dummy pthread headers if necessary
|
||||
%if 0%{?bundle_dummy_pthread_headers} == 0
|
||||
rm -f $RPM_BUILD_ROOT%{mingw32_includedir}/pthread_signal.h
|
||||
rm -f $RPM_BUILD_ROOT%{mingw32_includedir}/pthread_time.h
|
||||
rm -f $RPM_BUILD_ROOT%{mingw32_includedir}/pthread_unistd.h
|
||||
rm -f $RPM_BUILD_ROOT%{mingw64_includedir}/pthread_signal.h
|
||||
rm -f $RPM_BUILD_ROOT%{mingw64_includedir}/pthread_time.h
|
||||
rm -f $RPM_BUILD_ROOT%{mingw64_includedir}/pthread_unistd.h
|
||||
rm -f %{buildroot}%{mingw32_includedir}/pthread_signal.h
|
||||
rm -f %{buildroot}%{mingw32_includedir}/pthread_time.h
|
||||
rm -f %{buildroot}%{mingw32_includedir}/pthread_unistd.h
|
||||
rm -f %{buildroot}%{mingw64_includedir}/pthread_signal.h
|
||||
rm -f %{buildroot}%{mingw64_includedir}/pthread_time.h
|
||||
rm -f %{buildroot}%{mingw64_includedir}/pthread_unistd.h
|
||||
%endif
|
||||
|
||||
|
||||
@ -128,6 +122,9 @@ rm -f $RPM_BUILD_ROOT%{mingw64_includedir}/pthread_unistd.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 07 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
|
||||
- Update to 6.0.0
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mingw-w64-v5.0.4.tar.bz2) = 5b279222e86475a982e2aeb9fc14853f4fac0ca0c5a2d56f303584d1b348726afd99b0292a5ed050d326e7cb1434e5ad5b5dfdfb37c73fd08f13e7f4f4bcc046
|
||||
SHA512 (mingw-w64-v6.0.0.tar.bz2) = e3d3663e0cb33a16f90b1a33e81b5a30d26f7e34270b14e865c10068f2a2d32da9ef8cbbb0c3fed9c71429ae11c82152ff3b87d81558929b2a4993dc99cfc11e
|
||||
|
Loading…
Reference in New Issue
Block a user