Rebase to Fedora Rawhide (bundle_dummy_pthread_headers=1)

resolves: rhbz#2079435
side-tag: c9s-build-side-467-stack-gate
This commit is contained in:
Richard W.M. Jones 2022-05-06 14:03:01 +01:00
parent a3fc546d3d
commit 3900ff69c5
4 changed files with 41 additions and 48 deletions

1
.gitignore vendored
View File

@ -71,3 +71,4 @@
/mingw-w64-v8.0.0.tar.bz2
/mingw-w64-v8.0.2.tar.bz2
/mingw-w64-v9.0.0.tar.bz2
/mingw-w64-v10.0.0.tar.bz2

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference mingw-w64-v9.0.0/mingw-w64-headers/configure mingw-w64-v9.0.0-new/mingw-w64-headers/configure
--- mingw-w64-v9.0.0/mingw-w64-headers/configure 2021-05-22 14:34:25.000000000 +0200
+++ mingw-w64-v9.0.0-new/mingw-w64-headers/configure 2021-06-22 09:18:27.040547425 +0200
diff -rupN --no-dereference mingw-w64-v10.0.0/mingw-w64-headers/configure mingw-w64-v10.0.0-new/mingw-w64-headers/configure
--- mingw-w64-v10.0.0/mingw-w64-headers/configure 2022-04-03 17:08:58.000000000 +0200
+++ mingw-w64-v10.0.0-new/mingw-w64-headers/configure 2022-04-26 09:09:23.178755423 +0200
@@ -2734,7 +2734,7 @@ printf "%s\n" "$with_widl" >&6; }
if test "x$with_widl" = xno
@ -10,9 +10,9 @@ diff -rupN --no-dereference mingw-w64-v9.0.0/mingw-w64-headers/configure mingw-w
else $as_nop
if test "x$srcdir" = x.
diff -rupN --no-dereference mingw-w64-v9.0.0/mingw-w64-headers/configure.ac mingw-w64-v9.0.0-new/mingw-w64-headers/configure.ac
--- mingw-w64-v9.0.0/mingw-w64-headers/configure.ac 2021-05-22 14:34:25.000000000 +0200
+++ mingw-w64-v9.0.0-new/mingw-w64-headers/configure.ac 2021-06-22 09:18:27.041547429 +0200
diff -rupN --no-dereference mingw-w64-v10.0.0/mingw-w64-headers/configure.ac mingw-w64-v10.0.0-new/mingw-w64-headers/configure.ac
--- mingw-w64-v10.0.0/mingw-w64-headers/configure.ac 2022-04-03 17:08:58.000000000 +0200
+++ mingw-w64-v10.0.0-new/mingw-w64-headers/configure.ac 2022-04-26 09:09:23.178755423 +0200
@@ -27,7 +27,7 @@ AC_ARG_WITH([widl],
[AS_VAR_SET([with_widl],[no])])
AC_MSG_RESULT([$with_widl])

View File

@ -1,42 +1,21 @@
#%%global snapshot_date 20160723
#%%global snapshot_rev 65a0c3298db7cc5cbded63259663cb29e4780a56
#%%global snapshot_rev_short %(echo %snapshot_rev | cut -c1-6)
#%%global branch v5.x
#%%global pre rc2
%global mingw_build_ucrt64 1
# The mingw-w64-headers provide the headers pthread_time.h
# and pthread_unistd.h by default and are dummy headers.
# The real implementation for these headers is in a separate
# library called winpthreads. As long as winpthreads isn't
# available (and the old pthreads-w32 implementation is used)
# the flag below needs to be set to 1. When winpthreads is
# available then this flag needs to be set to 0 to avoid
# a file conflict with the winpthreads headers
# Winpthreads is available as of Fedora 20
%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
%global bundle_dummy_pthread_headers 0
%else
# build, the flag below needs to be set to 1. When winpthreads
# is available then this flag needs to be set to 0 to avoid
# a file conflict with the winpthreads headers.
%global bundle_dummy_pthread_headers 1
%endif
Name: mingw-headers
Version: 9.0.0
Release: 2%{?dist}
Version: 10.0.0
Release: 3%{?dist}
Summary: Win32/Win64 header files
License: Public Domain and LGPLv2+ and ZPLv2.1
URL: http://mingw-w64.sourceforge.net/
%if 0%{?snapshot_date}
# To regenerate a snapshot:
# Use your regular webbrowser to open https://sourceforge.net/p/mingw-w64/mingw-w64/ci/%{snapshot_rev}/tarball
# This triggers the SourceForge instructure to generate a snapshot
# After that you can pull in the archive with:
# spectool -g mingw-headers.spec
Source0: http://sourceforge.net/code-snapshots/git/m/mi/mingw-w64/mingw-w64.git/mingw-w64-mingw-w64-%{snapshot_rev}.zip
%else
Source0: http://downloads.sourceforge.net/mingw-w64/mingw-w64-v%{version}%{?pre:-%{pre}}.tar.bz2
%endif
# Our RPM macros automatically set the environment variable WIDL
# This confuses the mingw-headers configure scripts and causes various
@ -47,8 +26,9 @@ Patch0: mingw-headers-no-widl.patch
BuildArch: noarch
BuildRequires: make
BuildRequires: mingw32-filesystem >= 95
BuildRequires: mingw64-filesystem >= 95
BuildRequires: mingw32-filesystem >= 133
BuildRequires: mingw64-filesystem >= 133
BuildRequires: ucrt64-filesystem >= 133
%description
@ -62,9 +42,6 @@ Requires: mingw32-filesystem >= 95
Requires: mingw32-winpthreads
%endif
Obsoletes: mingw32-w32api < 3.17-3%{?dist}
Provides: mingw32-w32api = 3.17-3%{?dist}
%description -n mingw32-headers
MinGW Windows cross-compiler Win32 header files.
@ -78,22 +55,26 @@ Requires: mingw64-winpthreads
%description -n mingw64-headers
MinGW Windows cross-compiler Win64 header files.
%package -n ucrt64-headers
Summary: MinGW Windows cross-compiler Win64 header files
Requires: ucrt64-filesystem >= 133
%if 0%{bundle_dummy_pthread_headers} == 0
Requires: ucrt64-winpthreads
%endif
%description -n ucrt64-headers
MinGW Windows cross-compiler Win64 header files.
%prep
%if 0%{?snapshot_date}
rm -rf mingw-w64-v%{version}
mkdir mingw-w64-v%{version}
cd mingw-w64-v%{version}
unzip %{S:0}
%autosetup -p1 -D -T -n mingw-w64-v%{version}/mingw-w64-mingw-w64-%{snapshot_rev}
%else
%autosetup -p1 -n mingw-w64-v%{version}%{?pre:-%{pre}}
%endif
%build
export UCRT64_CONFIGURE_ARGS="--with-default-msvcrt=ucrt"
pushd mingw-w64-headers
%mingw_configure --enable-sdk=all --enable-secure-api
%mingw_configure --enable-sdk=all --enable-idl
popd
@ -110,6 +91,9 @@ rm -f %{buildroot}%{mingw32_includedir}/pthread_unistd.h
rm -f %{buildroot}%{mingw64_includedir}/pthread_signal.h
rm -f %{buildroot}%{mingw64_includedir}/pthread_time.h
rm -f %{buildroot}%{mingw64_includedir}/pthread_unistd.h
rm -f %{buildroot}%{ucrt64_includedir}/pthread_signal.h
rm -f %{buildroot}%{ucrt64_includedir}/pthread_time.h
rm -f %{buildroot}%{ucrt64_includedir}/pthread_unistd.h
%endif
@ -121,8 +105,16 @@ rm -f %{buildroot}%{mingw64_includedir}/pthread_unistd.h
%license COPYING DISCLAIMER DISCLAIMER.PD
%{mingw64_includedir}/*
%files -n ucrt64-headers
%license COPYING DISCLAIMER DISCLAIMER.PD
%{ucrt64_includedir}/*
%changelog
* Fri May 06 2022 Richard W.M. Jones <rjones@redhat.com> - 10.0.0-3
- Rebase to Fedora Rawhide
resolves: rhbz#2079435
* Mon Aug 23 2021 Richard W.M. Jones <rjones@redhat.com> - 9.0.0-2
- Update to 9.0.0
- Manually merge with fedora/rawhide

View File

@ -1 +1 @@
SHA512 (mingw-w64-v9.0.0.tar.bz2) = 6691331a2ab521d22c1d32bebe0ed049bd62a7a7722cff38e7792b4e42c6b8df4356084afff6c916b487b3ebddc4372b398ab7cd0c7f4ff6991a70fe64177386
SHA512 (mingw-w64-v10.0.0.tar.bz2) = 3c0827af7c40809a867758f6cd9ef3ff0c988b43082345bf725e03949af95968d634ace99a7ffae323189549221dcb5d861de9e801f1fbc7904e446641b60516