Update to 2.6.7
This commit is contained in:
parent
dd9da66411
commit
d46a370d63
1
.gitignore
vendored
1
.gitignore
vendored
@ -45,3 +45,4 @@
|
|||||||
/harfbuzz-2.6.2.tar.xz
|
/harfbuzz-2.6.2.tar.xz
|
||||||
/harfbuzz-2.6.4.tar.xz
|
/harfbuzz-2.6.4.tar.xz
|
||||||
/harfbuzz-2.6.6.tar.xz
|
/harfbuzz-2.6.6.tar.xz
|
||||||
|
/harfbuzz-2.6.7.tar.xz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-2.6.6/configure.ac harfbuzz-2.6.6-new/configure.ac
|
diff -rupN --no-dereference harfbuzz-2.6.7/configure.ac harfbuzz-2.6.7-new/configure.ac
|
||||||
--- harfbuzz-2.6.6/configure.ac 2020-05-11 22:59:31.000000000 +0200
|
--- harfbuzz-2.6.7/configure.ac 2020-06-03 08:58:51.000000000 +0200
|
||||||
+++ harfbuzz-2.6.6-new/configure.ac 2020-05-14 01:06:29.750319670 +0200
|
+++ harfbuzz-2.6.7-new/configure.ac 2020-06-07 12:59:13.196650847 +0200
|
||||||
@@ -484,6 +484,30 @@ fi
|
@@ -484,6 +484,30 @@ fi
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
@ -38,9 +38,9 @@ diff -rupN --no-dereference harfbuzz-2.6.6/configure.ac harfbuzz-2.6.6-new/confi
|
|||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN --no-dereference harfbuzz-2.6.6/src/Makefile.am harfbuzz-2.6.6-new/src/Makefile.am
|
diff -rupN --no-dereference harfbuzz-2.6.7/src/Makefile.am harfbuzz-2.6.7-new/src/Makefile.am
|
||||||
--- harfbuzz-2.6.6/src/Makefile.am 2020-05-06 20:42:00.000000000 +0200
|
--- harfbuzz-2.6.7/src/Makefile.am 2020-06-03 08:28:41.000000000 +0200
|
||||||
+++ harfbuzz-2.6.6-new/src/Makefile.am 2020-05-14 01:06:29.750319670 +0200
|
+++ harfbuzz-2.6.7-new/src/Makefile.am 2020-06-07 12:59:13.196650847 +0200
|
||||||
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -66,7 +66,7 @@ diff -rupN --no-dereference harfbuzz-2.6.6/src/Makefile.am harfbuzz-2.6.6-new/sr
|
|||||||
HBDEPS += $(FREETYPE_DEPS)
|
HBDEPS += $(FREETYPE_DEPS)
|
||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
@@ -138,9 +153,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -133,9 +148,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,9 +1,9 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-2.6.6/src/gen-def.py harfbuzz-2.6.6-new/src/gen-def.py
|
diff -rupN --no-dereference harfbuzz-2.6.7/src/gen-def.py harfbuzz-2.6.7-new/src/gen-def.py
|
||||||
--- harfbuzz-2.6.6/src/gen-def.py 2020-05-06 20:42:00.000000000 +0200
|
--- harfbuzz-2.6.7/src/gen-def.py 2020-05-28 21:30:56.000000000 +0200
|
||||||
+++ harfbuzz-2.6.6-new/src/gen-def.py 2020-05-14 01:06:29.867319808 +0200
|
+++ harfbuzz-2.6.7-new/src/gen-def.py 2020-06-07 12:59:13.347645729 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python3
|
-#!/usr/bin/env python3
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
|
||||||
import io, os, re, sys
|
"usage: gen-def.py harfbuzz.def hb.h [hb-blob.h hb-buffer.h ...]"
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 2.6.6
|
Version: 2.6.7
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jun 07 2020 Sandro Mani <manisandro@gmail.com> - 2.6.7-1
|
||||||
|
- Update to 2.6.7
|
||||||
|
|
||||||
* Tue May 19 2020 Sandro Mani <manisandro@gmail.com> - 2.6.6-2
|
* Tue May 19 2020 Sandro Mani <manisandro@gmail.com> - 2.6.6-2
|
||||||
- Rebuild (icu)
|
- Rebuild (icu)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-2.6.6.tar.xz) = b0b6323b893a3540e36e2358cc7e7d27c98aa14f1debe65cd8eaf817a55752ea4f22369e37e195abefd03bbc787f178d1b64f167237683ac208b9a65b0ae09c8
|
SHA512 (harfbuzz-2.6.7.tar.xz) = 6fdd6e0952a73e1949349aa5416ef8fb3fc351b15c95be4fe1f341b111159fe58113b73a334db2697f4e3aaef5a761bd8f1d8964514406cad40f9862768d59de
|
||||||
|
Loading…
Reference in New Issue
Block a user