Update to 2.3.1
This commit is contained in:
parent
25879b71bd
commit
b246bf2d0f
1
.gitignore
vendored
1
.gitignore
vendored
@ -34,3 +34,4 @@
|
|||||||
/harfbuzz-2.1.0.tar.bz2
|
/harfbuzz-2.1.0.tar.bz2
|
||||||
/harfbuzz-2.1.1.tar.bz2
|
/harfbuzz-2.1.1.tar.bz2
|
||||||
/harfbuzz-2.1.3.tar.bz2
|
/harfbuzz-2.1.3.tar.bz2
|
||||||
|
/harfbuzz-2.3.1.tar.bz2
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN harfbuzz-2.1.3/configure.ac harfbuzz-2.1.3-new/configure.ac
|
diff -rupN harfbuzz-2.3.1/configure.ac harfbuzz-2.3.1-new/configure.ac
|
||||||
--- harfbuzz-2.1.3/configure.ac 2018-11-17 01:49:50.000000000 +0100
|
--- harfbuzz-2.3.1/configure.ac 2019-01-30 22:42:09.000000000 +0100
|
||||||
+++ harfbuzz-2.1.3-new/configure.ac 2018-11-24 13:05:18.923513544 +0100
|
+++ harfbuzz-2.3.1-new/configure.ac 2019-01-31 15:12:55.676991795 +0100
|
||||||
@@ -497,6 +497,30 @@ fi
|
@@ -493,6 +493,30 @@ fi
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
|
|
||||||
@ -32,16 +32,16 @@ diff -rupN harfbuzz-2.1.3/configure.ac harfbuzz-2.1.3-new/configure.ac
|
|||||||
AC_CONFIG_FILES([
|
AC_CONFIG_FILES([
|
||||||
Makefile
|
Makefile
|
||||||
src/Makefile
|
src/Makefile
|
||||||
@@ -546,4 +570,5 @@ Other features:
|
@@ -543,4 +567,5 @@ Other features:
|
||||||
Documentation: ${enable_gtk_doc}
|
Documentation: ${enable_gtk_doc}
|
||||||
GObject bindings: ${have_gobject}
|
GObject bindings: ${have_gobject}
|
||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN harfbuzz-2.1.3/src/Makefile.am harfbuzz-2.1.3-new/src/Makefile.am
|
diff -rupN harfbuzz-2.3.1/src/Makefile.am harfbuzz-2.3.1-new/src/Makefile.am
|
||||||
--- harfbuzz-2.1.3/src/Makefile.am 2018-11-17 01:10:09.000000000 +0100
|
--- harfbuzz-2.3.1/src/Makefile.am 2018-12-21 23:29:03.000000000 +0100
|
||||||
+++ harfbuzz-2.1.3-new/src/Makefile.am 2018-11-24 13:05:18.923513544 +0100
|
+++ harfbuzz-2.3.1-new/src/Makefile.am 2019-01-31 15:12:55.676991795 +0100
|
||||||
@@ -50,14 +50,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -46,14 +46,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
if HAVE_FREETYPE
|
if HAVE_FREETYPE
|
||||||
@ -72,7 +72,7 @@ diff -rupN harfbuzz-2.1.3/src/Makefile.am harfbuzz-2.1.3-new/src/Makefile.am
|
|||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
endif
|
endif
|
||||||
@@ -147,9 +162,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -143,9 +158,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN harfbuzz-2.1.3/src/gen-def.py harfbuzz-2.1.3-new/src/gen-def.py
|
diff -rupN harfbuzz-2.3.1/src/gen-def.py harfbuzz-2.3.1-new/src/gen-def.py
|
||||||
--- harfbuzz-2.1.3/src/gen-def.py 2018-10-30 06:40:14.000000000 +0100
|
--- harfbuzz-2.3.1/src/gen-def.py 2018-12-14 20:54:21.000000000 +0100
|
||||||
+++ harfbuzz-2.1.3-new/src/gen-def.py 2018-11-24 13:05:18.983512939 +0100
|
+++ harfbuzz-2.3.1-new/src/gen-def.py 2019-01-31 15:12:55.767991303 +0100
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python
|
-#!/usr/bin/env python
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 2.1.3
|
Version: 2.3.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 31 2019 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
|
||||||
|
- Update to 2.3.1
|
||||||
|
|
||||||
* Sat Nov 24 2018 Sandro Mani <manisandro@gmail.com> - 2.1.3-1
|
* Sat Nov 24 2018 Sandro Mani <manisandro@gmail.com> - 2.1.3-1
|
||||||
- Update to 2.1.3
|
- Update to 2.1.3
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-2.1.3.tar.bz2) = 9bf5f7b857424037a3b3ea5c286e6ba8440c265fa663cf6b6c22cc08d36d84badfed8bdc46816ad982fc810677ebecccdb669ea98a021207e1858c8c355dbf19
|
SHA512 (harfbuzz-2.3.1.tar.bz2) = 78a8f05bfcc95cfe3fc0f1a595bdc7298c9c1456db6c7ef70914051fda43f37aaff15eac75aa6922eca82d2291baeb8385e02e6aacb44ca05b4873c311a662ac
|
||||||
|
Loading…
Reference in New Issue
Block a user