Update to 2.5.3
This commit is contained in:
parent
9a0e9d2f34
commit
9fd663d3aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -39,3 +39,4 @@
|
|||||||
/harfbuzz-2.5.0.tar.xz
|
/harfbuzz-2.5.0.tar.xz
|
||||||
/harfbuzz-2.5.1.tar.xz
|
/harfbuzz-2.5.1.tar.xz
|
||||||
/harfbuzz-2.5.2.tar.xz
|
/harfbuzz-2.5.2.tar.xz
|
||||||
|
/harfbuzz-2.5.3.tar.xz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN harfbuzz-2.5.1/configure.ac harfbuzz-2.5.1-new/configure.ac
|
diff -rupN harfbuzz-2.5.3/configure.ac harfbuzz-2.5.3-new/configure.ac
|
||||||
--- harfbuzz-2.5.1/configure.ac 2019-06-01 07:56:56.000000000 +0200
|
--- harfbuzz-2.5.3/configure.ac 2019-06-26 19:39:24.000000000 +0200
|
||||||
+++ harfbuzz-2.5.1-new/configure.ac 2019-06-03 13:49:38.656463527 +0200
|
+++ harfbuzz-2.5.3-new/configure.ac 2019-06-28 12:19:03.342499681 +0200
|
||||||
@@ -476,6 +476,30 @@ fi
|
@@ -462,6 +462,30 @@ fi
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
|
|
||||||
@ -32,16 +32,16 @@ diff -rupN harfbuzz-2.5.1/configure.ac harfbuzz-2.5.1-new/configure.ac
|
|||||||
AC_CONFIG_FILES([
|
AC_CONFIG_FILES([
|
||||||
Makefile
|
Makefile
|
||||||
src/Makefile
|
src/Makefile
|
||||||
@@ -530,4 +554,5 @@ Other features:
|
@@ -516,4 +540,5 @@ Other features:
|
||||||
Documentation: ${enable_gtk_doc}
|
Documentation: ${enable_gtk_doc}
|
||||||
GObject bindings: ${have_gobject}
|
GObject bindings: ${have_gobject}
|
||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN harfbuzz-2.5.1/src/Makefile.am harfbuzz-2.5.1-new/src/Makefile.am
|
diff -rupN harfbuzz-2.5.3/src/Makefile.am harfbuzz-2.5.3-new/src/Makefile.am
|
||||||
--- harfbuzz-2.5.1/src/Makefile.am 2019-05-24 02:34:19.000000000 +0200
|
--- harfbuzz-2.5.3/src/Makefile.am 2019-06-18 07:39:25.000000000 +0200
|
||||||
+++ harfbuzz-2.5.1-new/src/Makefile.am 2019-06-03 13:49:38.656463527 +0200
|
+++ harfbuzz-2.5.3-new/src/Makefile.am 2019-06-28 12:19:03.342499681 +0200
|
||||||
@@ -46,14 +46,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -42,14 +42,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
if HAVE_FREETYPE
|
if HAVE_FREETYPE
|
||||||
@ -72,7 +72,7 @@ diff -rupN harfbuzz-2.5.1/src/Makefile.am harfbuzz-2.5.1-new/src/Makefile.am
|
|||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
endif
|
endif
|
||||||
@@ -132,9 +147,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -128,9 +143,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN harfbuzz-2.5.1/src/gen-def.py harfbuzz-2.5.1-new/src/gen-def.py
|
diff -rupN harfbuzz-2.5.3/src/gen-def.py harfbuzz-2.5.3-new/src/gen-def.py
|
||||||
--- harfbuzz-2.5.1/src/gen-def.py 2019-05-06 21:14:20.000000000 +0200
|
--- harfbuzz-2.5.3/src/gen-def.py 2019-05-06 21:14:20.000000000 +0200
|
||||||
+++ harfbuzz-2.5.1-new/src/gen-def.py 2019-06-03 13:49:38.726463447 +0200
|
+++ harfbuzz-2.5.3-new/src/gen-def.py 2019-06-28 12:19:03.422500017 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python
|
-#!/usr/bin/env python
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 2.5.2
|
Version: 2.5.3
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 28 2019 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
|
||||||
|
- Update to 2.5.3
|
||||||
|
|
||||||
* Sat Jun 22 2019 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
|
* Sat Jun 22 2019 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
|
||||||
- Update to 2.5.2
|
- Update to 2.5.2
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-2.5.2.tar.xz) = 4a295074b56ff77581f79eae918fe064c25f07dc2ada1c87a3b2ba29ebc1ef55fa357b74c935b40621267eb061221050b4671021900ad5417580a4c57eb4739f
|
SHA512 (harfbuzz-2.5.3.tar.xz) = a2e6cedbe0e505fa31b540e0d0bc6c0b07080bd39879c27e04d351103e21201d75a809dd2fad559bf994b82b311f67ad85778cbbfb670d7e2580beafa09e93ff
|
||||||
|
Loading…
Reference in New Issue
Block a user