Update to 2.6.6
This commit is contained in:
parent
6e15e03d7b
commit
9aff78f897
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@
|
||||
/harfbuzz-2.6.1.tar.xz
|
||||
/harfbuzz-2.6.2.tar.xz
|
||||
/harfbuzz-2.6.4.tar.xz
|
||||
/harfbuzz-2.6.6.tar.xz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN --no-dereference harfbuzz-2.6.2/configure.ac harfbuzz-2.6.2-new/configure.ac
|
||||
--- harfbuzz-2.6.2/configure.ac 2019-09-30 21:34:21.000000000 +0200
|
||||
+++ harfbuzz-2.6.2-new/configure.ac 2019-10-01 11:03:18.335954546 +0200
|
||||
diff -rupN --no-dereference harfbuzz-2.6.6/configure.ac harfbuzz-2.6.6-new/configure.ac
|
||||
--- harfbuzz-2.6.6/configure.ac 2020-05-11 22:59:31.000000000 +0200
|
||||
+++ harfbuzz-2.6.6-new/configure.ac 2020-05-14 01:06:29.750319670 +0200
|
||||
@@ -484,6 +484,30 @@ fi
|
||||
|
||||
dnl ===========================================================================
|
||||
@ -38,10 +38,10 @@ diff -rupN --no-dereference harfbuzz-2.6.2/configure.ac harfbuzz-2.6.2-new/confi
|
||||
Introspection: ${have_introspection}
|
||||
+ Enable delay loading: ${enable_delay_load}
|
||||
])
|
||||
diff -rupN --no-dereference harfbuzz-2.6.2/src/Makefile.am harfbuzz-2.6.2-new/src/Makefile.am
|
||||
--- harfbuzz-2.6.2/src/Makefile.am 2019-09-04 17:28:40.000000000 +0200
|
||||
+++ harfbuzz-2.6.2-new/src/Makefile.am 2019-10-01 11:03:18.335954546 +0200
|
||||
@@ -48,14 +48,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||
diff -rupN --no-dereference harfbuzz-2.6.6/src/Makefile.am harfbuzz-2.6.6-new/src/Makefile.am
|
||||
--- harfbuzz-2.6.6/src/Makefile.am 2020-05-06 20:42:00.000000000 +0200
|
||||
+++ harfbuzz-2.6.6-new/src/Makefile.am 2020-05-14 01:06:29.750319670 +0200
|
||||
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||
endif
|
||||
|
||||
if HAVE_FREETYPE
|
||||
@ -62,17 +62,11 @@ diff -rupN --no-dereference harfbuzz-2.6.2/src/Makefile.am harfbuzz-2.6.2-new/sr
|
||||
+else
|
||||
HBLIBS += $(FREETYPE_LIBS)
|
||||
+endif
|
||||
# XXX
|
||||
# The following creates a recursive dependency on FreeType if FreeType is
|
||||
# built with HarfBuzz support enabled. Newer pkg-config handles that just
|
||||
# fine but pkg-config 0.26 as shipped in Ubuntu 14.04 crashes. Remove
|
||||
# in a year or two, or otherwise work around it...
|
||||
#HBDEPS += $(FREETYPE_DEPS)
|
||||
+HBCFLAGS += $(FREETYPE_CFLAGS)
|
||||
+HBCFLAGS += $(FREETYPE_CFLAGS)
|
||||
HBDEPS += $(FREETYPE_DEPS)
|
||||
HBSOURCES += $(HB_FT_sources)
|
||||
HBHEADERS += $(HB_FT_headers)
|
||||
endif
|
||||
@@ -141,9 +156,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||
@@ -138,9 +153,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||
|
@ -1,9 +1,9 @@
|
||||
diff -rupN --no-dereference harfbuzz-2.6.2/src/gen-def.py harfbuzz-2.6.2-new/src/gen-def.py
|
||||
--- harfbuzz-2.6.2/src/gen-def.py 2019-05-06 21:14:20.000000000 +0200
|
||||
+++ harfbuzz-2.6.2-new/src/gen-def.py 2019-10-01 11:03:18.435954541 +0200
|
||||
diff -rupN --no-dereference harfbuzz-2.6.6/src/gen-def.py harfbuzz-2.6.6-new/src/gen-def.py
|
||||
--- harfbuzz-2.6.6/src/gen-def.py 2020-05-06 20:42:00.000000000 +0200
|
||||
+++ harfbuzz-2.6.6-new/src/gen-def.py 2020-05-14 01:06:29.867319808 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
-#!/usr/bin/env python3
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from __future__ import print_function, division, absolute_import
|
||||
import io, os, re, sys
|
||||
|
||||
|
@ -1,13 +1,13 @@
|
||||
%{?mingw_package_header}
|
||||
|
||||
Name: mingw-harfbuzz
|
||||
Version: 2.6.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.6.6
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows Harfbuzz library
|
||||
|
||||
License: MIT
|
||||
URL: http://www.harfbuzz.org
|
||||
Source0: http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.xz
|
||||
Source0: https://github.com/harfbuzz/harfbuzz/releases/download/%{version}/harfbuzz-%{version}.tar.xz
|
||||
|
||||
# Allow the freetype dependency to be optional at runtime
|
||||
Patch0: harfbuzz-enable-delayload-freetype.patch
|
||||
@ -142,10 +142,13 @@ find %{buildroot} -name "*.la" -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 14 2020 Sandro Mani <manisandro@gmail.com> - 2.6.6-1
|
||||
- Update to 2.6.6
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Oct 05 2019 Sandro Mani <manisandro@gmail.com> - 2.6.4-2
|
||||
* Tue Nov 05 2019 Sandro Mani <manisandro@gmail.com> - 2.6.4-2
|
||||
- Rebuild (icu)
|
||||
|
||||
* Wed Oct 30 2019 Sandro Mani <manisandro@gmail.com> - 2.6.4-1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (harfbuzz-2.6.4.tar.xz) = d8664bb64fda11ff7646693070637e3827f8b3d1de50e11ecf108ce4d19c878b26b2ba4cff278da6e6cc0cb431e1630d9eaa7c32a9bebb9655a7aa8dabf7114f
|
||||
SHA512 (harfbuzz-2.6.6.tar.xz) = b0b6323b893a3540e36e2358cc7e7d27c98aa14f1debe65cd8eaf817a55752ea4f22369e37e195abefd03bbc787f178d1b64f167237683ac208b9a65b0ae09c8
|
||||
|
Loading…
Reference in New Issue
Block a user