Update to 2.0.1
This commit is contained in:
parent
5c6845a6b0
commit
96e13b6a32
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@
|
|||||||
/harfbuzz-1.8.5.tar.bz2
|
/harfbuzz-1.8.5.tar.bz2
|
||||||
/harfbuzz-1.8.7.tar.bz2
|
/harfbuzz-1.8.7.tar.bz2
|
||||||
/harfbuzz-1.8.8.tar.bz2
|
/harfbuzz-1.8.8.tar.bz2
|
||||||
|
/harfbuzz-2.0.1.tar.bz2
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN harfbuzz-1.8.8/configure.ac harfbuzz-1.8.8-new/configure.ac
|
diff -rupN harfbuzz-2.0.1/configure.ac harfbuzz-2.0.1-new/configure.ac
|
||||||
--- harfbuzz-1.8.8/configure.ac 2018-08-14 19:54:00.000000000 +0200
|
--- harfbuzz-2.0.1/configure.ac 2018-10-20 04:24:42.000000000 +0200
|
||||||
+++ harfbuzz-1.8.8-new/configure.ac 2018-09-10 11:01:44.189820831 +0200
|
+++ harfbuzz-2.0.1-new/configure.ac 2018-10-28 10:43:20.679631639 +0100
|
||||||
@@ -503,6 +503,30 @@ fi
|
@@ -497,6 +497,30 @@ fi
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
|
|
||||||
@ -32,16 +32,16 @@ diff -rupN harfbuzz-1.8.8/configure.ac harfbuzz-1.8.8-new/configure.ac
|
|||||||
AC_CONFIG_FILES([
|
AC_CONFIG_FILES([
|
||||||
Makefile
|
Makefile
|
||||||
src/Makefile
|
src/Makefile
|
||||||
@@ -552,4 +576,5 @@ Other features:
|
@@ -546,4 +570,5 @@ Other features:
|
||||||
Documentation: ${enable_gtk_doc}
|
Documentation: ${enable_gtk_doc}
|
||||||
GObject bindings: ${have_gobject}
|
GObject bindings: ${have_gobject}
|
||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN harfbuzz-1.8.8/src/Makefile.am harfbuzz-1.8.8-new/src/Makefile.am
|
diff -rupN harfbuzz-2.0.1/src/Makefile.am harfbuzz-2.0.1-new/src/Makefile.am
|
||||||
--- harfbuzz-1.8.8/src/Makefile.am 2018-08-14 18:48:02.000000000 +0200
|
--- harfbuzz-2.0.1/src/Makefile.am 2018-10-19 19:17:02.000000000 +0200
|
||||||
+++ harfbuzz-1.8.8-new/src/Makefile.am 2018-09-10 11:01:44.190820831 +0200
|
+++ harfbuzz-2.0.1-new/src/Makefile.am 2018-10-28 10:43:20.679631639 +0100
|
||||||
@@ -53,14 +53,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -51,14 +51,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
if HAVE_FREETYPE
|
if HAVE_FREETYPE
|
||||||
@ -72,7 +72,7 @@ diff -rupN harfbuzz-1.8.8/src/Makefile.am harfbuzz-1.8.8-new/src/Makefile.am
|
|||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
endif
|
endif
|
||||||
@@ -150,9 +165,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -148,9 +163,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN harfbuzz-1.8.8/src/gen-def.py harfbuzz-1.8.8-new/src/gen-def.py
|
diff -rupN harfbuzz-2.0.1/src/gen-def.py harfbuzz-2.0.1-new/src/gen-def.py
|
||||||
--- harfbuzz-1.8.8/src/gen-def.py 2018-07-17 16:29:54.000000000 +0200
|
--- harfbuzz-2.0.1/src/gen-def.py 2018-10-01 19:49:23.000000000 +0200
|
||||||
+++ harfbuzz-1.8.8-new/src/gen-def.py 2018-09-10 11:01:44.244820828 +0200
|
+++ harfbuzz-2.0.1-new/src/gen-def.py 2018-10-28 10:43:20.743631488 +0100
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python
|
-#!/usr/bin/env python
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 1.8.8
|
Version: 2.0.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 28 2018 Sandro Mani <manisandro@gmail.com> - 2.0.1-1
|
||||||
|
- Update to 2.0.1
|
||||||
|
|
||||||
* Mon Sep 10 2018 Sandro Mani <manisandro@gmail.com> - 1.8.8-1
|
* Mon Sep 10 2018 Sandro Mani <manisandro@gmail.com> - 1.8.8-1
|
||||||
- Update to 1.8.8
|
- Update to 1.8.8
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-1.8.8.tar.bz2) = eb96cd710571a96473b20bc9a01dadf2a3c11224497e52c63368e8edec64a8eb7085dd847c78111b798a1e8a6a950f0a04c930209822aabf13cf86d7a53b1f79
|
SHA512 (harfbuzz-2.0.1.tar.bz2) = 7bfd6194ca16251ae3382c9e06c5ac0d92613c0a67a4dd4a41227e53a217876aa509834b9265c6d6800fd7c1d703be40992435387c9f4611af6957c6c92ba94b
|
||||||
|
Loading…
Reference in New Issue
Block a user