Update to 6.0.0
This commit is contained in:
parent
2bb0df2906
commit
62b49ac64b
1
.gitignore
vendored
1
.gitignore
vendored
@ -72,3 +72,4 @@
|
|||||||
/harfbuzz-5.1.0.tar.xz
|
/harfbuzz-5.1.0.tar.xz
|
||||||
/harfbuzz-5.2.0.tar.xz
|
/harfbuzz-5.2.0.tar.xz
|
||||||
/harfbuzz-5.3.1.tar.xz
|
/harfbuzz-5.3.1.tar.xz
|
||||||
|
/harfbuzz-6.0.0.tar.xz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-5.3.1/configure.ac harfbuzz-5.3.1-new/configure.ac
|
diff -rupN --no-dereference harfbuzz-6.0.0/configure.ac harfbuzz-6.0.0-new/configure.ac
|
||||||
--- harfbuzz-5.3.1/configure.ac 2022-10-19 22:07:54.000000000 +0200
|
--- harfbuzz-6.0.0/configure.ac 2022-12-16 22:36:15.000000000 +0100
|
||||||
+++ harfbuzz-5.3.1-new/configure.ac 2022-10-20 14:18:02.457749659 +0200
|
+++ harfbuzz-6.0.0-new/configure.ac 2022-12-17 18:16:55.320071949 +0100
|
||||||
@@ -417,6 +417,30 @@ AM_CONDITIONAL(HAVE_CORETEXT, $have_core
|
@@ -417,6 +417,30 @@ AM_CONDITIONAL(HAVE_CORETEXT, $have_core
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
@ -38,10 +38,10 @@ diff -rupN --no-dereference harfbuzz-5.3.1/configure.ac harfbuzz-5.3.1-new/confi
|
|||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN --no-dereference harfbuzz-5.3.1/src/Makefile.am harfbuzz-5.3.1-new/src/Makefile.am
|
diff -rupN --no-dereference harfbuzz-6.0.0/src/Makefile.am harfbuzz-6.0.0-new/src/Makefile.am
|
||||||
--- harfbuzz-5.3.1/src/Makefile.am 2022-10-19 22:07:54.000000000 +0200
|
--- harfbuzz-6.0.0/src/Makefile.am 2022-12-16 22:36:15.000000000 +0100
|
||||||
+++ harfbuzz-5.3.1-new/src/Makefile.am 2022-10-20 14:18:02.458749659 +0200
|
+++ harfbuzz-6.0.0-new/src/Makefile.am 2022-12-17 18:16:55.321071949 +0100
|
||||||
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -53,8 +53,23 @@ HB_HAS_GLIB_DEF = undef HB_HAS_GLIB
|
||||||
endif
|
endif
|
||||||
|
|
||||||
if HAVE_FREETYPE
|
if HAVE_FREETYPE
|
||||||
@ -66,7 +66,7 @@ diff -rupN --no-dereference harfbuzz-5.3.1/src/Makefile.am harfbuzz-5.3.1-new/sr
|
|||||||
HBDEPS += $(FREETYPE_DEPS)
|
HBDEPS += $(FREETYPE_DEPS)
|
||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
@@ -138,9 +153,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -159,9 +174,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-5.3.1/src/gen-def.py harfbuzz-5.3.1-new/src/gen-def.py
|
diff -rupN --no-dereference harfbuzz-6.0.0/src/gen-def.py harfbuzz-6.0.0-new/src/gen-def.py
|
||||||
--- harfbuzz-5.3.1/src/gen-def.py 2022-10-19 22:07:54.000000000 +0200
|
--- harfbuzz-6.0.0/src/gen-def.py 2022-12-16 22:36:15.000000000 +0100
|
||||||
+++ harfbuzz-5.3.1-new/src/gen-def.py 2022-10-20 14:18:02.726749643 +0200
|
+++ harfbuzz-6.0.0-new/src/gen-def.py 2022-12-17 18:16:55.596071955 +0100
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python3
|
-#!/usr/bin/env python3
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 5.3.1
|
Version: 6.0.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
@ -145,6 +145,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 17 2022 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
|
||||||
|
- Update to 6.0.0
|
||||||
|
|
||||||
* Thu Oct 20 2022 Sandro Mani <manisandro@gmail.com> - 5.3.1-1
|
* Thu Oct 20 2022 Sandro Mani <manisandro@gmail.com> - 5.3.1-1
|
||||||
- Update to 5.3.1
|
- Update to 5.3.1
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-5.3.1.tar.xz) = 6b0aef2b7445f4a71c324b545414114507d8077dc186366f25140dcd3bedeee67868cfc65c0eef59ed950381a4c101a541900be4995f645377c11754b027b501
|
SHA512 (harfbuzz-6.0.0.tar.xz) = 66f8484586b1b334479d739df1d1107172715ce1d2a3c0105375174fa3e201fd69ceb1543c10d6db49b012912e823befc701f00621f7b5f68036eced80d36f65
|
||||||
|
Loading…
Reference in New Issue
Block a user