Update to 2.7.1
This commit is contained in:
parent
d1a71de3f8
commit
5cb3a85536
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@
|
|||||||
/harfbuzz-2.6.6.tar.xz
|
/harfbuzz-2.6.6.tar.xz
|
||||||
/harfbuzz-2.6.7.tar.xz
|
/harfbuzz-2.6.7.tar.xz
|
||||||
/harfbuzz-2.6.8.tar.xz
|
/harfbuzz-2.6.8.tar.xz
|
||||||
|
/harfbuzz-2.7.1.tar.xz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-2.6.8/configure.ac harfbuzz-2.6.8-new/configure.ac
|
diff -rupN --no-dereference harfbuzz-2.7.1/configure.ac harfbuzz-2.7.1-new/configure.ac
|
||||||
--- harfbuzz-2.6.8/configure.ac 2020-06-22 11:08:02.000000000 +0200
|
--- harfbuzz-2.7.1/configure.ac 2020-08-13 18:26:05.000000000 +0200
|
||||||
+++ harfbuzz-2.6.8-new/configure.ac 2020-06-23 09:39:51.396512692 +0200
|
+++ harfbuzz-2.7.1-new/configure.ac 2020-08-21 15:18:48.504983303 +0200
|
||||||
@@ -484,6 +484,30 @@ fi
|
@@ -475,6 +475,30 @@ fi
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
|
|
||||||
@ -32,15 +32,15 @@ diff -rupN --no-dereference harfbuzz-2.6.8/configure.ac harfbuzz-2.6.8-new/confi
|
|||||||
AC_CONFIG_FILES([
|
AC_CONFIG_FILES([
|
||||||
Makefile
|
Makefile
|
||||||
src/Makefile
|
src/Makefile
|
||||||
@@ -550,4 +574,5 @@ Other features:
|
@@ -538,4 +562,5 @@ Other features:
|
||||||
Documentation: ${enable_gtk_doc}
|
Documentation: ${enable_gtk_doc}
|
||||||
GObject bindings: ${have_gobject}
|
GObject bindings: ${have_gobject}
|
||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN --no-dereference harfbuzz-2.6.8/src/Makefile.am harfbuzz-2.6.8-new/src/Makefile.am
|
diff -rupN --no-dereference harfbuzz-2.7.1/src/Makefile.am harfbuzz-2.7.1-new/src/Makefile.am
|
||||||
--- harfbuzz-2.6.8/src/Makefile.am 2020-06-16 03:14:32.000000000 +0200
|
--- harfbuzz-2.7.1/src/Makefile.am 2020-08-13 18:26:05.000000000 +0200
|
||||||
+++ harfbuzz-2.6.8-new/src/Makefile.am 2020-06-23 09:39:51.397512690 +0200
|
+++ harfbuzz-2.7.1-new/src/Makefile.am 2020-08-21 15:18:48.505983867 +0200
|
||||||
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
@@ -50,8 +50,23 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -66,7 +66,7 @@ diff -rupN --no-dereference harfbuzz-2.6.8/src/Makefile.am harfbuzz-2.6.8-new/sr
|
|||||||
HBDEPS += $(FREETYPE_DEPS)
|
HBDEPS += $(FREETYPE_DEPS)
|
||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
@@ -133,9 +148,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -138,9 +153,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-2.6.8/src/gen-def.py harfbuzz-2.6.8-new/src/gen-def.py
|
diff -rupN --no-dereference harfbuzz-2.7.1/src/gen-def.py harfbuzz-2.7.1-new/src/gen-def.py
|
||||||
--- harfbuzz-2.6.8/src/gen-def.py 2020-06-18 07:28:41.000000000 +0200
|
--- harfbuzz-2.7.1/src/gen-def.py 2020-08-11 10:44:44.000000000 +0200
|
||||||
+++ harfbuzz-2.6.8-new/src/gen-def.py 2020-06-23 09:39:51.522512380 +0200
|
+++ harfbuzz-2.7.1-new/src/gen-def.py 2020-08-21 15:18:48.673077973 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python3
|
-#!/usr/bin/env python3
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 2.6.8
|
Version: 2.7.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 21 2020 Sandro Mani <manisandro@gmail.com> - 2.7.1-1
|
||||||
|
- Update to 2.7.1
|
||||||
|
|
||||||
* Wed Aug 12 13:40:57 GMT 2020 Sandro Mani <manisandro@gmail.com> - 2.6.8-3
|
* Wed Aug 12 13:40:57 GMT 2020 Sandro Mani <manisandro@gmail.com> - 2.6.8-3
|
||||||
- Rebuild (mingw-gettext)
|
- Rebuild (mingw-gettext)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-2.6.8.tar.xz) = 651b23d7d4fab6fef472ee57db39bbaebc31c2f40ea3a482c1499ad1a7b549b86a2bccbe9da191c8e9ecdf464191dd3c9a7485546b51695ad8ab3c0329732d9d
|
SHA512 (harfbuzz-2.7.1.tar.xz) = 9a89e44b228c334b1bdeff9b712a0d8122b23a89e76b7d9877c37103f11f90b2924b79bf89450879ec9870d84c0cccdcc967646924e049b1ff2013b0817c61a9
|
||||||
|
Loading…
Reference in New Issue
Block a user