Update to 8.0.1
This commit is contained in:
parent
b4653480ac
commit
5b1ae24f28
1
.gitignore
vendored
1
.gitignore
vendored
@ -78,3 +78,4 @@
|
|||||||
/harfbuzz-7.1.0.tar.xz
|
/harfbuzz-7.1.0.tar.xz
|
||||||
/harfbuzz-7.2.0.tar.xz
|
/harfbuzz-7.2.0.tar.xz
|
||||||
/harfbuzz-7.3.0.tar.xz
|
/harfbuzz-7.3.0.tar.xz
|
||||||
|
/harfbuzz-8.0.1.tar.xz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-7.3.0/configure.ac harfbuzz-7.3.0-new/configure.ac
|
diff -rupN --no-dereference harfbuzz-8.0.1/configure.ac harfbuzz-8.0.1-new/configure.ac
|
||||||
--- harfbuzz-7.3.0/configure.ac 2023-05-09 23:21:30.000000000 +0200
|
--- harfbuzz-8.0.1/configure.ac 2023-07-12 07:28:28.000000000 +0200
|
||||||
+++ harfbuzz-7.3.0-new/configure.ac 2023-05-11 07:05:56.821869470 +0200
|
+++ harfbuzz-8.0.1-new/configure.ac 2023-07-18 08:11:31.358239617 +0200
|
||||||
@@ -417,6 +417,30 @@ AM_CONDITIONAL(HAVE_CORETEXT, $have_core
|
@@ -439,6 +439,30 @@ AM_CONDITIONAL(HAVE_WASM, $have_wasm)
|
||||||
|
|
||||||
dnl ===========================================================================
|
dnl ===========================================================================
|
||||||
|
|
||||||
@ -32,15 +32,15 @@ diff -rupN --no-dereference harfbuzz-7.3.0/configure.ac harfbuzz-7.3.0-new/confi
|
|||||||
AC_CONFIG_FILES([
|
AC_CONFIG_FILES([
|
||||||
Makefile
|
Makefile
|
||||||
src/Makefile
|
src/Makefile
|
||||||
@@ -483,4 +507,5 @@ Other features:
|
@@ -506,4 +530,5 @@ Other features:
|
||||||
Documentation: ${enable_gtk_doc}
|
Documentation: ${enable_gtk_doc}
|
||||||
GObject bindings: ${have_gobject}
|
GObject bindings: ${have_gobject}
|
||||||
Introspection: ${have_introspection}
|
Introspection: ${have_introspection}
|
||||||
+ Enable delay loading: ${enable_delay_load}
|
+ Enable delay loading: ${enable_delay_load}
|
||||||
])
|
])
|
||||||
diff -rupN --no-dereference harfbuzz-7.3.0/src/Makefile.am harfbuzz-7.3.0-new/src/Makefile.am
|
diff -rupN --no-dereference harfbuzz-8.0.1/src/Makefile.am harfbuzz-8.0.1-new/src/Makefile.am
|
||||||
--- harfbuzz-7.3.0/src/Makefile.am 2023-05-09 23:21:30.000000000 +0200
|
--- harfbuzz-8.0.1/src/Makefile.am 2023-07-12 07:28:28.000000000 +0200
|
||||||
+++ harfbuzz-7.3.0-new/src/Makefile.am 2023-05-11 07:05:56.822869473 +0200
|
+++ harfbuzz-8.0.1-new/src/Makefile.am 2023-07-18 08:11:31.359239659 +0200
|
||||||
@@ -53,8 +53,23 @@ HB_HAS_GLIB_DEF = undef HB_HAS_GLIB
|
@@ -53,8 +53,23 @@ HB_HAS_GLIB_DEF = undef HB_HAS_GLIB
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -66,7 +66,7 @@ diff -rupN --no-dereference harfbuzz-7.3.0/src/Makefile.am harfbuzz-7.3.0-new/sr
|
|||||||
HBDEPS += $(FREETYPE_DEPS)
|
HBDEPS += $(FREETYPE_DEPS)
|
||||||
HBSOURCES += $(HB_FT_sources)
|
HBSOURCES += $(HB_FT_sources)
|
||||||
HBHEADERS += $(HB_FT_headers)
|
HBHEADERS += $(HB_FT_headers)
|
||||||
@@ -161,9 +176,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
@@ -171,9 +186,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference harfbuzz-7.3.0/src/gen-def.py harfbuzz-7.3.0-new/src/gen-def.py
|
diff -rupN --no-dereference harfbuzz-8.0.1/src/gen-def.py harfbuzz-8.0.1-new/src/gen-def.py
|
||||||
--- harfbuzz-7.3.0/src/gen-def.py 2023-05-09 23:21:30.000000000 +0200
|
--- harfbuzz-8.0.1/src/gen-def.py 2023-07-12 07:28:28.000000000 +0200
|
||||||
+++ harfbuzz-7.3.0-new/src/gen-def.py 2023-05-11 07:05:57.092870287 +0200
|
+++ harfbuzz-8.0.1-new/src/gen-def.py 2023-07-18 08:11:31.594249408 +0200
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/env python3
|
-#!/usr/bin/env python3
|
||||||
+#!/usr/bin/python3
|
+#!/usr/bin/python3
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%{?mingw_package_header}
|
%{?mingw_package_header}
|
||||||
|
|
||||||
Name: mingw-harfbuzz
|
Name: mingw-harfbuzz
|
||||||
Version: 7.3.0
|
Version: 8.0.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: MinGW Windows Harfbuzz library
|
Summary: MinGW Windows Harfbuzz library
|
||||||
|
|
||||||
@ -155,6 +155,9 @@ find %{buildroot} -name "*.la" -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 18 2023 Sandro Mani <manisandro@gmail.com> - 8.0.1-1
|
||||||
|
- Update to 8.0.1
|
||||||
|
|
||||||
* Thu May 11 2023 Sandro Mani <manisandro@gmail.com> - 7.3.0-1
|
* Thu May 11 2023 Sandro Mani <manisandro@gmail.com> - 7.3.0-1
|
||||||
- Update to 7.3.0
|
- Update to 7.3.0
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (harfbuzz-7.3.0.tar.xz) = e1fb484e4117cedc72bd473ee91b2f6143533fb467ec9a64361f0c7ffd8b5a44ad2ea42daa948a2d5d85297ace4b640fcd24a8291b0d75a1d4ee468c629febe9
|
SHA512 (harfbuzz-8.0.1.tar.xz) = e1292f059b07a5aa2f3fbf345b893209cac895c461b4abf30b8b76bcd03c79dd09f911450293403070e1a0bb08496a7f37693ba5a62a9d423dd6ba55e744444d
|
||||||
|
Loading…
Reference in New Issue
Block a user