RHEL 9.0.0 Alpha bootstrap

The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/mingw-gcc#f4a998837a222adac95005941d27013927232ffa
This commit is contained in:
Petr Šabata 2020-10-15 19:44:19 +02:00
parent aa108c86a7
commit 0ff061e08a
4 changed files with 1153 additions and 0 deletions

41
.gitignore vendored
View File

@ -0,0 +1,41 @@
gcc-4.5.1.tar.bz2
/gcc-4.5.3.tar.bz2
/gcc-4.6.1.tar.bz2
/gcc-4.7.0-20120106.tar.bz2
/gcc-4.7.0-20120126.tar.bz2
/gcc-4.7.0-20120224.tar.bz2
/gcc-4.7.0-20120322.tar.bz2
/gcc-4.7.0.tar.bz2
/gcc-4.7.1.tar.bz2
/gcc-4.7.2.tar.bz2
/gcc-4.8-20130120.tar.bz2
/gcc-4.8-20130203.tar.bz2
/gcc-4.8-20130310.tar.bz2
/gcc-4.8.0.tar.bz2
/gcc-4.8.1.tar.bz2
/gcc-4.8.2.tar.bz2
/gcc-4.9.0-RC-20140411.tar.bz2
/gcc-4.9.0.tar.bz2
/gcc-4.9.1.tar.bz2
/gcc-4.9.2.tar.bz2
/gcc-5-20150301.tar.bz2
/gcc-5-20150322.tar.bz2
/gcc-5-20150405.tar.bz2
/gcc-5.1.0.tar.bz2
/gcc-5.2.0.tar.bz2
/gcc-5.3.0.tar.bz2
/gcc-6-20160131.tar.bz2
/gcc-6-20160320.tar.bz2
/gcc-6.1.0.tar.bz2
/gcc-6.2.0.tar.bz2
/gcc-6.3.0.tar.bz2
/gcc-7-20170212.tar.bz2
/gcc-7.1.0.tar.bz2
/gcc-7.2.0.tar.xz
/gcc-8.1.0.tar.xz
/gcc-8.2.0.tar.xz
/gcc-8.3.0.tar.xz
/gcc-9.1.1-20190503.tar.xz
/gcc-9.2.1-20190827.tar.xz
/gcc-10.1.1-20200618.tar.xz
/gcc-10.2.1-20200723.tar.xz

42
mingw-gcc-config.patch Normal file
View File

@ -0,0 +1,42 @@
diff -rupN --no-dereference gcc-10.2.1-20200723/config/intdiv0.m4 gcc-10.2.1-20200723-new/config/intdiv0.m4
--- gcc-10.2.1-20200723/config/intdiv0.m4 2020-07-23 11:18:20.000000000 +0200
+++ gcc-10.2.1-20200723-new/config/intdiv0.m4 2020-07-23 18:21:10.151598317 +0200
@@ -31,10 +31,10 @@ sigfpe_handler (sig) int sig;
exit (sig != SIGFPE);
}
-int x = 1;
-int y = 0;
-int z;
-int nan;
+volatile int x = 1;
+volatile int y = 0;
+volatile int z;
+volatile int nan;
int main ()
{
diff -rupN --no-dereference gcc-10.2.1-20200723/libiberty/aclocal.m4 gcc-10.2.1-20200723-new/libiberty/aclocal.m4
--- gcc-10.2.1-20200723/libiberty/aclocal.m4 2020-07-23 11:18:20.000000000 +0200
+++ gcc-10.2.1-20200723-new/libiberty/aclocal.m4 2020-07-23 18:21:10.150598319 +0200
@@ -149,7 +149,7 @@ if test $ac_cv_os_cray = yes; then
fi
AC_CACHE_CHECK(stack direction for C alloca, ac_cv_c_stack_direction,
-[AC_TRY_RUN([find_stack_direction ()
+[AC_TRY_RUN([__attribute__ ((noclone,noinline)) find_stack_direction ()
{
static char *addr = 0;
auto char dummy;
diff -rupN --no-dereference gcc-10.2.1-20200723/libiberty/configure.ac gcc-10.2.1-20200723-new/libiberty/configure.ac
--- gcc-10.2.1-20200723/libiberty/configure.ac 2020-07-23 11:18:20.000000000 +0200
+++ gcc-10.2.1-20200723-new/libiberty/configure.ac 2020-07-23 18:21:10.151598317 +0200
@@ -664,7 +664,7 @@ if test -z "${setobjs}"; then
for v in $vars; do
AC_MSG_CHECKING([for $v])
AC_CACHE_VAL(libiberty_cv_var_$v,
- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[int *p;]],[[extern int $v []; p = $v;]])],
+ [AC_LINK_IFELSE([AC_LANG_PROGRAM([[__attribute__ ((used)) int *p;]],[[extern int $v []; p = $v;]])],
[eval "libiberty_cv_var_$v=yes"],
[eval "libiberty_cv_var_$v=no"])])
if eval "test \"`echo '$libiberty_cv_var_'$v`\" = yes"; then

1069
mingw-gcc.spec Normal file

File diff suppressed because it is too large Load Diff

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (gcc-10.2.1-20200723.tar.xz) = e1719e4a18f43bb76acb91c0d768711e78d7e8c478b72e691911094e233570597997ed108ba7ed4fb136542993af935ea38ec462a1972689c9220d4cc0e2933f