Update to 2.6
- Sync patches with the native package
This commit is contained in:
parent
212ca6b793
commit
7071176d0b
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ freetype-doc-2.3.11.tar.gz
|
||||
/freetype-2.5.0.1.tar.bz2
|
||||
/freetype-2.5.3.tar.bz2
|
||||
/freetype-2.5.4.tar.bz2
|
||||
/freetype-2.6.tar.bz2
|
||||
|
26
0001-cff-Don-t-use-hmtx-table-for-LSB-45520.patch
Normal file
26
0001-cff-Don-t-use-hmtx-table-for-LSB-45520.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From b650dfbb0b0700440cc88da31f97cec45b4140de Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <matthias.clasen@gmail.com>
|
||||
Date: Sun, 26 Jul 2015 21:08:34 +0200
|
||||
Subject: [PATCH] [cff] Don't use `hmtx' table for LSB (#45520).
|
||||
|
||||
* src/cff/cffgload.c (cff_slot_load): Use `htmx' table for advance
|
||||
width only. Bug introduced 2015-04-10.
|
||||
|
||||
diff --git a/src/cff/cffgload.c b/src/cff/cffgload.c
|
||||
index 43054f8..a075ddc 100644
|
||||
--- a/src/cff/cffgload.c
|
||||
+++ b/src/cff/cffgload.c
|
||||
@@ -3064,9 +3064,7 @@
|
||||
metrics->width = cbox.xMax - cbox.xMin;
|
||||
metrics->height = cbox.yMax - cbox.yMin;
|
||||
|
||||
- if ( !face->horizontal.number_Of_HMetrics )
|
||||
- metrics->horiBearingX = cbox.xMin;
|
||||
-
|
||||
+ metrics->horiBearingX = cbox.xMin;
|
||||
metrics->horiBearingY = cbox.yMax;
|
||||
|
||||
if ( has_vertical_info )
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- freetype-2.5.3/include/config/ftoption.h.spf 2014-07-10 12:38:17.838824142 +0200
|
||||
+++ freetype-2.5.3/include/config/ftoption.h 2014-07-10 12:38:28.001931982 +0200
|
||||
--- freetype-2.3.0/include/config/ftoption.h.spf 2007-01-18 14:27:34.000000000 -0500
|
||||
+++ freetype-2.3.0/include/config/ftoption.h 2007-01-18 14:27:48.000000000 -0500
|
||||
@@ -92,7 +92,7 @@
|
||||
/* This is done to allow FreeType clients to run unmodified, forcing */
|
||||
/* them to display normal gray-level anti-aliased glyphs. */
|
@ -1,18 +0,0 @@
|
||||
diff -up ft2demos-2.3.11/Makefile.more-demos freetype-2.3.11/ft2demos-2.3.11/Makefile
|
||||
--- ft2demos-2.3.11/Makefile.more-demos 2009-10-22 16:02:26.000000000 -0400
|
||||
+++ ft2demos-2.3.11/Makefile 2009-10-22 16:02:32.000000000 -0400
|
||||
@@ -288,10 +288,10 @@ else
|
||||
# Note that ttdebug only works if the FreeType's `truetype' driver has
|
||||
# been compiled with TT_CONFIG_OPTION_BYTECODE_INTERPRETER defined.
|
||||
#
|
||||
- # EXES += ftchkwd
|
||||
- # EXES += ftmemchk
|
||||
- # EXES += ftpatchk
|
||||
- # EXES += fttimer
|
||||
+ EXES += ftchkwd
|
||||
+ EXES += ftmemchk
|
||||
+ EXES += ftpatchk
|
||||
+ EXES += fttimer
|
||||
# EXES += testname
|
||||
# EXES += ttdebug
|
||||
|
@ -5,8 +5,8 @@
|
||||
%{!?_with_subpixel_rendering: %{!?_without_subpixel_rendering: %define _without_subpixel_rendering --without-subpixel_rendering}}
|
||||
|
||||
Name: mingw-freetype
|
||||
Version: 2.5.4
|
||||
Release: 2%{?dist}
|
||||
Version: 2.6
|
||||
Release: 1%{?dist}
|
||||
Summary: Free and portable font rendering engine
|
||||
|
||||
License: FTL or GPLv2+
|
||||
@ -15,9 +15,9 @@ Source0: http://download.savannah.gnu.org/releases/freetype/freetype-%{ve
|
||||
Group: Development/Libraries
|
||||
|
||||
# Patches from native Fedora package.
|
||||
Patch21: freetype-2.5.3-enable-spr.patch
|
||||
Patch0: 0001-cff-Don-t-use-hmtx-table-for-LSB-45520.patch
|
||||
Patch21: freetype-2.3.0-enable-spr.patch
|
||||
Patch46: freetype-2.2.1-enable-valid.patch
|
||||
#Patch47: freetype-2.3.11-more-demos.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -76,12 +76,13 @@ Static version of the MinGW Windows Freetype library.
|
||||
%prep
|
||||
%setup -q -n freetype-%{version}
|
||||
|
||||
%patch0 -p1 -b .hmtx-table
|
||||
|
||||
%if %{?_with_subpixel_rendering:1}%{!?_with_subpixel_rendering:0}
|
||||
%patch21 -p1 -b .enable-spr
|
||||
%endif
|
||||
|
||||
%patch46 -p1 -b .enable-valid
|
||||
#%patch47 -p1 -b .more-demos
|
||||
|
||||
|
||||
%build
|
||||
@ -132,6 +133,10 @@ rm -rf $RPM_BUILD_ROOT%{mingw32_mandir} $RPM_BUILD_ROOT%{mingw64_mandir}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 23 2015 Kalev Lember <klember@redhat.com> - 2.6-1
|
||||
- Update to 2.6
|
||||
- Sync patches with the native package
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user