From f185f589850ad3056f8bb7ea85de812891f5e91e Mon Sep 17 00:00:00 2001
From: Erik van Pienbroek <epienbro@fedoraproject.org>
Date: Fri, 10 Apr 2015 20:48:34 +0200
Subject: [PATCH] Don't use verbose output by default in the CMake wrapper
 scripts

---
 mingw-filesystem.spec | 2 ++
 mingw-scripts.sh      | 2 +-
 2 files changed, 3 insertions(+), 1 deletion(-)

diff --git a/mingw-filesystem.spec b/mingw-filesystem.spec
index c752d93..cbba17d 100644
--- a/mingw-filesystem.spec
+++ b/mingw-filesystem.spec
@@ -322,6 +322,8 @@ install -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/mingw/
   * Removed the rpath references as mingw doesn't support rpath
   * Allow verbose CMake output to be disabled by setting the
     environment variable MINGW_CMAKE_NO_VERBOSE (RHBZ #987644)
+  * When calling the mingw32-cmake and mingw64-cmake wrapper
+    scripts don't use verbose CMake output by default
 
 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
diff --git a/mingw-scripts.sh b/mingw-scripts.sh
index 53bd44d..a748fcf 100755
--- a/mingw-scripts.sh
+++ b/mingw-scripts.sh
@@ -33,4 +33,4 @@ fi
 # NOTE: The use of 'eval' in combination with '$@' is a potential security risk
 #       We should find a more safe replacement for this command
 #       Suggestions are welcome at the Fedora MinGW mailing list
-eval "`rpm --eval "%{$NAME}"`" '"$@"'
+eval "MINGW_CMAKE_NO_VERBOSE=1 `rpm --eval "%{$NAME}"`" '"$@"'