Initial import.
This commit is contained in:
parent
cfcc0043d0
commit
b062ec87ff
@ -0,0 +1 @@
|
||||
bzip2-1.0.5.tar.gz
|
12
bzip2-1.0.4-bzip2recover.patch
Normal file
12
bzip2-1.0.4-bzip2recover.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- bzip2-1.0.4/bzip2recover.c.pom 2007-01-03 03:00:55.000000000 +0100
|
||||
+++ bzip2-1.0.4/bzip2recover.c 2007-02-05 11:55:17.000000000 +0100
|
||||
@@ -309,7 +309,8 @@
|
||||
UInt32 buffHi, buffLo, blockCRC;
|
||||
Char* p;
|
||||
|
||||
- strcpy ( progName, argv[0] );
|
||||
+ strncpy ( progName, argv[0], BZ_MAX_FILENAME-1);
|
||||
+ progName[BZ_MAX_FILENAME-1]='\0';
|
||||
inFileName[0] = outFileName[0] = 0;
|
||||
|
||||
fprintf ( stderr,
|
11
bzip2-1.0.4-cflags.patch
Normal file
11
bzip2-1.0.4-cflags.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bzip2-1.0.4/Makefile-libbz2_so.cflags 2007-01-08 09:47:27.000000000 +0100
|
||||
+++ bzip2-1.0.4/Makefile-libbz2_so 2007-01-08 09:48:47.000000000 +0100
|
||||
@@ -35,7 +35,7 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
+ $(CC) $(CFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
rm -f libbz2.so.1.0
|
||||
ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
11
bzip2-1.0.4-saneso.patch
Normal file
11
bzip2-1.0.4-saneso.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bzip2-1.0.4/Makefile-libbz2_so.senaso 2007-01-03 03:00:55.000000000 +0100
|
||||
+++ bzip2-1.0.4/Makefile-libbz2_so 2007-01-08 09:12:42.000000000 +0100
|
||||
@@ -35,7 +35,7 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.4 $(OBJS)
|
||||
+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
rm -f libbz2.so.1.0
|
||||
ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
||||
mingw32-bzip2-1_0_5-5_fc10:HEAD:mingw32-bzip2-1.0.5-5.fc10.src.rpm:1229857848
|
15
mingw32-bzip2-1.0.5-dll.patch
Normal file
15
mingw32-bzip2-1.0.5-dll.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- bzip2-1.0.5/Makefile-libbz2_so 2008-09-25 12:52:11.000000000 +0100
|
||||
+++ bzip2-1.0.5.dll/Makefile-libbz2_so 2008-09-25 12:59:22.000000000 +0100
|
||||
@@ -35,10 +35,8 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) $(CFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
- rm -f libbz2.so.1.0
|
||||
- ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
||||
+ $(CC) $(CFLAGS) -shared -Wl,--out-implib -Wl,bz2.dll.a -Wl,-soname -Wl,bz2-1.dll -o bz2-1.dll $(OBJS)
|
||||
+ $(CC) $(CFLAGS) -o bzip2-shared bzip2.c bz2-1.dll
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) bzip2.o libbz2.so.1.0.4 libbz2.so.1.0 bzip2-shared
|
11
mingw32-bzip2-1.0.5-slash.patch
Normal file
11
mingw32-bzip2-1.0.5-slash.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bzip2-1.0.5.orig/bzip2.c 2007-12-09 12:22:06.000000000 +0000
|
||||
+++ bzip2-1.0.5/bzip2.c 2008-09-25 12:31:02.000000000 +0100
|
||||
@@ -128,7 +128,7 @@
|
||||
#if BZ_LCCWIN32
|
||||
# include <io.h>
|
||||
# include <fcntl.h>
|
||||
-# include <sys\stat.h>
|
||||
+# include <sys/stat.h>
|
||||
|
||||
# define NORETURN /**/
|
||||
# define PATH_SEP '\\'
|
153
mingw32-bzip2.spec
Normal file
153
mingw32-bzip2.spec
Normal file
@ -0,0 +1,153 @@
|
||||
%define __strip %{_mingw32_strip}
|
||||
%define __objdump %{_mingw32_objdump}
|
||||
%define _use_internal_dependency_generator 0
|
||||
%define __find_requires %{_mingw32_findrequires}
|
||||
%define __find_provides %{_mingw32_findprovides}
|
||||
|
||||
%define library_version 1.0.4
|
||||
|
||||
# Running the tests requires Wine.
|
||||
%define run_tests 0
|
||||
|
||||
Name: mingw32-bzip2
|
||||
Version: 1.0.5
|
||||
Release: 5%{?dist}
|
||||
Summary: MinGW port of bzip2 file compression utility
|
||||
|
||||
License: BSD
|
||||
Group: Development/Libraries
|
||||
URL: http://www.bzip.org/
|
||||
Source0: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
Patch0: bzip2-1.0.4-saneso.patch
|
||||
Patch5: bzip2-1.0.4-cflags.patch
|
||||
Patch6: bzip2-1.0.4-bzip2recover.patch
|
||||
|
||||
Patch10: mingw32-bzip2-1.0.5-slash.patch
|
||||
Patch11: mingw32-bzip2-1.0.5-dll.patch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 26
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw32-binutils
|
||||
|
||||
%if %{run_tests}
|
||||
BuildRequires: wine
|
||||
%endif
|
||||
|
||||
|
||||
%description
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
Bzip2 compresses files to within 10 to 15 percent of the capabilities
|
||||
of the best techniques available. However, bzip2 has the added benefit
|
||||
of being approximately two times faster at compression and six times
|
||||
faster at decompression than those techniques. Bzip2 is not the
|
||||
fastest compression utility, but it does strike a balance between speed
|
||||
and compression capability.
|
||||
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n bzip2-%{version}
|
||||
|
||||
%patch0 -p1 -b .saneso
|
||||
%patch5 -p1 -b .cflags
|
||||
%patch6 -p1 -b .bz2recover
|
||||
|
||||
%patch10 -p1 -b .slash
|
||||
%patch11 -p1 -b .dll
|
||||
|
||||
|
||||
%build
|
||||
make -f Makefile-libbz2_so \
|
||||
CC="%{_mingw32_cc}" \
|
||||
AR="%{_mingw32_ar}" \
|
||||
RANLIB="%{_mingw32_ranlib}" \
|
||||
CFLAGS="%{_mingw32_cflags} -D_FILE_OFFSET_BITS=64" \
|
||||
%{?_smp_mflags} all
|
||||
|
||||
rm -f *.o
|
||||
make CC="%{_mingw32_cc}" \
|
||||
AR="%{_mingw32_ar}" \
|
||||
RANLIB="%{_mingw32_ranlib}" \
|
||||
CFLAGS="%{_mingw32_cflags} -D_FILE_OFFSET_BITS=64" \
|
||||
%{?_smp_mflags} \
|
||||
%if %{run_tests}
|
||||
all
|
||||
%else
|
||||
libbz2.a bzip2 bzip2recover
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make PREFIX=$RPM_BUILD_ROOT%{_mingw32_prefix} install
|
||||
|
||||
# The binaries which are symlinks contain the full buildroot
|
||||
# name in the symlink, so replace those.
|
||||
pushd $RPM_BUILD_ROOT%{_mingw32_bindir}
|
||||
rm bzcmp bzegrep bzfgrep bzless
|
||||
ln -s bzdiff bzcmp
|
||||
ln -s bzgrep bzegrep
|
||||
ln -s bzgrep bzfgrep
|
||||
ln -s bzmore bzless
|
||||
popd
|
||||
|
||||
# Remove the manpages, they're duplicates of the native package,
|
||||
# and located in the wrong place anyway.
|
||||
rm -rf $RPM_BUILD_ROOT%{_mingw32_prefix}/man
|
||||
|
||||
# The Makefile doesn't install the DLL.
|
||||
# Rename the library so that libtool can find it.
|
||||
install bz2.dll.a $RPM_BUILD_ROOT%{_mingw32_libdir}/libbz2.dll.a
|
||||
install bz2-1.dll $RPM_BUILD_ROOT%{_mingw32_bindir}/
|
||||
|
||||
# Remove the static library.
|
||||
rm $RPM_BUILD_ROOT%{_mingw32_libdir}/libbz2.a
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc LICENSE
|
||||
|
||||
%{_mingw32_bindir}/bz2-1.dll
|
||||
%{_mingw32_libdir}/libbz2.dll.a
|
||||
|
||||
%{_mingw32_bindir}/bunzip2
|
||||
%{_mingw32_bindir}/bzcat
|
||||
%{_mingw32_bindir}/bzcmp
|
||||
%{_mingw32_bindir}/bzdiff
|
||||
%{_mingw32_bindir}/bzegrep
|
||||
%{_mingw32_bindir}/bzfgrep
|
||||
%{_mingw32_bindir}/bzgrep
|
||||
%{_mingw32_bindir}/bzip2
|
||||
%{_mingw32_bindir}/bzip2recover
|
||||
%{_mingw32_bindir}/bzless
|
||||
%{_mingw32_bindir}/bzmore
|
||||
|
||||
%{_mingw32_includedir}/bzlib.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 18 2008 Richard Jones <rjones@redhat.com> - 1.0.5-5
|
||||
- Include the LICENSE file in doc section.
|
||||
|
||||
* Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 1.0.5-4
|
||||
- Rename the implib as libbz2.dll.a so that libtool can find it.
|
||||
|
||||
* Wed Oct 29 2008 Richard Jones <rjones@redhat.com> - 1.0.5-3
|
||||
- Fix mixed spaces/tabs in specfile.
|
||||
|
||||
* Fri Oct 10 2008 Richard Jones <rjones@redhat.com> - 1.0.5-2
|
||||
- Allow the tests to be disabled selectively.
|
||||
|
||||
* Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 1.0.5-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user