New upstream version 1.0.8
This commit is contained in:
parent
fd22f65c5f
commit
8fd0fcbd0a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
bzip2-1.0.5.tar.gz
|
||||
/bzip2-1.0.6.tar.gz
|
||||
/bzip2-1.0.8.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- bzip2-1.0.4/bzip2recover.c.pom 2007-01-03 03:00:55.000000000 +0100
|
||||
+++ bzip2-1.0.4/bzip2recover.c 2007-02-05 11:55:17.000000000 +0100
|
||||
@@ -309,7 +309,8 @@
|
||||
UInt32 buffHi, buffLo, blockCRC;
|
||||
Char* p;
|
||||
|
||||
- strcpy ( progName, argv[0] );
|
||||
+ strncpy ( progName, argv[0], BZ_MAX_FILENAME-1);
|
||||
+ progName[BZ_MAX_FILENAME-1]='\0';
|
||||
inFileName[0] = outFileName[0] = 0;
|
||||
|
||||
fprintf ( stderr,
|
@ -61,7 +61,7 @@ diff -urN bzip2-1.0.5.orig/configure.ac bzip2-1.0.5.autoconfiscated/configure.ac
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.57])
|
||||
+AC_INIT([bzip2], [1.0.5], [Julian Seward <jseward@bzip.org>])
|
||||
+AC_INIT([bzip2], [1.0.8], [Julian Seward <jseward@bzip.org>])
|
||||
+BZIP2_LT_CURRENT=1
|
||||
+BZIP2_LT_REVISION=5
|
||||
+BZIP2_LT_AGE=0
|
||||
|
@ -1,8 +1,8 @@
|
||||
%?mingw_package_header
|
||||
|
||||
Name: mingw-bzip2
|
||||
Version: 1.0.6
|
||||
Release: 13%{?dist}
|
||||
Version: 1.0.8
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW port of bzip2 file compression utility
|
||||
|
||||
License: BSD
|
||||
@ -11,10 +11,6 @@ Source0: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
Patch6: bzip2-1.0.4-bzip2recover.patch
|
||||
|
||||
Patch10: mingw32-bzip2-1.0.5-slash.patch
|
||||
|
||||
Patch12: bzip2-1.0.5-autoconfiscated.patch
|
||||
|
||||
# Export all symbols using the cdecl calling convention instead of
|
||||
@ -98,10 +94,6 @@ Static library for mingw64-bzip2 development.
|
||||
%prep
|
||||
%setup -q -n bzip2-%{version}
|
||||
|
||||
%patch6 -p1 -b .bz2recover
|
||||
|
||||
%patch10 -p1 -b .slash
|
||||
|
||||
%patch12 -p1 -b .autoconfiscated
|
||||
|
||||
%patch13 -p1 -b .cdecl
|
||||
@ -185,6 +177,9 @@ rm $RPM_BUILD_ROOT%{mingw64_libdir}/libbz2.la
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 13 2019 Marc-André Lureau <marcandre.lureau@redhat.com> - 1.0.8-1
|
||||
- New upstream version 1.0.8
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- bzip2-1.0.5.orig/bzip2.c 2007-12-09 12:22:06.000000000 +0000
|
||||
+++ bzip2-1.0.5/bzip2.c 2008-09-25 12:31:02.000000000 +0100
|
||||
@@ -128,7 +128,7 @@
|
||||
#if BZ_LCCWIN32
|
||||
# include <io.h>
|
||||
# include <fcntl.h>
|
||||
-# include <sys\stat.h>
|
||||
+# include <sys/stat.h>
|
||||
|
||||
# define NORETURN /**/
|
||||
# define PATH_SEP '\\'
|
Loading…
Reference in New Issue
Block a user