import mingw-bzip2-1.0.6-11.el8
This commit is contained in:
commit
612136eaa6
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/bzip2-1.0.6.tar.gz
|
1
.mingw-bzip2.metadata
Normal file
1
.mingw-bzip2.metadata
Normal file
@ -0,0 +1 @@
|
||||
3f89f861209ce81a6bab1fd1998c0ef311712002 SOURCES/bzip2-1.0.6.tar.gz
|
12
SOURCES/bzip2-1.0.4-bzip2recover.patch
Normal file
12
SOURCES/bzip2-1.0.4-bzip2recover.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- bzip2-1.0.4/bzip2recover.c.pom 2007-01-03 03:00:55.000000000 +0100
|
||||
+++ bzip2-1.0.4/bzip2recover.c 2007-02-05 11:55:17.000000000 +0100
|
||||
@@ -309,7 +309,8 @@
|
||||
UInt32 buffHi, buffLo, blockCRC;
|
||||
Char* p;
|
||||
|
||||
- strcpy ( progName, argv[0] );
|
||||
+ strncpy ( progName, argv[0], BZ_MAX_FILENAME-1);
|
||||
+ progName[BZ_MAX_FILENAME-1]='\0';
|
||||
inFileName[0] = outFileName[0] = 0;
|
||||
|
||||
fprintf ( stderr,
|
286
SOURCES/bzip2-1.0.5-autoconfiscated.patch
Normal file
286
SOURCES/bzip2-1.0.5-autoconfiscated.patch
Normal file
@ -0,0 +1,286 @@
|
||||
diff -urN files/autogen.sh ./autogen.sh
|
||||
--- bzip2-1.0.5.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/autogen.sh 2009-11-06 12:10:43.574602171 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+mv LICENSE COPYING
|
||||
+mv CHANGES NEWS
|
||||
+touch AUTHORS
|
||||
+touch ChangeLog
|
||||
+libtoolize --force
|
||||
+aclocal
|
||||
+automake --add-missing --gnu
|
||||
+autoconf
|
||||
diff -urN bzip2-1.0.5.orig/README.autotools bzip2-1.0.5.autoconfiscated/README.autotools
|
||||
--- bzip2-1.0.5.orig/README.autotools 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/README.autotools 2010-11-02 17:04:06.000000000 +0100
|
||||
@@ -0,0 +1,39 @@
|
||||
+bzip2 autoconfiscated
|
||||
+=====================
|
||||
+
|
||||
+Temporarily at http://ftp.suse.com/pub/people/sbrabec/bzip2/ expecting
|
||||
+that it will become a new upstream version to prevent per-distribution
|
||||
+shared library patching done by nearly each Linux vendor separately.
|
||||
+
|
||||
+Autoconfiscation brings standard ./configure ; make ; make install
|
||||
+installation, seamless support of DESTDIR, automatic check for supported
|
||||
+CFLAGS, standard shared library support, automatic large files CFLAGS
|
||||
+check and all things that are supported by automake.
|
||||
+
|
||||
+It makes obsolete Makefile-libbz2_so and README.COMPILATION.PROBLEMS.
|
||||
+Now configure should automatically detect correct build flags.
|
||||
+
|
||||
+In case of any problem or question with autotools support feel free to
|
||||
+contact me: Stanislav Brabec <sbrabec@suse.cz>
|
||||
+
|
||||
+Autoconfiscated version binaries are exactly equal to
|
||||
+bzip2-1.0.5.tar.gz. There are only few changes. See below.
|
||||
+
|
||||
+
|
||||
+New features:
|
||||
+
|
||||
+Trivial link man pages for bzcat and bunzip2 added.
|
||||
+
|
||||
+bzip2.pc file for pkg-config. Packages can use it for checks.
|
||||
+
|
||||
+
|
||||
+Incompatible changes:
|
||||
+
|
||||
+soname change. Libtool has no support for two parts name suffix (e. g.
|
||||
+libbz2.so.1.0). It must be a single number (e. g. libbz2.so.1). That is
|
||||
+why soname must change. But I see not a big problem with it. Several
|
||||
+distributions already use the new number instead of the non-standard
|
||||
+number from Makefile-libbz2_so.
|
||||
+
|
||||
+To be super-safe, I incremented minor number of the library file, so
|
||||
+both instances of the shared library can live together.
|
||||
diff -urN bzip2-1.0.5.orig/configure.ac bzip2-1.0.5.autoconfiscated/configure.ac
|
||||
--- bzip2-1.0.5.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/configure.ac 2009-11-06 17:04:04.000000000 +0100
|
||||
@@ -0,0 +1,70 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.57])
|
||||
+AC_INIT([bzip2], [1.0.5], [Julian Seward <jseward@bzip.org>])
|
||||
+BZIP2_LT_CURRENT=1
|
||||
+BZIP2_LT_REVISION=5
|
||||
+BZIP2_LT_AGE=0
|
||||
+AC_CONFIG_SRCDIR([bzlib.h])
|
||||
+AC_CONFIG_MACRO_DIR([m4])
|
||||
+
|
||||
+AM_INIT_AUTOMAKE
|
||||
+AM_MAINTAINER_MODE
|
||||
+
|
||||
+# Checks for programs.
|
||||
+AC_PROG_AWK
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_INSTALL
|
||||
+AC_PROG_LN_S
|
||||
+AC_PROG_MAKE_SET
|
||||
+AC_PROG_LIBTOOL
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+
|
||||
+# Checks for header files.
|
||||
+
|
||||
+# Checks for typedefs, structures, and compiler characteristics.
|
||||
+
|
||||
+# Check for system features.
|
||||
+AC_SYS_LARGEFILE
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -Wall])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -Wall"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -Winline])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -Winline"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -fno-strength-reduce])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -fno-strength-reduce"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+# Checks for library functions.
|
||||
+
|
||||
+# Write the output.
|
||||
+AC_SUBST([BZIP2_LT_CURRENT])
|
||||
+AC_SUBST([BZIP2_LT_REVISION])
|
||||
+AC_SUBST([BZIP2_LT_AGE])
|
||||
+AC_CONFIG_FILES([Makefile bzip2.pc])
|
||||
+AC_OUTPUT
|
||||
diff -urN bzip2-1.0.5.orig/Makefile.am bzip2-1.0.5.autoconfiscated/Makefile.am
|
||||
--- bzip2-1.0.5.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/Makefile.am 2009-11-05 16:45:11.000000000 +0100
|
||||
@@ -0,0 +1,138 @@
|
||||
+lib_LTLIBRARIES = libbz2.la
|
||||
+
|
||||
+libbz2_la_SOURCES = \
|
||||
+ blocksort.c \
|
||||
+ huffman.c \
|
||||
+ crctable.c \
|
||||
+ randtable.c \
|
||||
+ compress.c \
|
||||
+ decompress.c \
|
||||
+ bzlib.c
|
||||
+
|
||||
+libbz2_la_LDFLAGS = \
|
||||
+ -version-info $(BZIP2_LT_CURRENT):$(BZIP2_LT_REVISION):$(BZIP2_LT_AGE) \
|
||||
+ -no-undefined
|
||||
+
|
||||
+include_HEADERS = bzlib.h
|
||||
+
|
||||
+noinst_HEADERS = bzlib_private.h
|
||||
+
|
||||
+bin_PROGRAMS = bzip2 bzip2recover
|
||||
+
|
||||
+bzip2_SOURCES = bzip2.c
|
||||
+bzip2_LDADD = libbz2.la
|
||||
+
|
||||
+bzip2recover_SOURCES = bzip2recover.c
|
||||
+bzip2recover_LDADD = libbz2.la
|
||||
+
|
||||
+bin_SCRIPTS = bzgrep bzmore bzdiff
|
||||
+
|
||||
+man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = bzip2.pc
|
||||
+
|
||||
+$(pkgconfig_DATA): $(srcdir)/bzip2.pc.in config.status
|
||||
+
|
||||
+install-exec-hook:
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzmore" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzdiff" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+
|
||||
+install-data-hook:
|
||||
+ echo ".so man1/`echo "bzip2" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bunzip2" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzip2" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzcat" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzgrep" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzegrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzgrep" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzfgrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzmore" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzless" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzdiff" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzcmp" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+
|
||||
+uninstall-hook:
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bunzip2" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzcat" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzegrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzfgrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzless" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzcmp" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+
|
||||
+test: bzip2
|
||||
+ @cat $(srcdir)/words1
|
||||
+ ./bzip2 -1 <$(srcdir)/sample1.ref >sample1.rb2
|
||||
+ ./bzip2 -2 <$(srcdir)/sample2.ref >sample2.rb2
|
||||
+ ./bzip2 -3 <$(srcdir)/sample3.ref >sample3.rb2
|
||||
+ ./bzip2 -d <$(srcdir)/sample1.bz2 >sample1.tst
|
||||
+ ./bzip2 -d <$(srcdir)/sample2.bz2 >sample2.tst
|
||||
+ ./bzip2 -ds <$(srcdir)/sample3.bz2 >sample3.tst
|
||||
+ cmp $(srcdir)/sample1.bz2 sample1.rb2
|
||||
+ cmp $(srcdir)/sample2.bz2 sample2.rb2
|
||||
+ cmp $(srcdir)/sample3.bz2 sample3.rb2
|
||||
+ cmp sample1.tst $(srcdir)/sample1.ref
|
||||
+ cmp sample2.tst $(srcdir)/sample2.ref
|
||||
+ cmp sample3.tst $(srcdir)/sample3.ref
|
||||
+ @cat $(srcdir)/words3
|
||||
+
|
||||
+manual: $(srcdir)/manual.html $(srcdir)/manual.ps $(srcdir)/manual.pdf
|
||||
+
|
||||
+manual.ps: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -ps manual.xml
|
||||
+
|
||||
+manual.pdf: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -pdf manual.xml
|
||||
+
|
||||
+manual.html: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -html manual.xml
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ $(bin_SCRIPTS) \
|
||||
+ $(man_MANS) \
|
||||
+ README.autotools \
|
||||
+ README.XML.STUFF \
|
||||
+ bz-common.xsl \
|
||||
+ bz-fo.xsl \
|
||||
+ bz-html.xsl \
|
||||
+ bzip.css \
|
||||
+ bzip2.1.preformatted \
|
||||
+ bzip2.pc.in \
|
||||
+ bzip2.txt \
|
||||
+ dlltest.c \
|
||||
+ dlltest.dsp \
|
||||
+ entities.xml \
|
||||
+ format.pl \
|
||||
+ libbz2.def \
|
||||
+ libbz2.dsp \
|
||||
+ makefile.msc \
|
||||
+ manual.html \
|
||||
+ manual.pdf \
|
||||
+ manual.ps \
|
||||
+ manual.xml \
|
||||
+ mk251.c \
|
||||
+ sample1.bz2 \
|
||||
+ sample1.ref \
|
||||
+ sample2.bz2 \
|
||||
+ sample2.ref \
|
||||
+ sample3.bz2 \
|
||||
+ sample3.ref \
|
||||
+ spewG.c \
|
||||
+ unzcrash.c \
|
||||
+ words0 \
|
||||
+ words1 \
|
||||
+ words2 \
|
||||
+ words3 \
|
||||
+ xmlproc.sh
|
||||
+
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
diff -urN bzip2-1.0.5.orig/bzip2.pc.in bzip2-1.0.5.autoconfiscated/bzip2.pc.in
|
||||
--- bzip2-1.0.5.orig/bzip2.pc.in 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/bzip2.pc.in 2009-11-03 18:48:28.000000000 +0100
|
||||
@@ -0,0 +1,11 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+bindir=@bindir@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: bzip2
|
||||
+Description: Lossless, block-sorting data compression
|
||||
+Version: @VERSION@
|
||||
+Libs: -L${libdir} -lbz2
|
||||
+Cflags: -I${includedir}
|
64
SOURCES/bzip2-use-cdecl-calling-convention.patch
Normal file
64
SOURCES/bzip2-use-cdecl-calling-convention.patch
Normal file
@ -0,0 +1,64 @@
|
||||
--- bzip2-1.0.5/bzlib.h 2007-12-09 13:34:39.000000000 +0100
|
||||
+++ src/bzip2/1.0.5/bzip2-1.0.5/bzlib.h 2008-03-20 20:05:47.000000000 +0100
|
||||
@@ -81,18 +81,52 @@
|
||||
/* windows.h define small to char */
|
||||
# undef small
|
||||
# endif
|
||||
-# ifdef BZ_EXPORT
|
||||
-# define BZ_API(func) WINAPI func
|
||||
-# define BZ_EXTERN extern
|
||||
+//# ifdef BZ_EXPORT
|
||||
+//# define BZ_API(func) WINAPI func
|
||||
+//# define BZ_EXTERN extern
|
||||
+//# else
|
||||
+// /* import windows dll dynamically */
|
||||
+//# define BZ_API(func) (WINAPI * func)
|
||||
+//# define BZ_EXTERN
|
||||
+//# endif
|
||||
+//#else
|
||||
+//# define BZ_API(func) func
|
||||
+//# define BZ_EXTERN extern
|
||||
+# include <stdio.h>
|
||||
+# include <io.h>
|
||||
+# include <sys/utime.h>
|
||||
+# define fdopen _fdopen
|
||||
+# define isatty _isatty
|
||||
+# define setmode _setmode
|
||||
+# define utime _utime
|
||||
+# endif
|
||||
+
|
||||
+#ifndef __GNUC__
|
||||
+# define __DLL_IMPORT__ __declspec(dllimport)
|
||||
+# define __DLL_EXPORT__ __declspec(dllexport)
|
||||
# else
|
||||
- /* import windows dll dynamically */
|
||||
-# define BZ_API(func) (WINAPI * func)
|
||||
-# define BZ_EXTERN
|
||||
+# define __DLL_IMPORT__ __attribute__((dllimport)) extern
|
||||
+# define __DLL_EXPORT__ __attribute__((dllexport)) extern
|
||||
# endif
|
||||
-#else
|
||||
-# define BZ_API(func) func
|
||||
-# define BZ_EXTERN extern
|
||||
+
|
||||
+#if (defined __WIN32__) || (defined _WIN32)
|
||||
+# if defined BUILD_BZIP2_DLL || defined BZ_EXPORT
|
||||
+# define BZIP2_DLL_IMPEXP __DLL_EXPORT__
|
||||
+# elif defined(BZIP2_STATIC)
|
||||
+# define BZIP2_DLL_IMPEXP
|
||||
+# elif defined (USE_BZIP2_DLL) || defined BZ_IMPORT
|
||||
+# define BZIP2_DLL_IMPEXP __DLL_IMPORT__
|
||||
+# elif defined (USE_BZIP2_STATIC)
|
||||
+# define BZIP2_DLL_IMPEXP
|
||||
+# else /* assume USE_BZIP2_DLL */
|
||||
+# define BZIP2_DLL_IMPEXP __DLL_IMPORT__
|
||||
#endif
|
||||
+#else /* __WIN32__ */
|
||||
+# define BZIP2_DLL_IMPEXP
|
||||
+#endif
|
||||
+
|
||||
+#define BZ_API(func) func
|
||||
+#define BZ_EXTERN BZIP2_DLL_IMPEXP
|
||||
|
||||
|
||||
/*-- Core (low-level) library functions --*/
|
11
SOURCES/mingw32-bzip2-1.0.5-slash.patch
Normal file
11
SOURCES/mingw32-bzip2-1.0.5-slash.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bzip2-1.0.5.orig/bzip2.c 2007-12-09 12:22:06.000000000 +0000
|
||||
+++ bzip2-1.0.5/bzip2.c 2008-09-25 12:31:02.000000000 +0100
|
||||
@@ -128,7 +128,7 @@
|
||||
#if BZ_LCCWIN32
|
||||
# include <io.h>
|
||||
# include <fcntl.h>
|
||||
-# include <sys\stat.h>
|
||||
+# include <sys/stat.h>
|
||||
|
||||
# define NORETURN /**/
|
||||
# define PATH_SEP '\\'
|
272
SPECS/mingw-bzip2.spec
Normal file
272
SPECS/mingw-bzip2.spec
Normal file
@ -0,0 +1,272 @@
|
||||
%?mingw_package_header
|
||||
|
||||
Name: mingw-bzip2
|
||||
Version: 1.0.6
|
||||
Release: 11%{?dist}
|
||||
Summary: MinGW port of bzip2 file compression utility
|
||||
|
||||
License: BSD
|
||||
Group: Development/Libraries
|
||||
URL: http://www.bzip.org/
|
||||
Source0: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
|
||||
Patch6: bzip2-1.0.4-bzip2recover.patch
|
||||
|
||||
Patch10: mingw32-bzip2-1.0.5-slash.patch
|
||||
|
||||
Patch12: bzip2-1.0.5-autoconfiscated.patch
|
||||
|
||||
# Export all symbols using the cdecl calling convention instead of
|
||||
# stdcall as it is also done by various other downstream distributors
|
||||
# (like mingw.org and gnuwin32) and it resolves various autoconf and
|
||||
# cmake detection issues (RHBZ #811909, RHBZ #812573)
|
||||
# Patch is taken from the gnuwin32 project
|
||||
Patch13: bzip2-use-cdecl-calling-convention.patch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 95
|
||||
BuildRequires: mingw64-filesystem >= 95
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw64-gcc
|
||||
BuildRequires: mingw32-binutils
|
||||
BuildRequires: mingw64-binutils
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
|
||||
%description
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
Bzip2 compresses files to within 10 to 15 percent of the capabilities
|
||||
of the best techniques available. However, bzip2 has the added benefit
|
||||
of being approximately two times faster at compression and six times
|
||||
faster at decompression than those techniques. Bzip2 is not the
|
||||
fastest compression utility, but it does strike a balance between speed
|
||||
and compression capability.
|
||||
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
# Win32
|
||||
%package -n mingw32-bzip2
|
||||
Summary: 32 Bit version of bzip2 for Windows
|
||||
|
||||
%description -n mingw32-bzip2
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
Bzip2 compresses files to within 10 to 15 percent of the capabilities
|
||||
of the best techniques available. However, bzip2 has the added benefit
|
||||
of being approximately two times faster at compression and six times
|
||||
faster at decompression than those techniques. Bzip2 is not the
|
||||
fastest compression utility, but it does strike a balance between speed
|
||||
and compression capability.
|
||||
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
%package -n mingw32-bzip2-static
|
||||
Summary: Static library for mingw32-bzip2 development
|
||||
Requires: mingw32-bzip2 = %{version}-%{release}
|
||||
|
||||
%description -n mingw32-bzip2-static
|
||||
Static library for mingw32-bzip2 development.
|
||||
|
||||
# Win64
|
||||
%package -n mingw64-bzip2
|
||||
Summary: 64 Bit version of bzip2 for Windows
|
||||
|
||||
%description -n mingw64-bzip2
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
Bzip2 compresses files to within 10 to 15 percent of the capabilities
|
||||
of the best techniques available. However, bzip2 has the added benefit
|
||||
of being approximately two times faster at compression and six times
|
||||
faster at decompression than those techniques. Bzip2 is not the
|
||||
fastest compression utility, but it does strike a balance between speed
|
||||
and compression capability.
|
||||
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
%package -n mingw64-bzip2-static
|
||||
Summary: Static library for mingw64-bzip2 development
|
||||
Requires: mingw64-bzip2 = %{version}-%{release}
|
||||
|
||||
%description -n mingw64-bzip2-static
|
||||
Static library for mingw64-bzip2 development.
|
||||
|
||||
|
||||
%?mingw_debug_package
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n bzip2-%{version}
|
||||
|
||||
%patch6 -p1 -b .bz2recover
|
||||
|
||||
%patch10 -p1 -b .slash
|
||||
|
||||
%patch12 -p1 -b .autoconfiscated
|
||||
|
||||
%patch13 -p1 -b .cdecl
|
||||
|
||||
sh ./autogen.sh
|
||||
|
||||
|
||||
%build
|
||||
%mingw_configure
|
||||
%mingw_make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
%mingw_make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# The binaries which are symlinks contain the full buildroot
|
||||
# name in the symlink, so replace those.
|
||||
for dir in $RPM_BUILD_ROOT%{mingw32_bindir} $RPM_BUILD_ROOT%{mingw64_bindir} ; do
|
||||
pushd $dir
|
||||
rm bzcmp.exe bzegrep.exe bzfgrep.exe bzless.exe
|
||||
ln -s bzdiff bzcmp
|
||||
ln -s bzgrep bzegrep
|
||||
ln -s bzgrep bzfgrep
|
||||
ln -s bzmore bzless
|
||||
popd
|
||||
done
|
||||
|
||||
|
||||
# Remove the manpages, they're duplicates of the native package,
|
||||
# and located in the wrong place anyway.
|
||||
rm -r $RPM_BUILD_ROOT%{mingw32_mandir}/man1
|
||||
rm -r $RPM_BUILD_ROOT%{mingw64_mandir}/man1
|
||||
|
||||
# Remove libtool .la files.
|
||||
rm $RPM_BUILD_ROOT%{mingw32_libdir}/libbz2.la
|
||||
rm $RPM_BUILD_ROOT%{mingw64_libdir}/libbz2.la
|
||||
|
||||
# Win32
|
||||
%files -n mingw32-bzip2
|
||||
%doc COPYING
|
||||
%{mingw32_bindir}/libbz2-1.dll
|
||||
%{mingw32_bindir}/bunzip2.exe
|
||||
%{mingw32_bindir}/bzcat.exe
|
||||
%{mingw32_bindir}/bzcmp
|
||||
%{mingw32_bindir}/bzdiff
|
||||
%{mingw32_bindir}/bzegrep
|
||||
%{mingw32_bindir}/bzfgrep
|
||||
%{mingw32_bindir}/bzgrep
|
||||
%{mingw32_bindir}/bzip2.exe
|
||||
%{mingw32_bindir}/bzip2recover.exe
|
||||
%{mingw32_bindir}/bzless
|
||||
%{mingw32_bindir}/bzmore
|
||||
%{mingw32_includedir}/bzlib.h
|
||||
%{mingw32_libdir}/libbz2.dll.a
|
||||
%{mingw32_libdir}/pkgconfig/bzip2.pc
|
||||
|
||||
%files -n mingw32-bzip2-static
|
||||
%{mingw32_libdir}/libbz2.a
|
||||
|
||||
# Win64
|
||||
%files -n mingw64-bzip2
|
||||
%doc COPYING
|
||||
%{mingw64_bindir}/libbz2-1.dll
|
||||
%{mingw64_bindir}/bunzip2.exe
|
||||
%{mingw64_bindir}/bzcat.exe
|
||||
%{mingw64_bindir}/bzcmp
|
||||
%{mingw64_bindir}/bzdiff
|
||||
%{mingw64_bindir}/bzegrep
|
||||
%{mingw64_bindir}/bzfgrep
|
||||
%{mingw64_bindir}/bzgrep
|
||||
%{mingw64_bindir}/bzip2.exe
|
||||
%{mingw64_bindir}/bzip2recover.exe
|
||||
%{mingw64_bindir}/bzless
|
||||
%{mingw64_bindir}/bzmore
|
||||
%{mingw64_includedir}/bzlib.h
|
||||
%{mingw64_libdir}/libbz2.dll.a
|
||||
%{mingw64_libdir}/pkgconfig/bzip2.pc
|
||||
|
||||
%files -n mingw64-bzip2-static
|
||||
%{mingw64_libdir}/libbz2.a
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 14 2018 Victor Toso <victortoso@redhat.com> - 1.0.6-11
|
||||
- ExclusiveArch: i686, x86_64
|
||||
- Related: rhbz#1615874
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Apr 25 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.6-1
|
||||
- Update to 1.0.6
|
||||
- Export all symbols using the cdecl calling convention instead of
|
||||
stdcall as it is also done by various other downstream distributors
|
||||
(like mingw.org and gnuwin32) and it resolves various autoconf and
|
||||
cmake detection issues (RHBZ #811909, RHBZ #812573)
|
||||
- Added -static subpackages (RHBZ #665539)
|
||||
|
||||
* Fri Mar 16 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.5-13
|
||||
- Added win64 support (contributed by Jay Higley)
|
||||
- Added the autoconf patch from http://ftp.suse.com/pub/people/sbrabec/bzip2/
|
||||
- Dropped some unneeded patches
|
||||
- Dropped the non-implementated testsuite pieces
|
||||
- Bundle the pkgconfig files
|
||||
|
||||
* Wed Mar 07 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.5-12
|
||||
- Renamed the source package to mingw-bzip2 (RHBZ #800847)
|
||||
- Use mingw macros without leading underscore
|
||||
- Dropped unneeded RPM tags
|
||||
|
||||
* Mon Feb 27 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.5-11
|
||||
- Rebuild against the mingw-w64 toolchain
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Fri Feb 20 2009 Richard W.M. Jones <rjones@redhat.com> - 1.0.5-6
|
||||
- Rebuild for mingw32-gcc 4.4
|
||||
|
||||
* Thu Dec 18 2008 Richard Jones <rjones@redhat.com> - 1.0.5-5
|
||||
- Include the LICENSE file in doc section.
|
||||
|
||||
* Sat Nov 22 2008 Richard Jones <rjones@redhat.com> - 1.0.5-4
|
||||
- Rename the implib as libbz2.dll.a so that libtool can find it.
|
||||
|
||||
* Wed Oct 29 2008 Richard Jones <rjones@redhat.com> - 1.0.5-3
|
||||
- Fix mixed spaces/tabs in specfile.
|
||||
|
||||
* Fri Oct 10 2008 Richard Jones <rjones@redhat.com> - 1.0.5-2
|
||||
- Allow the tests to be disabled selectively.
|
||||
|
||||
* Thu Sep 25 2008 Richard Jones <rjones@redhat.com> - 1.0.5-1
|
||||
- Initial RPM release.
|
Loading…
Reference in New Issue
Block a user