Added win64 support (contributed by Jay Higley)
- Added win64 support (contributed by Jay Higley) - Added the autoconf patch from http://ftp.suse.com/pub/people/sbrabec/bzip2/ - Dropped some unneeded patches - Dropped the non-implementated testsuite pieces - Bundle the pkgconfig files
This commit is contained in:
parent
217cb33d3f
commit
0759b5d10e
@ -1,11 +0,0 @@
|
||||
--- bzip2-1.0.4/Makefile-libbz2_so.cflags 2007-01-08 09:47:27.000000000 +0100
|
||||
+++ bzip2-1.0.4/Makefile-libbz2_so 2007-01-08 09:48:47.000000000 +0100
|
||||
@@ -35,7 +35,7 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
+ $(CC) $(CFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
rm -f libbz2.so.1.0
|
||||
ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
@ -1,11 +0,0 @@
|
||||
--- bzip2-1.0.4/Makefile-libbz2_so.senaso 2007-01-03 03:00:55.000000000 +0100
|
||||
+++ bzip2-1.0.4/Makefile-libbz2_so 2007-01-08 09:12:42.000000000 +0100
|
||||
@@ -35,7 +35,7 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.4 $(OBJS)
|
||||
+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
$(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
rm -f libbz2.so.1.0
|
||||
ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
286
bzip2-1.0.5-autoconfiscated.patch
Normal file
286
bzip2-1.0.5-autoconfiscated.patch
Normal file
@ -0,0 +1,286 @@
|
||||
diff -urN files/autogen.sh ./autogen.sh
|
||||
--- bzip2-1.0.5.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/autogen.sh 2009-11-06 12:10:43.574602171 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+mv LICENSE COPYING
|
||||
+mv CHANGES NEWS
|
||||
+touch AUTHORS
|
||||
+touch ChangeLog
|
||||
+libtoolize --force
|
||||
+aclocal
|
||||
+automake --add-missing --gnu
|
||||
+autoconf
|
||||
diff -urN bzip2-1.0.5.orig/README.autotools bzip2-1.0.5.autoconfiscated/README.autotools
|
||||
--- bzip2-1.0.5.orig/README.autotools 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/README.autotools 2010-11-02 17:04:06.000000000 +0100
|
||||
@@ -0,0 +1,39 @@
|
||||
+bzip2 autoconfiscated
|
||||
+=====================
|
||||
+
|
||||
+Temporarily at http://ftp.suse.com/pub/people/sbrabec/bzip2/ expecting
|
||||
+that it will become a new upstream version to prevent per-distribution
|
||||
+shared library patching done by nearly each Linux vendor separately.
|
||||
+
|
||||
+Autoconfiscation brings standard ./configure ; make ; make install
|
||||
+installation, seamless support of DESTDIR, automatic check for supported
|
||||
+CFLAGS, standard shared library support, automatic large files CFLAGS
|
||||
+check and all things that are supported by automake.
|
||||
+
|
||||
+It makes obsolete Makefile-libbz2_so and README.COMPILATION.PROBLEMS.
|
||||
+Now configure should automatically detect correct build flags.
|
||||
+
|
||||
+In case of any problem or question with autotools support feel free to
|
||||
+contact me: Stanislav Brabec <sbrabec@suse.cz>
|
||||
+
|
||||
+Autoconfiscated version binaries are exactly equal to
|
||||
+bzip2-1.0.5.tar.gz. There are only few changes. See below.
|
||||
+
|
||||
+
|
||||
+New features:
|
||||
+
|
||||
+Trivial link man pages for bzcat and bunzip2 added.
|
||||
+
|
||||
+bzip2.pc file for pkg-config. Packages can use it for checks.
|
||||
+
|
||||
+
|
||||
+Incompatible changes:
|
||||
+
|
||||
+soname change. Libtool has no support for two parts name suffix (e. g.
|
||||
+libbz2.so.1.0). It must be a single number (e. g. libbz2.so.1). That is
|
||||
+why soname must change. But I see not a big problem with it. Several
|
||||
+distributions already use the new number instead of the non-standard
|
||||
+number from Makefile-libbz2_so.
|
||||
+
|
||||
+To be super-safe, I incremented minor number of the library file, so
|
||||
+both instances of the shared library can live together.
|
||||
diff -urN bzip2-1.0.5.orig/configure.ac bzip2-1.0.5.autoconfiscated/configure.ac
|
||||
--- bzip2-1.0.5.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/configure.ac 2009-11-06 17:04:04.000000000 +0100
|
||||
@@ -0,0 +1,70 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.57])
|
||||
+AC_INIT([bzip2], [1.0.5], [Julian Seward <jseward@bzip.org>])
|
||||
+BZIP2_LT_CURRENT=1
|
||||
+BZIP2_LT_REVISION=5
|
||||
+BZIP2_LT_AGE=0
|
||||
+AC_CONFIG_SRCDIR([bzlib.h])
|
||||
+AC_CONFIG_MACRO_DIR([m4])
|
||||
+
|
||||
+AM_INIT_AUTOMAKE
|
||||
+AM_MAINTAINER_MODE
|
||||
+
|
||||
+# Checks for programs.
|
||||
+AC_PROG_AWK
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_INSTALL
|
||||
+AC_PROG_LN_S
|
||||
+AC_PROG_MAKE_SET
|
||||
+AC_PROG_LIBTOOL
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+
|
||||
+# Checks for header files.
|
||||
+
|
||||
+# Checks for typedefs, structures, and compiler characteristics.
|
||||
+
|
||||
+# Check for system features.
|
||||
+AC_SYS_LARGEFILE
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -Wall])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -Wall"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -Winline])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -Winline"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+AC_MSG_CHECKING([whether compiler understands -fno-strength-reduce])
|
||||
+save_CFLAGS="$CFLAGS"
|
||||
+CFLAGS="$CFLAGS -fno-strength-reduce"
|
||||
+AC_TRY_COMPILE([], [], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ CFLAGS="$save_CFLAGS"
|
||||
+])
|
||||
+
|
||||
+# Checks for library functions.
|
||||
+
|
||||
+# Write the output.
|
||||
+AC_SUBST([BZIP2_LT_CURRENT])
|
||||
+AC_SUBST([BZIP2_LT_REVISION])
|
||||
+AC_SUBST([BZIP2_LT_AGE])
|
||||
+AC_CONFIG_FILES([Makefile bzip2.pc])
|
||||
+AC_OUTPUT
|
||||
diff -urN bzip2-1.0.5.orig/Makefile.am bzip2-1.0.5.autoconfiscated/Makefile.am
|
||||
--- bzip2-1.0.5.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/Makefile.am 2009-11-05 16:45:11.000000000 +0100
|
||||
@@ -0,0 +1,138 @@
|
||||
+lib_LTLIBRARIES = libbz2.la
|
||||
+
|
||||
+libbz2_la_SOURCES = \
|
||||
+ blocksort.c \
|
||||
+ huffman.c \
|
||||
+ crctable.c \
|
||||
+ randtable.c \
|
||||
+ compress.c \
|
||||
+ decompress.c \
|
||||
+ bzlib.c
|
||||
+
|
||||
+libbz2_la_LDFLAGS = \
|
||||
+ -version-info $(BZIP2_LT_CURRENT):$(BZIP2_LT_REVISION):$(BZIP2_LT_AGE) \
|
||||
+ -no-undefined
|
||||
+
|
||||
+include_HEADERS = bzlib.h
|
||||
+
|
||||
+noinst_HEADERS = bzlib_private.h
|
||||
+
|
||||
+bin_PROGRAMS = bzip2 bzip2recover
|
||||
+
|
||||
+bzip2_SOURCES = bzip2.c
|
||||
+bzip2_LDADD = libbz2.la
|
||||
+
|
||||
+bzip2recover_SOURCES = bzip2recover.c
|
||||
+bzip2recover_LDADD = libbz2.la
|
||||
+
|
||||
+bin_SCRIPTS = bzgrep bzmore bzdiff
|
||||
+
|
||||
+man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = bzip2.pc
|
||||
+
|
||||
+$(pkgconfig_DATA): $(srcdir)/bzip2.pc.in config.status
|
||||
+
|
||||
+install-exec-hook:
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzmore" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ $(LN_S) `echo "bzdiff" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'` $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+
|
||||
+install-data-hook:
|
||||
+ echo ".so man1/`echo "bzip2" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bunzip2" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzip2" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzcat" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzgrep" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzegrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzgrep" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzfgrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzmore" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzless" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ echo ".so man1/`echo "bzdiff" | sed 's,^.*/,,;$(transform)'`.1" >$(DESTDIR)$(mandir)/man1/`echo "bzcmp" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+
|
||||
+uninstall-hook:
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bunzip2" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcat" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzegrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzfgrep" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzless" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(bindir)/`echo "bzcmp" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bunzip2" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzcat" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzegrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzfgrep" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzless" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+ rm -f $(DESTDIR)$(mandir)/man1/`echo "bzcmp" | sed 's,^.*/,,;$(transform)'`.1
|
||||
+
|
||||
+test: bzip2
|
||||
+ @cat $(srcdir)/words1
|
||||
+ ./bzip2 -1 <$(srcdir)/sample1.ref >sample1.rb2
|
||||
+ ./bzip2 -2 <$(srcdir)/sample2.ref >sample2.rb2
|
||||
+ ./bzip2 -3 <$(srcdir)/sample3.ref >sample3.rb2
|
||||
+ ./bzip2 -d <$(srcdir)/sample1.bz2 >sample1.tst
|
||||
+ ./bzip2 -d <$(srcdir)/sample2.bz2 >sample2.tst
|
||||
+ ./bzip2 -ds <$(srcdir)/sample3.bz2 >sample3.tst
|
||||
+ cmp $(srcdir)/sample1.bz2 sample1.rb2
|
||||
+ cmp $(srcdir)/sample2.bz2 sample2.rb2
|
||||
+ cmp $(srcdir)/sample3.bz2 sample3.rb2
|
||||
+ cmp sample1.tst $(srcdir)/sample1.ref
|
||||
+ cmp sample2.tst $(srcdir)/sample2.ref
|
||||
+ cmp sample3.tst $(srcdir)/sample3.ref
|
||||
+ @cat $(srcdir)/words3
|
||||
+
|
||||
+manual: $(srcdir)/manual.html $(srcdir)/manual.ps $(srcdir)/manual.pdf
|
||||
+
|
||||
+manual.ps: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -ps manual.xml
|
||||
+
|
||||
+manual.pdf: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -pdf manual.xml
|
||||
+
|
||||
+manual.html: $(MANUAL_SRCS)
|
||||
+ cd $(srcdir); ./xmlproc.sh -html manual.xml
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ $(bin_SCRIPTS) \
|
||||
+ $(man_MANS) \
|
||||
+ README.autotools \
|
||||
+ README.XML.STUFF \
|
||||
+ bz-common.xsl \
|
||||
+ bz-fo.xsl \
|
||||
+ bz-html.xsl \
|
||||
+ bzip.css \
|
||||
+ bzip2.1.preformatted \
|
||||
+ bzip2.pc.in \
|
||||
+ bzip2.txt \
|
||||
+ dlltest.c \
|
||||
+ dlltest.dsp \
|
||||
+ entities.xml \
|
||||
+ format.pl \
|
||||
+ libbz2.def \
|
||||
+ libbz2.dsp \
|
||||
+ makefile.msc \
|
||||
+ manual.html \
|
||||
+ manual.pdf \
|
||||
+ manual.ps \
|
||||
+ manual.xml \
|
||||
+ mk251.c \
|
||||
+ sample1.bz2 \
|
||||
+ sample1.ref \
|
||||
+ sample2.bz2 \
|
||||
+ sample2.ref \
|
||||
+ sample3.bz2 \
|
||||
+ sample3.ref \
|
||||
+ spewG.c \
|
||||
+ unzcrash.c \
|
||||
+ words0 \
|
||||
+ words1 \
|
||||
+ words2 \
|
||||
+ words3 \
|
||||
+ xmlproc.sh
|
||||
+
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
diff -urN bzip2-1.0.5.orig/bzip2.pc.in bzip2-1.0.5.autoconfiscated/bzip2.pc.in
|
||||
--- bzip2-1.0.5.orig/bzip2.pc.in 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ bzip2-1.0.5.autoconfiscated/bzip2.pc.in 2009-11-03 18:48:28.000000000 +0100
|
||||
@@ -0,0 +1,11 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+bindir=@bindir@
|
||||
+libdir=@libdir@
|
||||
+includedir=@includedir@
|
||||
+
|
||||
+Name: bzip2
|
||||
+Description: Lossless, block-sorting data compression
|
||||
+Version: @VERSION@
|
||||
+Libs: -L${libdir} -lbz2
|
||||
+Cflags: -I${includedir}
|
143
mingw-bzip2.spec
143
mingw-bzip2.spec
@ -1,14 +1,13 @@
|
||||
%define __strip %{mingw32_strip}
|
||||
%define __objdump %{mingw32_objdump}
|
||||
%?mingw_package_header
|
||||
|
||||
%global mingw_build_win32 1
|
||||
%global mingw_build_win64 1
|
||||
|
||||
%define library_version 1.0.4
|
||||
|
||||
# Running the tests requires Wine.
|
||||
%define run_tests 0
|
||||
|
||||
Name: mingw-bzip2
|
||||
Version: 1.0.5
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
Summary: MinGW port of bzip2 file compression utility
|
||||
|
||||
License: BSD
|
||||
@ -18,20 +17,19 @@ Source0: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
Patch0: bzip2-1.0.4-saneso.patch
|
||||
Patch5: bzip2-1.0.4-cflags.patch
|
||||
Patch6: bzip2-1.0.4-bzip2recover.patch
|
||||
|
||||
Patch10: mingw32-bzip2-1.0.5-slash.patch
|
||||
Patch11: mingw32-bzip2-1.0.5-dll.patch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 49
|
||||
Patch12: bzip2-1.0.5-autoconfiscated.patch
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 95
|
||||
BuildRequires: mingw64-filesystem >= 95
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw64-gcc
|
||||
BuildRequires: mingw32-binutils
|
||||
|
||||
%if %{run_tests}
|
||||
BuildRequires: wine
|
||||
%endif
|
||||
BuildRequires: mingw64-binutils
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
|
||||
%description
|
||||
@ -46,9 +44,9 @@ and compression capability.
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
|
||||
# Win32
|
||||
%package -n mingw32-bzip2
|
||||
Summary: MinGW port of bzip2 file compression utility
|
||||
Summary: 32 Bit version of bzip2 for Windows
|
||||
|
||||
%description -n mingw32-bzip2
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
@ -62,87 +60,116 @@ and compression capability.
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
# Win64
|
||||
%package -n mingw64-bzip2
|
||||
Summary: 64 Bit version of bzip2 for Windows
|
||||
|
||||
%description -n mingw64-bzip2
|
||||
Bzip2 is a freely available, patent-free, high quality data compressor.
|
||||
Bzip2 compresses files to within 10 to 15 percent of the capabilities
|
||||
of the best techniques available. However, bzip2 has the added benefit
|
||||
of being approximately two times faster at compression and six times
|
||||
faster at decompression than those techniques. Bzip2 is not the
|
||||
fastest compression utility, but it does strike a balance between speed
|
||||
and compression capability.
|
||||
|
||||
This package contains development tools and libraries for use when
|
||||
cross-compiling Windows software in Fedora.
|
||||
|
||||
|
||||
%?mingw_debug_package
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n bzip2-%{version}
|
||||
|
||||
%patch0 -p1 -b .saneso
|
||||
%patch5 -p1 -b .cflags
|
||||
%patch6 -p1 -b .bz2recover
|
||||
|
||||
%patch10 -p1 -b .slash
|
||||
%patch11 -p1 -b .dll
|
||||
|
||||
%patch12 -p1 -b .autoconfiscated
|
||||
|
||||
sh ./autogen.sh
|
||||
|
||||
|
||||
%build
|
||||
make -f Makefile-libbz2_so \
|
||||
CC="%{mingw32_cc}" \
|
||||
AR="%{mingw32_ar}" \
|
||||
RANLIB="%{mingw32_ranlib}" \
|
||||
CFLAGS="%{mingw32_cflags} -D_FILE_OFFSET_BITS=64" \
|
||||
%{?_smp_mflags} all
|
||||
|
||||
rm -f *.o
|
||||
make CC="%{mingw32_cc}" \
|
||||
AR="%{mingw32_ar}" \
|
||||
RANLIB="%{mingw32_ranlib}" \
|
||||
CFLAGS="%{mingw32_cflags} -D_FILE_OFFSET_BITS=64" \
|
||||
%{?_smp_mflags} \
|
||||
%if %{run_tests}
|
||||
all
|
||||
%else
|
||||
libbz2.a bzip2 bzip2recover
|
||||
%endif
|
||||
%mingw_configure
|
||||
%mingw_make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make PREFIX=$RPM_BUILD_ROOT%{mingw32_prefix} install
|
||||
%mingw_make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
# The binaries which are symlinks contain the full buildroot
|
||||
# name in the symlink, so replace those.
|
||||
pushd $RPM_BUILD_ROOT%{mingw32_bindir}
|
||||
rm bzcmp bzegrep bzfgrep bzless
|
||||
for dir in $RPM_BUILD_ROOT%{mingw32_bindir} $RPM_BUILD_ROOT%{mingw64_bindir} ; do
|
||||
pushd $dir
|
||||
rm bzcmp.exe bzegrep.exe bzfgrep.exe bzless.exe
|
||||
ln -s bzdiff bzcmp
|
||||
ln -s bzgrep bzegrep
|
||||
ln -s bzgrep bzfgrep
|
||||
ln -s bzmore bzless
|
||||
popd
|
||||
done
|
||||
|
||||
|
||||
# Remove the manpages, they're duplicates of the native package,
|
||||
# and located in the wrong place anyway.
|
||||
rm -rf $RPM_BUILD_ROOT%{mingw32_prefix}/man
|
||||
rm -r $RPM_BUILD_ROOT%{mingw32_mandir}/man1
|
||||
rm -r $RPM_BUILD_ROOT%{mingw64_mandir}/man1
|
||||
|
||||
# The Makefile doesn't install the DLL.
|
||||
# Rename the library so that libtool can find it.
|
||||
install bz2.dll.a $RPM_BUILD_ROOT%{mingw32_libdir}/libbz2.dll.a
|
||||
install bz2-1.dll $RPM_BUILD_ROOT%{mingw32_bindir}/
|
||||
|
||||
# Remove the static library.
|
||||
# Remove static libraries and libtool .la files.
|
||||
rm $RPM_BUILD_ROOT%{mingw32_libdir}/libbz2.a
|
||||
|
||||
rm $RPM_BUILD_ROOT%{mingw32_libdir}/libbz2.la
|
||||
rm $RPM_BUILD_ROOT%{mingw64_libdir}/libbz2.a
|
||||
rm $RPM_BUILD_ROOT%{mingw64_libdir}/libbz2.la
|
||||
|
||||
%files -n mingw32-bzip2
|
||||
%doc LICENSE
|
||||
|
||||
%{mingw32_bindir}/bz2-1.dll
|
||||
%{mingw32_libdir}/libbz2.dll.a
|
||||
|
||||
%{mingw32_bindir}/bunzip2
|
||||
%{mingw32_bindir}/bzcat
|
||||
%doc COPYING
|
||||
%{mingw32_bindir}/libbz2-1.dll
|
||||
%{mingw32_bindir}/bunzip2.exe
|
||||
%{mingw32_bindir}/bzcat.exe
|
||||
%{mingw32_bindir}/bzcmp
|
||||
%{mingw32_bindir}/bzdiff
|
||||
%{mingw32_bindir}/bzegrep
|
||||
%{mingw32_bindir}/bzfgrep
|
||||
%{mingw32_bindir}/bzgrep
|
||||
%{mingw32_bindir}/bzip2
|
||||
%{mingw32_bindir}/bzip2recover
|
||||
%{mingw32_bindir}/bzip2.exe
|
||||
%{mingw32_bindir}/bzip2recover.exe
|
||||
%{mingw32_bindir}/bzless
|
||||
%{mingw32_bindir}/bzmore
|
||||
|
||||
%{mingw32_includedir}/bzlib.h
|
||||
%{mingw32_libdir}/libbz2.dll.a
|
||||
%{mingw32_libdir}/pkgconfig/bzip2.pc
|
||||
|
||||
|
||||
%files -n mingw64-bzip2
|
||||
%doc COPYING
|
||||
%{mingw64_bindir}/libbz2-1.dll
|
||||
%{mingw64_bindir}/bunzip2.exe
|
||||
%{mingw64_bindir}/bzcat.exe
|
||||
%{mingw64_bindir}/bzcmp
|
||||
%{mingw64_bindir}/bzdiff
|
||||
%{mingw64_bindir}/bzegrep
|
||||
%{mingw64_bindir}/bzfgrep
|
||||
%{mingw64_bindir}/bzgrep
|
||||
%{mingw64_bindir}/bzip2.exe
|
||||
%{mingw64_bindir}/bzip2recover.exe
|
||||
%{mingw64_bindir}/bzless
|
||||
%{mingw64_bindir}/bzmore
|
||||
%{mingw64_includedir}/bzlib.h
|
||||
%{mingw64_libdir}/libbz2.dll.a
|
||||
%{mingw64_libdir}/pkgconfig/bzip2.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 16 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.5-13
|
||||
- Added win64 support (contributed by Jay Higley)
|
||||
- Added the autoconf patch from http://ftp.suse.com/pub/people/sbrabec/bzip2/
|
||||
- Dropped some unneeded patches
|
||||
- Dropped the non-implementated testsuite pieces
|
||||
- Bundle the pkgconfig files
|
||||
|
||||
* Wed Mar 07 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 1.0.5-12
|
||||
- Renamed the source package to mingw-bzip2 (RHBZ #800847)
|
||||
- Use mingw macros without leading underscore
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- bzip2-1.0.5/Makefile-libbz2_so 2008-09-25 12:52:11.000000000 +0100
|
||||
+++ bzip2-1.0.5.dll/Makefile-libbz2_so 2008-09-25 12:59:22.000000000 +0100
|
||||
@@ -35,10 +35,8 @@
|
||||
bzlib.o
|
||||
|
||||
all: $(OBJS)
|
||||
- $(CC) $(CFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
|
||||
- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
|
||||
- rm -f libbz2.so.1.0
|
||||
- ln -s libbz2.so.1.0.4 libbz2.so.1.0
|
||||
+ $(CC) $(CFLAGS) -shared -Wl,--out-implib -Wl,bz2.dll.a -Wl,-soname -Wl,bz2-1.dll -o bz2-1.dll $(OBJS)
|
||||
+ $(CC) $(CFLAGS) -o bzip2-shared bzip2.c bz2-1.dll
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) bzip2.o libbz2.so.1.0.4 libbz2.so.1.0 bzip2-shared
|
Loading…
Reference in New Issue
Block a user