1.11 release
This commit is contained in:
parent
e4b3410eba
commit
1ceac0453b
@ -1 +1,2 @@
|
||||
microcode_ctl-1.10.tar.gz
|
||||
microcode_ctl-1.11
|
||||
microcode_ctl-1.11.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- microcode_ctl-1.10/microcode_ctl.c~ Sat Apr 14 23:18:13 2001
|
||||
+++ microcode_ctl-1.10/microcode_ctl.c Fri Dec 7 10:31:08 2001
|
||||
--- microcode_ctl-1.11/microcode_ctl.c~ Sat Apr 14 23:18:13 2001
|
||||
+++ microcode_ctl-1.11/microcode_ctl.c Fri Dec 7 10:31:08 2001
|
||||
@@ -36,8 +36,8 @@
|
||||
#define BUFFER_SIZE 4096
|
||||
#define MAX_MICROCODE 2000000
|
||||
@ -11,8 +11,8 @@
|
||||
|
||||
/* yuck */
|
||||
#ifndef MICROCODE_IOCFREE
|
||||
--- microcode_ctl-1.10/Makefile~ Mon Jun 11 16:57:42 2001
|
||||
+++ microcode_ctl-1.10/Makefile Tue Jan 8 20:20:58 2002
|
||||
--- microcode_ctl-1.11/Makefile~ Mon Jun 11 16:57:42 2001
|
||||
+++ microcode_ctl-1.11/Makefile Tue Jan 8 20:20:58 2002
|
||||
@@ -20,7 +20,7 @@
|
||||
PREFIX = /usr/local
|
||||
|
||||
@ -32,8 +32,8 @@
|
||||
|
||||
$(INS) -m 644 $(MANPAGE) $(DESTDIR)$(MANDIR)
|
||||
gzip -9f $(DESTDIR)$(MANDIR)/$(MANPAGE)
|
||||
--- microcode_ctl-1.10/microcode_ctl.c~ 2004-10-28 20:37:08.000000000 -0400
|
||||
+++ microcode_ctl-1.10/microcode_ctl.c 2004-10-28 20:37:35.000000000 -0400
|
||||
--- microcode_ctl-1.11/microcode_ctl.c~ 2004-10-28 20:37:08.000000000 -0400
|
||||
+++ microcode_ctl-1.11/microcode_ctl.c 2004-10-28 20:37:35.000000000 -0400
|
||||
@@ -168,7 +168,7 @@ int main(int argc, char *argv[])
|
||||
|
||||
if (upload) {
|
||||
@ -43,8 +43,8 @@
|
||||
} else
|
||||
usage();
|
||||
|
||||
--- microcode_ctl-1.10/microcode_ctl.c.org 2003-05-28 19:56:22.000000000 +0200
|
||||
+++ microcode_ctl-1.10/microcode_ctl.c 2003-05-28 19:57:01.000000000 +0200
|
||||
--- microcode_ctl-1.11/microcode_ctl.c.org 2003-05-28 19:56:22.000000000 +0200
|
||||
+++ microcode_ctl-1.11/microcode_ctl.c 2003-05-28 19:57:01.000000000 +0200
|
||||
@@ -95,11 +95,13 @@
|
||||
{
|
||||
FILE *fd;
|
||||
@ -60,8 +60,8 @@
|
||||
|
||||
if( (fd=fopen(filename, "r")) == NULL){
|
||||
if(print_error_messages)
|
||||
--- microcode_ctl-1.10/microcode_ctl.c~ 2003-12-13 15:05:56.000000000 +0100
|
||||
+++ microcode_ctl-1.10/microcode_ctl.c 2003-12-13 15:05:56.000000000 +0100
|
||||
--- microcode_ctl-1.11/microcode_ctl.c~ 2003-12-13 15:05:56.000000000 +0100
|
||||
+++ microcode_ctl-1.11/microcode_ctl.c 2003-12-13 15:05:56.000000000 +0100
|
||||
@@ -146,7 +146,7 @@
|
||||
return errno;
|
||||
}
|
||||
|
@ -1,11 +1,11 @@
|
||||
Summary: Tool to update x86/x86-64 CPU microcode.
|
||||
Name: microcode_ctl
|
||||
Version: 1.10
|
||||
Version: 1.11
|
||||
Release: %(R="$Revision$"; RR="${R##: }"; echo ${RR%%?})
|
||||
Serial: 1
|
||||
Group: System Environment/Base
|
||||
License: GPL
|
||||
Source0: microcode_ctl-1.10.tar.gz
|
||||
Source0: microcode_ctl-1.11.tar.gz
|
||||
Source1: microcode_ctl.init
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
Prereq: /sbin/chkconfig /sbin/service
|
||||
@ -30,14 +30,14 @@ mkdir -p %{buildroot}/usr/man
|
||||
mkdir -p %{buildroot}/etc/rc.d/init.d
|
||||
mkdir -p %{buildroot}/etc/sysconfig
|
||||
|
||||
cd microcode_ctl-1.10
|
||||
cd microcode_ctl-1.11
|
||||
make CFLAGS="$RPM_OPT_FLAGS"
|
||||
cd ..
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}/usr/share/man/man{1,8}
|
||||
|
||||
cd microcode_ctl-1.10
|
||||
cd microcode_ctl-1.11
|
||||
|
||||
make DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix} \
|
||||
INSDIR=/sbin MANDIR=%{_mandir}/man8 RCDIR=/etc MICDIR=/etc/firmware install clean
|
||||
@ -66,6 +66,9 @@ fi
|
||||
/sbin/chkconfig --add microcode_ctl
|
||||
|
||||
%changelog
|
||||
* Mon Jan 10 2005 Dave Jones <davej@redhat.com>
|
||||
- Update to upstream 1.11 release.
|
||||
|
||||
* Sat Dec 18 2004 Dave Jones <davej@redhat.com>
|
||||
- Initial packaging, based upon kernel-utils.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user