Update version

This commit is contained in:
sagitter 2013-04-14 20:37:01 +02:00
parent 2d350d0107
commit 84cd4021cc
7 changed files with 27 additions and 23 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/metis-5.0.3.tar.gz /metis-5.0.3.tar.gz
/metis-5.1.0.tar.gz

View File

@ -1,5 +1,5 @@
--- metis-5.0.3/GKlib/Makefile.orig 2013-03-11 20:50:42.000000000 +0100 --- GKlib/Makefile.orig 2013-03-11 20:50:42.000000000 +0100
+++ metis-5.0.3/GKlib/Makefile 2013-03-17 14:26:23.632867727 +0100 +++ GKlib/Makefile 2013-03-17 14:26:23.632867727 +0100
@@ -41,10 +41,10 @@ @@ -41,10 +41,10 @@
CONFIG_FLAGS += -DPCRE=$(pcre) CONFIG_FLAGS += -DPCRE=$(pcre)
endif endif
@ -14,21 +14,21 @@
ifneq ($(prefix), not-set) ifneq ($(prefix), not-set)
CONFIG_FLAGS += -DCMAKE_INSTALL_PREFIX=$(prefix) CONFIG_FLAGS += -DCMAKE_INSTALL_PREFIX=$(prefix)
--- metis-5.0.3/Makefile.orig 2013-03-11 20:50:09.000000000 +0100 --- Makefile.origin 2013-03-30 17:24:45.000000000 +0100
+++ metis-5.0.3/Makefile 2013-03-17 18:30:50.634301059 +0100 +++ Makefile 2013-04-14 20:04:38.887674462 +0200
@@ -9,7 +9,10 @@ @@ -9,6 +9,11 @@
gklib_path = not-set gklib_path = not-set
shared = not-set shared = not-set
cc = not-set cc = not-set
-
+libsuffix = not-set +libsuffix = not-set
+pcre = not-set +pcre = not-set
+gkregex = not-set +gkregex = not-set
+gkrand = not-set +gkrand = not-set
+
# Basically proxies everything to the builddir cmake. # Basically proxies everything to the builddir cmake.
@@ -23,6 +28,9 @@
@@ -23,6 +26,9 @@
ifeq ($(gklib_path), not-set) ifeq ($(gklib_path), not-set)
gklib_path = GKlib gklib_path = GKlib
endif endif
@ -38,7 +38,7 @@
CONFIG_FLAGS += -DGKLIB_PATH=$(abspath $(gklib_path)) CONFIG_FLAGS += -DGKLIB_PATH=$(abspath $(gklib_path))
ifneq ($(gdb), not-set) ifneq ($(gdb), not-set)
CONFIG_FLAGS += -DGDB=$(gdb) CONFIG_FLAGS += -DGDB=$(gdb)
@@ -51,6 +57,15 @@ @@ -51,6 +59,15 @@
ifneq ($(cc), not-set) ifneq ($(cc), not-set)
CONFIG_FLAGS += -DCMAKE_C_COMPILER=$(cc) CONFIG_FLAGS += -DCMAKE_C_COMPILER=$(cc)
endif endif
@ -52,5 +52,5 @@
+ CONFIG_FLAGS += -DGKRAND=$(gkrand) + CONFIG_FLAGS += -DGKRAND=$(gkrand)
+endif +endif
VERNUM=5.0.3 VERNUM=5.1.0
PKGNAME=metis-$(VERNUM) PKGNAME=metis-$(VERNUM)

View File

@ -1,5 +1,5 @@
--- metis-5.0.3/libmetis/CMakeLists.orig.txt 2011-06-22 19:47:13.000000000 +0200 --- libmetis/CMakeLists.orig.txt 2011-06-22 19:47:13.000000000 +0200
+++ metis-5.0.3/libmetis/CMakeLists.txt 2013-03-15 17:13:19.948911972 +0100 +++ libmetis/CMakeLists.txt 2013-03-15 17:13:19.948911972 +0100
@@ -4,13 +4,14 @@ @@ -4,13 +4,14 @@
file(GLOB metis_sources *.c) file(GLOB metis_sources *.c)
# Build libmetis. # Build libmetis.

View File

@ -1,5 +1,5 @@
--- metis-5.0.3/GKlib/CMakeLists.orig.txt 2013-03-11 20:50:14.000000000 +0100 --- GKlib/CMakeLists.orig.txt 2013-03-11 20:50:14.000000000 +0100
+++ metis-5.0.3/GKlib/CMakeLists.txt 2013-03-17 19:53:44.220827579 +0100 +++ GKlib/CMakeLists.txt 2013-03-17 19:53:44.220827579 +0100
@@ -7,7 +7,7 @@ @@ -7,7 +7,7 @@
include(GKlibSystem.cmake) include(GKlibSystem.cmake)

View File

@ -1,5 +1,5 @@
--- metis-5.0.3/include/metis.orig.h 2013-03-11 20:50:00.000000000 +0100 --- include/metis.orig.h 2013-03-11 20:50:00.000000000 +0100
+++ metis-5.0.3/include/metis.h 2013-03-16 12:14:59.117329640 +0100 +++ include/metis.h 2013-03-16 12:14:59.117329640 +0100
@@ -30,7 +30,7 @@ @@ -30,7 +30,7 @@
GCC does provides these definitions in stdint.h, but it may require some GCC does provides these definitions in stdint.h, but it may require some
modifications on other architectures. modifications on other architectures.

View File

@ -1,6 +1,6 @@
Name: metis Name: metis
Version: 5.0.3 Version: 5.1.0
Release: 10%{?dist} Release: 1%{?dist}
Summary: Serial Graph Partitioning and Fill-reducing Matrix Ordering Summary: Serial Graph Partitioning and Fill-reducing Matrix Ordering
License: ASL 2.0 and BSD and LGPLv2+ License: ASL 2.0 and BSD and LGPLv2+
Group: Development/Libraries Group: Development/Libraries
@ -53,14 +53,14 @@ Header and library files of Metis.
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
%patch0 -p1 %patch0 -p0
%patch1 -p1 %patch1 -p0
if [ %{__isa_bits} = "64" ]; then if [ %{__isa_bits} = "64" ]; then
%patch2 -p1 %patch2 -p0
fi fi
%patch4 -p1 %patch4 -p0
%build %build
@ -157,6 +157,9 @@ popd
%{_libdir}/lib%{name}.so %{_libdir}/lib%{name}.so
%changelog %changelog
* Sun Apr 14 2013 Antonio Trande <sagitter@fedoraproject.org> - 5.1.0-1
- Update to 5.1.0
* Sun Mar 31 2013 Antonio Trande <sagitter@fedoraproject.org> - 5.0.3-10 * Sun Mar 31 2013 Antonio Trande <sagitter@fedoraproject.org> - 5.0.3-10
- Removed BR 'perl-Carp' (Bug 926996) - Removed BR 'perl-Carp' (Bug 926996)
- Added LD_PRELOAD before help2man tasks to fix manpage shared_lib_error - Added LD_PRELOAD before help2man tasks to fix manpage shared_lib_error

View File

@ -1 +1 @@
125ea640cac0bb76207562b615c2a1f8 metis-5.0.3.tar.gz 5465e67079419a69e0116de24fce58fe metis-5.1.0.tar.gz