Update to latest git
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
d55639426a
commit
e2b9f4a649
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/meson-18550fe.tar.gz
|
/meson-18550fe.tar.gz
|
||||||
/meson-3b49b71.tar.gz
|
/meson-3b49b71.tar.gz
|
||||||
/meson-0.23.0.tar.gz
|
/meson-0.23.0.tar.gz
|
||||||
|
/meson-0ba1d54.tar.gz
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
From 0ba1d545afe021e09090f434d5242ae942e7d5b4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jussi Pakkanen <jpakkane@gmail.com>
|
|
||||||
Date: Wed, 20 May 2015 22:32:55 +0300
|
|
||||||
Subject: [PATCH] Accept .S files as assembler too.
|
|
||||||
|
|
||||||
---
|
|
||||||
compilers.py | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/compilers.py b/compilers.py
|
|
||||||
index 6fe7370..5e66b23 100644
|
|
||||||
--- a/compilers.py
|
|
||||||
+++ b/compilers.py
|
|
||||||
@@ -1043,7 +1043,7 @@ class GnuCCompiler(CCompiler):
|
|
||||||
return get_gcc_soname_args(self.gcc_type, shlib_name, path, soversion)
|
|
||||||
|
|
||||||
def can_compile(self, filename):
|
|
||||||
- return super().can_compile(filename) or filename.split('.')[-1] == 's' # Gcc can do asm, too.
|
|
||||||
+ return super().can_compile(filename) or filename.split('.')[-1].lower() == 's' # Gcc can do asm, too.
|
|
||||||
|
|
||||||
class GnuObjCCompiler(ObjCCompiler):
|
|
||||||
std_warn_args = ['-Wall', '-Wpedantic', '-Winvalid-pch']
|
|
||||||
@@ -1120,7 +1120,7 @@ class ClangCCompiler(CCompiler):
|
|
||||||
return 'pch'
|
|
||||||
|
|
||||||
def can_compile(self, filename):
|
|
||||||
- return super().can_compile(filename) or filename.split('.')[-1] == 's' # Clang can do asm, too.
|
|
||||||
+ return super().can_compile(filename) or filename.split('.')[-1].lower() == 's' # Clang can do asm, too.
|
|
||||||
|
|
||||||
def get_pch_use_args(self, pch_dir, header):
|
|
||||||
# Workaround for Clang bug http://llvm.org/bugs/show_bug.cgi?id=15136
|
|
||||||
--
|
|
||||||
2.4.1
|
|
||||||
|
|
14
meson.spec
14
meson.spec
@ -1,15 +1,18 @@
|
|||||||
%global __python %{__python3}
|
%global __python %{__python3}
|
||||||
|
|
||||||
|
%global commit 0ba1d54
|
||||||
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
%global date 20150521
|
||||||
|
|
||||||
Name: meson
|
Name: meson
|
||||||
Version: 0.23.0
|
Version: 0.23.0
|
||||||
Release: 3%{?dist}
|
Release: 3.%{date}git%{shortcommit}%{?dist}
|
||||||
Summary: High productivity build system
|
Summary: High productivity build system
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://jpakkane.github.io/meson/
|
URL: https://jpakkane.github.io/meson/
|
||||||
Source0: https://github.com/jpakkane/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
#Source0: https://github.com/jpakkane/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
# https://github.com/jpakkane/meson/commit/0ba1d545afe021e09090f434d5242ae942e7d5b4
|
Source0: https://github.com/jpakkane/meson/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
||||||
Patch0: 0001-Accept-.S-files-as-assembler-too.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: python3-devel ninja-build
|
BuildRequires: python3-devel ninja-build
|
||||||
@ -88,6 +91,9 @@ chmod +x %{buildroot}%{_bindir}/meson*
|
|||||||
%{_mandir}/man1/%{name}gui.1.*
|
%{_mandir}/man1/%{name}gui.1.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
|
||||||
|
- Update to latest git
|
||||||
|
|
||||||
* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
|
* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
|
||||||
- Add patch to accept .S files
|
- Add patch to accept .S files
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user