update to latest git
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
0d5fc66586
commit
9cd3811824
@ -1,26 +0,0 @@
|
|||||||
From 9e9bc5223c49bc51dbfd266f5dc89f2874016622 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Sat, 21 Mar 2015 17:11:04 +0300
|
|
||||||
Subject: [PATCH] install: install rpm macros if RPM bin in system. Closes #56
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
install_meson.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/install_meson.py b/install_meson.py
|
|
||||||
index 616b635..2c13046 100755
|
|
||||||
--- a/install_meson.py
|
|
||||||
+++ b/install_meson.py
|
|
||||||
@@ -107,7 +107,7 @@ if os.path.exists(module_dir):
|
|
||||||
shutil.rmtree(module_dir)
|
|
||||||
shutil.copytree('modules', module_dir)
|
|
||||||
|
|
||||||
-if os.path.exists(os.path.join('/usr', rpmmacros_dir)):
|
|
||||||
+if os.path.exists('/usr/bin/rpm'):
|
|
||||||
print('Installing RPM macros to %s.' % rpmmacros_dir)
|
|
||||||
outfilename = os.path.join(rpmmacros_dir, 'macros.meson')
|
|
||||||
os.makedirs(rpmmacros_dir, exist_ok=True)
|
|
||||||
--
|
|
||||||
2.3.3
|
|
||||||
|
|
10
meson.spec
10
meson.spec
@ -1,7 +1,7 @@
|
|||||||
%global __python %{__python3}
|
%global __python %{__python3}
|
||||||
%global commit a084a8ec3ec12e91c3897dc6b805636be6d36527
|
%global commit 78d31cafd73ef7df0e842efc822a8778fe4f9761
|
||||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
%global date 20150321
|
%global date 20150322
|
||||||
|
|
||||||
Name: meson
|
Name: meson
|
||||||
Version: 0.22.0
|
Version: 0.22.0
|
||||||
@ -12,8 +12,6 @@ License: ASL 2.0
|
|||||||
URL: https://jpakkane.github.io/meson/
|
URL: https://jpakkane.github.io/meson/
|
||||||
#Source0: https://github.com/jpakkane/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
#Source0: https://github.com/jpakkane/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Source0: https://github.com/jpakkane/meson/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
Source0: https://github.com/jpakkane/meson/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
||||||
# https://github.com/jpakkane/meson/pull/57
|
|
||||||
Patch0: 0001-install-install-rpm-macros-if-RPM-bin-in-system.-Clo.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: python3-devel ninja-build
|
BuildRequires: python3-devel ninja-build
|
||||||
@ -87,6 +85,10 @@ chmod +x %{buildroot}%{_bindir}/meson*
|
|||||||
%{_mandir}/man1/%{name}gui.1.*
|
%{_mandir}/man1/%{name}gui.1.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
|
||||||
|
- update to latest git
|
||||||
|
- fix tests on arm
|
||||||
|
|
||||||
* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
|
* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
|
||||||
- update to latest git
|
- update to latest git
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user