don't sneak auto-features yet
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
795680bbd1
commit
66003dedf7
@ -1,7 +1,7 @@
|
||||
From f40355d8a1c12504d2a4d7494d1c9c0b92558d9a Mon Sep 17 00:00:00 2001
|
||||
From 4750aba45d940feef0aa29fb2258fe69f161fb65 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Mon, 23 Jul 2018 19:25:30 +0200
|
||||
Subject: [PATCH 2/3] rpm: use %set_build_flags [skip ci]
|
||||
Subject: [PATCH 1/4] rpm: use %set_build_flags [skip ci]
|
||||
|
||||
It has better name and should do the trick.
|
||||
|
||||
@ -11,11 +11,11 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||
|
||||
diff --git a/data/macros.meson b/data/macros.meson
|
||||
index 31f77951..acd3af93 100644
|
||||
index 732b68d2..7be47895 100644
|
||||
--- a/data/macros.meson
|
||||
+++ b/data/macros.meson
|
||||
@@ -3,11 +3,7 @@
|
||||
%__meson_auto_features enabled
|
||||
@@ -2,11 +2,7 @@
|
||||
%__meson_wrap_mode nodownload
|
||||
|
||||
%meson \
|
||||
- export CFLAGS="${CFLAGS:-%__global_cflags}" \
|
@ -1,7 +1,7 @@
|
||||
From a1b22cae59c0ac8e0297dd42fad3a4edb6354071 Mon Sep 17 00:00:00 2001
|
||||
From 448479e7d6822217e2c363f65911613bf026fbd9 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Mon, 23 Jul 2018 19:29:19 +0200
|
||||
Subject: [PATCH 3/3] =?UTF-8?q?rpm:=20use=20%{shrink=E2=80=A6}=20[skip=20c?=
|
||||
Subject: [PATCH 2/4] =?UTF-8?q?rpm:=20use=20%{shrink=E2=80=A6}=20[skip=20c?=
|
||||
=?UTF-8?q?i]?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
@ -11,14 +11,14 @@ Make logs look better!
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
data/macros.meson | 38 +++++++++++++++++++-------------------
|
||||
1 file changed, 19 insertions(+), 19 deletions(-)
|
||||
data/macros.meson | 36 ++++++++++++++++++------------------
|
||||
1 file changed, 18 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/data/macros.meson b/data/macros.meson
|
||||
index acd3af93..4a8a3ca4 100644
|
||||
index 7be47895..a6a90525 100644
|
||||
--- a/data/macros.meson
|
||||
+++ b/data/macros.meson
|
||||
@@ -4,25 +4,25 @@
|
||||
@@ -3,24 +3,24 @@
|
||||
|
||||
%meson \
|
||||
%set_build_flags \
|
||||
@ -38,7 +38,6 @@ index acd3af93..4a8a3ca4 100644
|
||||
- --localstatedir=%{_localstatedir} \\\
|
||||
- --sharedstatedir=%{_sharedstatedir} \\\
|
||||
- --wrap-mode=%{__meson_wrap_mode} \\\
|
||||
- --auto-features=%{__meson_auto_features} \\\
|
||||
- %{_vpath_srcdir} %{_vpath_builddir} \\\
|
||||
- %{nil}
|
||||
+ %{shrink:%{__meson} \
|
||||
@ -57,7 +56,6 @@ index acd3af93..4a8a3ca4 100644
|
||||
+ --localstatedir=%{_localstatedir} \
|
||||
+ --sharedstatedir=%{_sharedstatedir} \
|
||||
+ --wrap-mode=%{__meson_wrap_mode} \
|
||||
+ --auto-features=%{__meson_auto_features} \
|
||||
+ %{_vpath_srcdir} %{_vpath_builddir} \
|
||||
+ %{nil}}
|
||||
|
@ -1,7 +1,7 @@
|
||||
From cb50f9f0778043629c90d660ba4237120dafbdff Mon Sep 17 00:00:00 2001
|
||||
From e6a4aeab0f70b0149fd4021ed875f4a60e1c5c64 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Mon, 23 Jul 2018 19:24:33 +0200
|
||||
Subject: [PATCH 1/3] rpm: pass --auto-features=enabled [skip ci]
|
||||
Subject: [PATCH 3/4] rpm: pass --auto-features=enabled [skip ci]
|
||||
|
||||
We really want to be explicit.
|
||||
|
||||
@ -11,7 +11,7 @@ Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/data/macros.meson b/data/macros.meson
|
||||
index 732b68d2..31f77951 100644
|
||||
index a6a90525..4a8a3ca4 100644
|
||||
--- a/data/macros.meson
|
||||
+++ b/data/macros.meson
|
||||
@@ -1,5 +1,6 @@
|
||||
@ -20,14 +20,14 @@ index 732b68d2..31f77951 100644
|
||||
+%__meson_auto_features enabled
|
||||
|
||||
%meson \
|
||||
export CFLAGS="${CFLAGS:-%__global_cflags}" \
|
||||
@@ -23,6 +24,7 @@
|
||||
--localstatedir=%{_localstatedir} \\\
|
||||
--sharedstatedir=%{_sharedstatedir} \\\
|
||||
--wrap-mode=%{__meson_wrap_mode} \\\
|
||||
+ --auto-features=%{__meson_auto_features} \\\
|
||||
%{_vpath_srcdir} %{_vpath_builddir} \\\
|
||||
%{nil}
|
||||
%set_build_flags \
|
||||
@@ -19,6 +20,7 @@
|
||||
--localstatedir=%{_localstatedir} \
|
||||
--sharedstatedir=%{_sharedstatedir} \
|
||||
--wrap-mode=%{__meson_wrap_mode} \
|
||||
+ --auto-features=%{__meson_auto_features} \
|
||||
%{_vpath_srcdir} %{_vpath_builddir} \
|
||||
%{nil}}
|
||||
|
||||
--
|
||||
2.18.0
|
25
0004-rpm-set-auto-features-auto.patch
Normal file
25
0004-rpm-set-auto-features-auto.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From d6b119dd63869631ccb4c72e002406a65a5060d5 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Tue, 24 Jul 2018 15:55:14 +0200
|
||||
Subject: [PATCH 4/4] rpm: set --auto-features=auto
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
data/macros.meson | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/macros.meson b/data/macros.meson
|
||||
index 4a8a3ca4..39ceca23 100644
|
||||
--- a/data/macros.meson
|
||||
+++ b/data/macros.meson
|
||||
@@ -1,6 +1,6 @@
|
||||
%__meson %{_bindir}/meson
|
||||
%__meson_wrap_mode nodownload
|
||||
-%__meson_auto_features enabled
|
||||
+%__meson_auto_features auto
|
||||
|
||||
%meson \
|
||||
%set_build_flags \
|
||||
--
|
||||
2.18.0
|
||||
|
14
meson.spec
14
meson.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: meson
|
||||
Version: 0.47.1
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: High productivity build system
|
||||
|
||||
License: ASL 2.0
|
||||
@ -12,9 +12,12 @@ URL: http://mesonbuild.com/
|
||||
Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# https://github.com/mesonbuild/meson/pull/3930
|
||||
Patch0001: 0001-rpm-pass-auto-features-enabled-skip-ci.patch
|
||||
Patch0002: 0002-rpm-use-set_build_flags-skip-ci.patch
|
||||
Patch0003: 0003-rpm-use-shrink-skip-ci.patch
|
||||
Patch0001: 0001-rpm-use-set_build_flags-skip-ci.patch
|
||||
Patch0002: 0002-rpm-use-shrink-skip-ci.patch
|
||||
Patch0003: 0003-rpm-pass-auto-features-enabled-skip-ci.patch
|
||||
# We do not want this yet
|
||||
# https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/SVURE6JRDBTFKHJAPFBYRZ62JQ56OLEG/
|
||||
Patch0004: 0004-rpm-set-auto-features-auto.patch
|
||||
|
||||
BuildArch: noarch
|
||||
Obsoletes: %{name}-gui < 0.31.0-3
|
||||
@ -121,6 +124,9 @@ export MESON_PRINT_TEST_OUTPUT=1
|
||||
%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
|
||||
|
||||
%changelog
|
||||
* Tue Jul 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.47.1-4
|
||||
- Don't sneak auto-features patch yet
|
||||
|
||||
* Tue Jul 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.47.1-3
|
||||
- Macros improvements
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user