Update to 0.55.0rc1
Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
209c74edcf
commit
2aca549235
@ -1,45 +0,0 @@
|
|||||||
From 9a634850c8e2fdc56159dc6e57d4842b7c7f4e0d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Mon, 15 Jun 2020 19:33:52 +0200
|
|
||||||
Subject: [PATCH 1/3] macros.meson: Switch to %{_smp_build_ncpus}
|
|
||||||
|
|
||||||
It is available since RPM 4.15 which has been around 1 year by now.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
(cherry picked from commit c4761afa634a1c3b15c1c8229cb39b3f267fd3b1)
|
|
||||||
---
|
|
||||||
data/macros.meson | 12 +++---------
|
|
||||||
1 file changed, 3 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index c5b90de03..25601aad3 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -2,12 +2,6 @@
|
|
||||||
%__meson_wrap_mode nodownload
|
|
||||||
%__meson_auto_features enabled
|
|
||||||
|
|
||||||
-%_smp_mesonflags %([ -z "$MESON_BUILD_NCPUS" ] \\\
|
|
||||||
- && MESON_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"; \\\
|
|
||||||
- ncpus_max=%{?_smp_ncpus_max}; \\\
|
|
||||||
- if [ -n "$ncpus_max" ] && [ "$ncpus_max" -gt 0 ] && [ "$MESON_BUILD_NCPUS" -gt "$ncpus_max" ]; then MESON_BUILD_NCPUS="$ncpus_max"; fi; \\\
|
|
||||||
- if [ "$MESON_BUILD_NCPUS" -gt 1 ]; then echo "--num-processes $MESON_BUILD_NCPUS"; fi)
|
|
||||||
-
|
|
||||||
%meson \
|
|
||||||
%set_build_flags \
|
|
||||||
%{shrink:%{__meson} \
|
|
||||||
@@ -37,8 +31,8 @@
|
|
||||||
%ninja_install -C %{_vpath_builddir}
|
|
||||||
|
|
||||||
%meson_test \
|
|
||||||
- %{shrink: %{__meson} test \
|
|
||||||
+ %{shrink:%{__meson} test \
|
|
||||||
-C %{_vpath_builddir} \
|
|
||||||
- %{?_smp_mesonflags} \
|
|
||||||
+ --num-processes %{_smp_build_ncpus} \
|
|
||||||
--print-errorlogs \
|
|
||||||
- %{nil}}
|
|
||||||
+ %{nil}}
|
|
||||||
--
|
|
||||||
2.27.0
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
From 314e5bcb7a26dec4f9eb2a5915ba2dffe3aba405 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Mon, 15 Jun 2020 19:36:47 +0200
|
|
||||||
Subject: [PATCH 2/3] macros.meson: Switch to meson compile / install
|
|
||||||
|
|
||||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
(cherry picked from commit 0a61f511aa1960ac0d3f9b5e50e35f5f603b99b7)
|
|
||||||
---
|
|
||||||
data/macros.meson | 12 +++++++++---
|
|
||||||
1 file changed, 9 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index 25601aad3..8a66c9657 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -22,13 +22,19 @@
|
|
||||||
--wrap-mode=%{__meson_wrap_mode} \
|
|
||||||
--auto-features=%{__meson_auto_features} \
|
|
||||||
%{_vpath_srcdir} %{_vpath_builddir} \
|
|
||||||
- %{nil}}
|
|
||||||
+ %{nil}}
|
|
||||||
|
|
||||||
%meson_build \
|
|
||||||
- %ninja_build -C %{_vpath_builddir}
|
|
||||||
+ %{shrink:%{__meson} compile \
|
|
||||||
+ -C %{_vpath_builddir} \
|
|
||||||
+ -j %{_smp_build_ncpus} \
|
|
||||||
+ %{nil}}
|
|
||||||
|
|
||||||
%meson_install \
|
|
||||||
- %ninja_install -C %{_vpath_builddir}
|
|
||||||
+ %{shrink:DESTDIR=%{buildroot} %{__meson} install \
|
|
||||||
+ -C %{_vpath_builddir} \
|
|
||||||
+ --no-rebuild \
|
|
||||||
+ %{nil}}
|
|
||||||
|
|
||||||
%meson_test \
|
|
||||||
%{shrink:%{__meson} test \
|
|
||||||
--
|
|
||||||
2.27.0
|
|
||||||
|
|
@ -1,64 +0,0 @@
|
|||||||
From 25c1a78616ae93af61e61f7aab7cb8ca5e4fd1b1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Thu, 18 Jun 2020 16:45:27 +0200
|
|
||||||
Subject: [PATCH 3/3] mcompile: Add --verbose mode
|
|
||||||
|
|
||||||
Closes: https://github.com/mesonbuild/meson/issues/7352
|
|
||||||
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
data/macros.meson | 1 +
|
|
||||||
mesonbuild/mcompile.py | 11 ++++++++++-
|
|
||||||
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index 8a66c9657..cc4953c5f 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
%{shrink:%{__meson} compile \
|
|
||||||
-C %{_vpath_builddir} \
|
|
||||||
-j %{_smp_build_ncpus} \
|
|
||||||
+ --verbose \
|
|
||||||
%{nil}}
|
|
||||||
|
|
||||||
%meson_install \
|
|
||||||
diff --git a/mesonbuild/mcompile.py b/mesonbuild/mcompile.py
|
|
||||||
index 7829ffc19..12048d09d 100644
|
|
||||||
--- a/mesonbuild/mcompile.py
|
|
||||||
+++ b/mesonbuild/mcompile.py
|
|
||||||
@@ -57,6 +57,11 @@ def add_arguments(parser: 'argparse.ArgumentParser') -> None:
|
|
||||||
default='.',
|
|
||||||
help='The directory containing build files to be built.'
|
|
||||||
)
|
|
||||||
+ parser.add_argument(
|
|
||||||
+ '--verbose',
|
|
||||||
+ action='store_true',
|
|
||||||
+ help='Show more verbose output.'
|
|
||||||
+ )
|
|
||||||
|
|
||||||
|
|
||||||
def run(options: 'argparse.Namespace') -> int:
|
|
||||||
@@ -89,6 +94,8 @@ def run(options: 'argparse.Namespace') -> int:
|
|
||||||
cmd.extend(['-j', str(options.jobs)])
|
|
||||||
if options.load_average > 0:
|
|
||||||
cmd.extend(['-l', str(options.load_average)])
|
|
||||||
+ if options.verbose:
|
|
||||||
+ cmd.append('-v')
|
|
||||||
if options.clean:
|
|
||||||
cmd.append('clean')
|
|
||||||
|
|
||||||
@@ -107,8 +114,10 @@ def run(options: 'argparse.Namespace') -> int:
|
|
||||||
|
|
||||||
if options.load_average:
|
|
||||||
mlog.warning('Msbuild does not have a load-average switch, ignoring.')
|
|
||||||
+ if not options.verbose:
|
|
||||||
+ cmd.append('/v:minimal')
|
|
||||||
if options.clean:
|
|
||||||
- cmd.extend(['/t:Clean'])
|
|
||||||
+ cmd.append('/t:Clean')
|
|
||||||
|
|
||||||
# TODO: xcode?
|
|
||||||
else:
|
|
||||||
--
|
|
||||||
2.27.0
|
|
||||||
|
|
19
meson.spec
19
meson.spec
@ -6,16 +6,15 @@
|
|||||||
%bcond_with check
|
%bcond_with check
|
||||||
|
|
||||||
Name: meson
|
Name: meson
|
||||||
Version: 0.54.3
|
Version: 0.55.0~rc1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: High productivity build system
|
Summary: High productivity build system
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://mesonbuild.com/
|
URL: https://mesonbuild.com/
|
||||||
Source: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
Source: https://github.com/mesonbuild/meson/releases/download/%{version_no_tilde .}/meson-%{version_no_tilde %{quote:}}.tar.gz
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Obsoletes: %{name}-gui < 0.31.0-3
|
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3-setuptools
|
BuildRequires: python3-setuptools
|
||||||
@ -78,15 +77,8 @@ productivity. It aims to do this by providing simple, out-of-the-box
|
|||||||
support for modern software development tools and practices, such as
|
support for modern software development tools and practices, such as
|
||||||
unit tests, coverage reports, Valgrind, CCache and the like.
|
unit tests, coverage reports, Valgrind, CCache and the like.
|
||||||
|
|
||||||
%patchlist
|
|
||||||
# https://github.com/mesonbuild/meson/pull/7329
|
|
||||||
0001-macros.meson-Switch-to-_smp_build_ncpus.patch
|
|
||||||
0002-macros.meson-Switch-to-meson-compile-install.patch
|
|
||||||
# https://github.com/mesonbuild/meson/pull/7353
|
|
||||||
0003-mcompile-Add-verbose-mode.patch
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -p1
|
%autosetup -p1 -n meson-%{version_no_tilde %{quote:}}
|
||||||
# Macro should not change when we are redefining bindir
|
# Macro should not change when we are redefining bindir
|
||||||
sed -i -e "/^%%__meson /s| .*$| %{_bindir}/%{name}|" data/macros.%{name}
|
sed -i -e "/^%%__meson /s| .*$| %{_bindir}/%{name}|" data/macros.%{name}
|
||||||
|
|
||||||
@ -119,6 +111,9 @@ export MESON_PRINT_TEST_OUTPUT=1
|
|||||||
%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
|
%{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 03 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.55.0~rc1-1
|
||||||
|
- Update to 0.55.0rc1
|
||||||
|
|
||||||
* Thu Jun 18 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.54.3-2
|
* Thu Jun 18 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.54.3-2
|
||||||
- Use verbose mode for meson compile
|
- Use verbose mode for meson compile
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (meson-0.54.3.tar.gz) = 4a342728ecba101bf329a015b6be5aaab9221eaef4a96317e4eada9ec7362ad6132182eb6eecaf95192e9cd53832eeadbfa378825e0800fe1f7153de08e57ba8
|
SHA512 (meson-0.55.0rc1.tar.gz) = 4d86bc8b4d2996f39c578287e32c5dcbce088cfb2a67e354c0766cb8be0212bd4ce8022221d3cddfd01d271dccd1caef4bdbe604f3687bd83376b25151238d50
|
||||||
|
Loading…
Reference in New Issue
Block a user