Update to 0.37.0
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
d6502d0e67
commit
1d9beee8c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
|||||||
/meson-0.35.0.tar.gz
|
/meson-0.35.0.tar.gz
|
||||||
/meson-0.35.1.tar.gz
|
/meson-0.35.1.tar.gz
|
||||||
/meson-0.36.0.tar.gz
|
/meson-0.36.0.tar.gz
|
||||||
|
/meson-0.37.0.tar.gz
|
||||||
|
@ -1,65 +0,0 @@
|
|||||||
From 99948536aefc6ed661cf50caca026f10ee3d4679 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Tue, 13 Dec 2016 11:59:52 +0100
|
|
||||||
Subject: [PATCH 1/3] rpm: use meson's syntax to specify sourcedir and builddir
|
|
||||||
|
|
||||||
When user uses %meson -Denable_cool_feature=true current macro fails
|
|
||||||
because RPM adds flag after popd:
|
|
||||||
...
|
|
||||||
pushd x86_64-redhat-linux-gnu
|
|
||||||
/usr/bin/meson ... $OLDPWD/.
|
|
||||||
popd -Denable_cool_feature
|
|
||||||
|
|
||||||
Since meson can accept $srcdir and $builddir arugments we don't have
|
|
||||||
this problem with pushd/popd. It also simplifies things a bit.
|
|
||||||
|
|
||||||
Reported-by: Richard Hughes <richard@hughsie.com>
|
|
||||||
References: https://bugzilla.redhat.com/show_bug.cgi?id=1401062
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
(cherry picked from commit dcd3c217121fbb09be8acecd2d866219e85ad9bd)
|
|
||||||
---
|
|
||||||
data/macros.meson | 28 +++++++++++++---------------
|
|
||||||
1 file changed, 13 insertions(+), 15 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index 4b91c70d..1512a6bf 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -8,21 +8,19 @@
|
|
||||||
export FFLAGS="%{optflags} -I%{_fmoddir}" \
|
|
||||||
export FCFLAGS="%{optflags} -I%{_fmoddir}" \
|
|
||||||
export LDFLAGS="%{?__global_ldflags}" \
|
|
||||||
- mkdir -p %{__builddir} \
|
|
||||||
- pushd %{__builddir} \
|
|
||||||
- %{__meson} \\\
|
|
||||||
- --buildtype=plain \\\
|
|
||||||
- --prefix=%{_prefix} \\\
|
|
||||||
- --libdir=%{_libdir} \\\
|
|
||||||
- --libexecdir=%{_libexecdir} \\\
|
|
||||||
- --bindir=%{_bindir} \\\
|
|
||||||
- --includedir=%{_includedir} \\\
|
|
||||||
- --datadir=%{_datadir} \\\
|
|
||||||
- --mandir=%{_mandir} \\\
|
|
||||||
- --localedir=%{_datadir}/locale \\\
|
|
||||||
- --sysconfdir=%{_sysconfdir} \\\
|
|
||||||
- $OLDPWD/%{__sourcedir} \
|
|
||||||
- popd
|
|
||||||
+ %{__meson} \\\
|
|
||||||
+ --buildtype=plain \\\
|
|
||||||
+ --prefix=%{_prefix} \\\
|
|
||||||
+ --libdir=%{_libdir} \\\
|
|
||||||
+ --libexecdir=%{_libexecdir} \\\
|
|
||||||
+ --bindir=%{_bindir} \\\
|
|
||||||
+ --includedir=%{_includedir} \\\
|
|
||||||
+ --datadir=%{_datadir} \\\
|
|
||||||
+ --mandir=%{_mandir} \\\
|
|
||||||
+ --localedir=%{_datadir}/locale \\\
|
|
||||||
+ --sysconfdir=%{_sysconfdir} \\\
|
|
||||||
+ %{__sourcedir} %{__builddir} \\\
|
|
||||||
+ %{nil}
|
|
||||||
|
|
||||||
%meson_build \
|
|
||||||
%ninja_build -C %{__builddir}
|
|
||||||
--
|
|
||||||
2.11.0
|
|
||||||
|
|
@ -1,45 +0,0 @@
|
|||||||
From 469fbaba002796975baf8d60f583c55d690e381a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Tue, 13 Dec 2016 12:29:28 +0100
|
|
||||||
Subject: [PATCH 2/3] rpm: use __global_*flags
|
|
||||||
|
|
||||||
Using RPM's %{optflags} is definitely nice, but not enough. LDFLAGS
|
|
||||||
are not there, and idea of optflags is too generic. It is supposed
|
|
||||||
to work under CC and CXX, but apparently someone forgot that there
|
|
||||||
is difference between these two.
|
|
||||||
|
|
||||||
%__global_*flags is not part of RPM itself, it's coming within
|
|
||||||
redhat-rpm-config which makes our macros file not that portable,
|
|
||||||
but anyway we already have %__global_ldflags and %ninja_build and
|
|
||||||
no one complained.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
(cherry picked from commit 0121faf16873b500274b36955a08c6994e7f6f76)
|
|
||||||
---
|
|
||||||
data/macros.meson | 10 +++++-----
|
|
||||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index 1512a6bf..e8b15cdd 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -3,11 +3,11 @@
|
|
||||||
%__builddir %{_target_platform}
|
|
||||||
|
|
||||||
%meson \
|
|
||||||
- export CFLAGS="%{optflags}" \
|
|
||||||
- export CXXFLAGS="%{optflags}" \
|
|
||||||
- export FFLAGS="%{optflags} -I%{_fmoddir}" \
|
|
||||||
- export FCFLAGS="%{optflags} -I%{_fmoddir}" \
|
|
||||||
- export LDFLAGS="%{?__global_ldflags}" \
|
|
||||||
+ export CFLAGS="${CFLAGS:-%__global_cflags}" \
|
|
||||||
+ export CXXFLAGS="${CXXFLAGS:-%__global_cxxflags}" \
|
|
||||||
+ export FFLAGS="${FFLAGS:-%__global_fflags}" \
|
|
||||||
+ export FCFLAGS="${FCFLAGS:-%__global_fcflags}" \
|
|
||||||
+ export LDFLAGS="${LDFLAGS:-%__global_ldflags}" \
|
|
||||||
%{__meson} \\\
|
|
||||||
--buildtype=plain \\\
|
|
||||||
--prefix=%{_prefix} \\\
|
|
||||||
--
|
|
||||||
2.11.0
|
|
||||||
|
|
@ -1,69 +0,0 @@
|
|||||||
From be232228b77e9d91810efb62765f8bdf69584caa Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Tue, 13 Dec 2016 19:20:03 +0100
|
|
||||||
Subject: [PATCH 3/3] rpm: use VPATH macro
|
|
||||||
|
|
||||||
This is more or less standardized way to have one variable which
|
|
||||||
will work for all buildsystems defined in redhat-rpm-config.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
(cherry picked from commit b80f8b2dc2d1ca838c814ae1b8842860a39de175)
|
|
||||||
---
|
|
||||||
data/macros.meson | 32 +++++++++++++++-----------------
|
|
||||||
1 file changed, 15 insertions(+), 17 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/data/macros.meson b/data/macros.meson
|
|
||||||
index e8b15cdd..14d39da4 100644
|
|
||||||
--- a/data/macros.meson
|
|
||||||
+++ b/data/macros.meson
|
|
||||||
@@ -1,6 +1,4 @@
|
|
||||||
%__meson %{_bindir}/meson
|
|
||||||
-%__sourcedir .
|
|
||||||
-%__builddir %{_target_platform}
|
|
||||||
|
|
||||||
%meson \
|
|
||||||
export CFLAGS="${CFLAGS:-%__global_cflags}" \
|
|
||||||
@@ -8,25 +6,25 @@
|
|
||||||
export FFLAGS="${FFLAGS:-%__global_fflags}" \
|
|
||||||
export FCFLAGS="${FCFLAGS:-%__global_fcflags}" \
|
|
||||||
export LDFLAGS="${LDFLAGS:-%__global_ldflags}" \
|
|
||||||
- %{__meson} \\\
|
|
||||||
- --buildtype=plain \\\
|
|
||||||
- --prefix=%{_prefix} \\\
|
|
||||||
- --libdir=%{_libdir} \\\
|
|
||||||
- --libexecdir=%{_libexecdir} \\\
|
|
||||||
- --bindir=%{_bindir} \\\
|
|
||||||
- --includedir=%{_includedir} \\\
|
|
||||||
- --datadir=%{_datadir} \\\
|
|
||||||
- --mandir=%{_mandir} \\\
|
|
||||||
- --localedir=%{_datadir}/locale \\\
|
|
||||||
- --sysconfdir=%{_sysconfdir} \\\
|
|
||||||
- %{__sourcedir} %{__builddir} \\\
|
|
||||||
+ %{__meson} \\\
|
|
||||||
+ --buildtype=plain \\\
|
|
||||||
+ --prefix=%{_prefix} \\\
|
|
||||||
+ --libdir=%{_libdir} \\\
|
|
||||||
+ --libexecdir=%{_libexecdir} \\\
|
|
||||||
+ --bindir=%{_bindir} \\\
|
|
||||||
+ --includedir=%{_includedir} \\\
|
|
||||||
+ --datadir=%{_datadir} \\\
|
|
||||||
+ --mandir=%{_mandir} \\\
|
|
||||||
+ --localedir=%{_datadir}/locale \\\
|
|
||||||
+ --sysconfdir=%{_sysconfdir} \\\
|
|
||||||
+ %{_vpath_srcdir} %{_vpath_builddir} \\\
|
|
||||||
%{nil}
|
|
||||||
|
|
||||||
%meson_build \
|
|
||||||
- %ninja_build -C %{__builddir}
|
|
||||||
+ %ninja_build -C %{_vpath_builddir}
|
|
||||||
|
|
||||||
%meson_install \
|
|
||||||
- %ninja_install -C %{__builddir}
|
|
||||||
+ %ninja_install -C %{_vpath_builddir}
|
|
||||||
|
|
||||||
%meson_test \
|
|
||||||
- %ninja_test -C %{__builddir}
|
|
||||||
+ %ninja_test -C %{_vpath_builddir}
|
|
||||||
--
|
|
||||||
2.11.0
|
|
||||||
|
|
10
meson.spec
10
meson.spec
@ -1,16 +1,13 @@
|
|||||||
%global libname mesonbuild
|
%global libname mesonbuild
|
||||||
|
|
||||||
Name: meson
|
Name: meson
|
||||||
Version: 0.36.0
|
Version: 0.37.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: High productivity build system
|
Summary: High productivity build system
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: http://mesonbuild.com/
|
URL: http://mesonbuild.com/
|
||||||
Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch0001: 0001-rpm-use-meson-s-syntax-to-specify-sourcedir-and-buil.patch
|
|
||||||
Patch0002: 0002-rpm-use-__global_-flags.patch
|
|
||||||
Patch0003: 0003-rpm-use-VPATH-macro.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Obsoletes: %{name}-gui < 0.31.0-3
|
Obsoletes: %{name}-gui < 0.31.0-3
|
||||||
|
|
||||||
@ -93,6 +90,9 @@ export MESON_PRINT_TEST_OUTPUT=1
|
|||||||
%{rpmmacrodir}/macros.%{name}
|
%{rpmmacrodir}/macros.%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
|
||||||
|
- Update to 0.37.0
|
||||||
|
|
||||||
* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
|
* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
|
||||||
- Backport more RPM macro fixes (FPC ticket #655)
|
- Backport more RPM macro fixes (FPC ticket #655)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user