This commit is contained in:
Peter Robinson 2019-07-25 10:50:47 +01:00
parent cb0f808356
commit 664a271eea
5 changed files with 11 additions and 80 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/libGLU-20120904.tar.xz
/glu-9.0.0.tar.bz2
/glu-9.0.1.tar.xz

View File

@ -1,33 +0,0 @@
From bfdf99d6ff64b9c2d840e8a5767eaa57e4363c79 Mon Sep 17 00:00:00 2001
From: Mike Gorchak <mike.gorchak.qnx@gmail.com>
Date: Wed, 2 Jan 2013 13:39:50 -0700
Subject: [PATCH 1/2] glu: initialize PriorityQ::order field to NULL in
pqNewPriorityQ()
pqNewPriorityQ() function creates and setups PriorityQ structure, all
except for the field "order". It is filled later in function
pqInit(). Depending on vertices of polygon which must be tesselated
there possible following situation, pqDeletePriorityQ() is called
right after pqNewPriorityQ() function. pqNewPriorityQ() tries to free
memory using pq->order as pointer, which is unitialized at this point.
Signed-off-by: Brian Paul <brianp@vmware.com>
---
src/libtess/priorityq.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/libtess/priorityq.c b/src/libtess/priorityq.c
index c6b99cc..db7cd59 100644
--- a/src/libtess/priorityq.c
+++ b/src/libtess/priorityq.c
@@ -65,6 +65,7 @@ PriorityQ *pqNewPriorityQ( int (*leq)(PQkey key1, PQkey key2) )
return NULL;
}
+ pq->order = NULL;
pq->size = 0;
pq->max = INIT_SIZE;
pq->initialized = FALSE;
--
1.8.3.1

View File

@ -1,35 +0,0 @@
From 069211570c32a8d5848e127975a2943e9d8fc6b9 Mon Sep 17 00:00:00 2001
From: Matt Turner <mattst88@gmail.com>
Date: Thu, 21 Feb 2013 20:40:31 -0800
Subject: [PATCH 2/2] Add -D(N)DEBUG to CFLAGS dependent on --enable-debug
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Tested-by: Blaž Hrastnik <speed.the.bboy@gmail.com>
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=61003
---
configure.ac | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index cbfd047..45abf17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,9 +42,10 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[Enable debugging information]),
- [CFLAGS="$CFLAGS -g -O0"
- CXXFLAGS="$CXXFLAGS -g -O0"],
- [])
+ [CFLAGS="$CFLAGS -g -O0 -DDEBUG"
+ CXXFLAGS="$CXXFLAGS -g -O0 -DDEBUG"],
+ [CFLAGS="$CFLAGS -DNDEBUG"
+ CXXFLAGS="$CXXFLAGS -DNDEBUG"])
dnl Make sure the pkg-config macros are defined
m4_ifndef([PKG_PROG_PKG_CONFIG],
--
1.8.3.1

View File

@ -1,18 +1,15 @@
#define gitdate 20120904
Name: mesa-libGLU
Version: 9.0.0
Release: 17%{?dist}
Version: 9.0.1
Release: 1%{?dist}
Summary: Mesa libGLU library
License: MIT
URL: http://mesa3d.org/
Source0: ftp://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.bz2
Source0: https://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.xz
Source2: make-git-snapshot.sh
Patch1: 0001-glu-initialize-PriorityQ-order-field-to-NULL-in-pqNe.patch
Patch2: 0002-Add-D-N-DEBUG-to-CFLAGS-dependent-on-enable-debug.patch
BuildRequires: gcc-c++
BuildRequires: autoconf automake libtool
BuildRequires: mesa-libGL-devel
@ -34,18 +31,16 @@ developing applications that use %{name}.
%prep
%setup -q -n glu-%{?gitdate:%{gitdate}}%{?!gitdate:%{version}}
%patch1 -p1
%patch2 -p1
%build
autoreconf -v -i -f
%configure --disable-static
%make_build
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%make_install
find $RPM_BUILD_ROOT -name '*.la' -delete
rm -rf $RPM_BUILD_ROOT%{_datadir}/man/man3/gl[A-Z]*
%ldconfig_post
@ -62,6 +57,9 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/man/man3/gl[A-Z]*
%{_libdir}/pkgconfig/glu.pc
%changelog
* Thu Jul 25 2019 Peter Robinson <pbrobinson@fedoraproject.org> 9.0.1-1
- libGLU 9.0.1
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.0-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
be9249132ff49275461cf92039083030 glu-9.0.0.tar.bz2
SHA512 (glu-9.0.1.tar.xz) = 8a6dae5b4bd63efb96d15f23ccda4ad9c2ffaa964897e5fa63d1e58360d8d4e6732c5efd2109dba04155d5fc457ab1718a65cf9b544ce0d452679ba988d04018