Sync with git (#1011823)
This commit is contained in:
parent
4f75410715
commit
2b34d36974
@ -0,0 +1,33 @@
|
|||||||
|
From bfdf99d6ff64b9c2d840e8a5767eaa57e4363c79 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mike Gorchak <mike.gorchak.qnx@gmail.com>
|
||||||
|
Date: Wed, 2 Jan 2013 13:39:50 -0700
|
||||||
|
Subject: [PATCH 1/2] glu: initialize PriorityQ::order field to NULL in
|
||||||
|
pqNewPriorityQ()
|
||||||
|
|
||||||
|
pqNewPriorityQ() function creates and setups PriorityQ structure, all
|
||||||
|
except for the field "order". It is filled later in function
|
||||||
|
pqInit(). Depending on vertices of polygon which must be tesselated
|
||||||
|
there possible following situation, pqDeletePriorityQ() is called
|
||||||
|
right after pqNewPriorityQ() function. pqNewPriorityQ() tries to free
|
||||||
|
memory using pq->order as pointer, which is unitialized at this point.
|
||||||
|
|
||||||
|
Signed-off-by: Brian Paul <brianp@vmware.com>
|
||||||
|
---
|
||||||
|
src/libtess/priorityq.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/libtess/priorityq.c b/src/libtess/priorityq.c
|
||||||
|
index c6b99cc..db7cd59 100644
|
||||||
|
--- a/src/libtess/priorityq.c
|
||||||
|
+++ b/src/libtess/priorityq.c
|
||||||
|
@@ -65,6 +65,7 @@ PriorityQ *pqNewPriorityQ( int (*leq)(PQkey key1, PQkey key2) )
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ pq->order = NULL;
|
||||||
|
pq->size = 0;
|
||||||
|
pq->max = INIT_SIZE;
|
||||||
|
pq->initialized = FALSE;
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
35
0002-Add-D-N-DEBUG-to-CFLAGS-dependent-on-enable-debug.patch
Normal file
35
0002-Add-D-N-DEBUG-to-CFLAGS-dependent-on-enable-debug.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From 069211570c32a8d5848e127975a2943e9d8fc6b9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Matt Turner <mattst88@gmail.com>
|
||||||
|
Date: Thu, 21 Feb 2013 20:40:31 -0800
|
||||||
|
Subject: [PATCH 2/2] Add -D(N)DEBUG to CFLAGS dependent on --enable-debug
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Tested-by: Blaž Hrastnik <speed.the.bboy@gmail.com>
|
||||||
|
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=61003
|
||||||
|
---
|
||||||
|
configure.ac | 7 ++++---
|
||||||
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index cbfd047..45abf17 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -42,9 +42,10 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
|
||||||
|
AC_ARG_ENABLE(debug,
|
||||||
|
AS_HELP_STRING([--enable-debug],
|
||||||
|
[Enable debugging information]),
|
||||||
|
- [CFLAGS="$CFLAGS -g -O0"
|
||||||
|
- CXXFLAGS="$CXXFLAGS -g -O0"],
|
||||||
|
- [])
|
||||||
|
+ [CFLAGS="$CFLAGS -g -O0 -DDEBUG"
|
||||||
|
+ CXXFLAGS="$CXXFLAGS -g -O0 -DDEBUG"],
|
||||||
|
+ [CFLAGS="$CFLAGS -DNDEBUG"
|
||||||
|
+ CXXFLAGS="$CXXFLAGS -DNDEBUG"])
|
||||||
|
|
||||||
|
dnl Make sure the pkg-config macros are defined
|
||||||
|
m4_ifndef([PKG_PROG_PKG_CONFIG],
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: mesa-libGLU
|
Name: mesa-libGLU
|
||||||
Version: 9.0.0
|
Version: 9.0.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Mesa libGLU library
|
Summary: Mesa libGLU library
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -10,6 +10,9 @@ URL: http://mesa3d.org/
|
|||||||
Source0: ftp://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.bz2
|
Source0: ftp://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.bz2
|
||||||
Source2: make-git-snapshot.sh
|
Source2: make-git-snapshot.sh
|
||||||
|
|
||||||
|
Patch1: 0001-glu-initialize-PriorityQ-order-field-to-NULL-in-pqNe.patch
|
||||||
|
Patch2: 0002-Add-D-N-DEBUG-to-CFLAGS-dependent-on-enable-debug.patch
|
||||||
|
|
||||||
%if 0%{?gitdate}
|
%if 0%{?gitdate}
|
||||||
BuildRequires: autoconf automake libtool
|
BuildRequires: autoconf automake libtool
|
||||||
%endif
|
%endif
|
||||||
@ -32,6 +35,8 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n glu-%{?gitdate:%{gitdate}}%{?!gitdate:%{version}}
|
%setup -q -n glu-%{?gitdate:%{gitdate}}%{?!gitdate:%{version}}
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?gitdate}
|
%if 0%{?gitdate}
|
||||||
@ -60,6 +65,9 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/man/man3/gl[A-Z]*
|
|||||||
%{_libdir}/pkgconfig/glu.pc
|
%{_libdir}/pkgconfig/glu.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 09 2013 Adam Jackson <ajax@redhat.com> 9.0.0-4
|
||||||
|
- Sync with git (#1011823)
|
||||||
|
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 9.0.0-3
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 9.0.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user