mercurial 6.2
This commit is contained in:
parent
d89037fae5
commit
d3b863b122
@ -1,22 +1,16 @@
|
||||
# HG changeset patch
|
||||
# Parent 5bd6bcd31dd1ebb63b8914b00064f96297267af7
|
||||
Patch cargo metadata for Fedora build
|
||||
|
||||
Backport upstream 6.2 changes to 6.1:
|
||||
- update memmap2 to 0.5.3 (upstream ec8d9b5a5e7c)
|
||||
- update micro-timer to 0.4.0 (upstream 8848c3453661, ec8d9b5a5e7c)
|
||||
Tweaks that hasn't been upstreamed for 6.2:
|
||||
- update one micro-timer to 0.4.0
|
||||
- update memmap2 to 0.5.3
|
||||
|
||||
Update zstd to 0.10.0 (upstream is stuck on 0.5 because MSRV)
|
||||
- adapt for breaking changes in zstd 0.10.0
|
||||
|
||||
Downgrade ouroboros to 0.13.0 (Fedora packaging needs update - rhbz#2027028)
|
||||
|
||||
Work around narrow constraint on im-rc - https://www.mercurial-scm.org/pipermail/mercurial-devel/2022-May/148500.html
|
||||
|
||||
diff --git a/rust/hg-core/Cargo.toml b/rust/hg-core/Cargo.toml
|
||||
--- a/rust/hg-core/Cargo.toml
|
||||
+++ b/rust/hg-core/Cargo.toml
|
||||
@@ -29,10 +29,10 @@ twox-hash = "1.5.0"
|
||||
@@ -30,10 +30,10 @@ twox-hash = "1.6.2"
|
||||
same-file = "1.0.6"
|
||||
tempfile = "3.1.0"
|
||||
crossbeam-channel = "0.4"
|
||||
@ -30,29 +24,15 @@ diff --git a/rust/hg-core/Cargo.toml b/rust/hg-core/Cargo.toml
|
||||
format-bytes = "0.3.0"
|
||||
|
||||
# We don't use the `miniz-oxide` backend to not change rhg benchmarks and until
|
||||
|
||||
diff --git a/rust/hg-core/src/revlog/revlog.rs b/rust/hg-core/src/revlog/revlog.rs
|
||||
--- a/rust/hg-core/src/revlog/revlog.rs
|
||||
+++ b/rust/hg-core/src/revlog/revlog.rs
|
||||
@@ -431,7 +431,7 @@ impl<'a> RevlogEntry<'a> {
|
||||
@@ -513,7 +513,7 @@ impl<'a> RevlogEntry<'a> {
|
||||
} else {
|
||||
let cap = self.uncompressed_len.max(0) as usize;
|
||||
let mut buf = vec![0; cap];
|
||||
- let len = zstd::block::decompress_to_buffer(self.bytes, &mut buf)
|
||||
+ let len = zstd::bulk::decompress_to_buffer(self.bytes, &mut buf)
|
||||
.map_err(|_| corrupted())?;
|
||||
.map_err(|e| corrupted(e.to_string()))?;
|
||||
if len != self.uncompressed_len as usize {
|
||||
Err(corrupted())
|
||||
|
||||
diff --git a/rust/rhg/Cargo.toml b/rust/rhg/Cargo.toml
|
||||
--- a/rust/rhg/Cargo.toml
|
||||
+++ b/rust/rhg/Cargo.toml
|
||||
@@ -16,7 +16,7 @@ derive_more = "0.99"
|
||||
home = "0.5.3"
|
||||
lazy_static = "1.4.0"
|
||||
log = "0.4.11"
|
||||
-micro-timer = "0.3.1"
|
||||
+micro-timer = "0.4.0"
|
||||
regex = "1.3.9"
|
||||
env_logger = "0.7.1"
|
||||
format-bytes = "0.3.0"
|
||||
Err(corrupted("uncompressed length does not match"))
|
||||
|
@ -9,8 +9,8 @@
|
||||
|
||||
Summary: A fast, lightweight Source Control Management system
|
||||
Name: mercurial
|
||||
Version: 6.1.4
|
||||
Release: 2%{?dist}
|
||||
Version: 6.2
|
||||
Release: 1%{?dist}
|
||||
|
||||
# Release: 1.rc1%%{?dist}
|
||||
|
||||
@ -235,7 +235,7 @@ pathfix.py -pni "%{python3}" %{buildroot}%{_bindir}/hg-ssh
|
||||
%dir %{_datadir}/zsh/site-functions/
|
||||
%dir %{_sysconfdir}/mercurial
|
||||
%dir %{_sysconfdir}/mercurial/hgrc.d
|
||||
%{_datadir}/bash-completion/
|
||||
%dir %{_datadir}/bash-completion/
|
||||
%{_datadir}/zsh/site-functions/_mercurial
|
||||
%exclude %{python3_sitearch}/mercurial/rustext%{python3_ext_suffix}
|
||||
%{python3_sitearch}/mercurial/
|
||||
@ -272,6 +272,9 @@ pathfix.py -pni "%{python3}" %{buildroot}%{_bindir}/hg-ssh
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 11 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2-1
|
||||
- mercurial 6.2
|
||||
|
||||
* Mon Jul 11 2022 Mads Kiilerich <mads@kiilerich.com> - 6.1.4-2
|
||||
- Fix build after upstream applied patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user