mercurial 6.3.0
This commit is contained in:
parent
d36fab1f31
commit
8866eeaa64
1
.gitignore
vendored
1
.gitignore
vendored
@ -87,3 +87,4 @@ mercurial-1.6.2.tar.gz
|
||||
/mercurial-6.2.1.tar.gz
|
||||
/mercurial-6.2.2.tar.gz
|
||||
/mercurial-6.2.3.tar.gz
|
||||
/mercurial-6.3.0.tar.gz
|
||||
|
@ -6,15 +6,20 @@ Update zstd to 0.11.0 (upstream is stuck on 0.5 because MSRV)
|
||||
diff --git a/rust/hg-core/Cargo.toml b/rust/hg-core/Cargo.toml
|
||||
--- a/rust/hg-core/Cargo.toml
|
||||
+++ b/rust/hg-core/Cargo.toml
|
||||
@@ -33,7 +33,7 @@
|
||||
@@ -34,11 +34,11 @@
|
||||
micro-timer = "0.4.0"
|
||||
log = "0.4.8"
|
||||
memmap2 = { version = "0.5.3", features = ["stable_deref_trait"] }
|
||||
-zstd = "0.5.3"
|
||||
+zstd = "0.11"
|
||||
format-bytes = "0.3.0"
|
||||
|
||||
# once_cell 1.15 uses edition 2021, while the heptapod CI
|
||||
# uses an old version of Cargo that doesn't support it.
|
||||
-once_cell = "=1.14.0"
|
||||
+once_cell = "1.14.0"
|
||||
|
||||
# We don't use the `miniz-oxide` backend to not change rhg benchmarks and until
|
||||
# we have a clearer view of which backend is the fastest.
|
||||
diff --git a/rust/hg-core/src/revlog/revlog.rs b/rust/hg-core/src/revlog/revlog.rs
|
||||
--- a/rust/hg-core/src/revlog/revlog.rs
|
||||
+++ b/rust/hg-core/src/revlog/revlog.rs
|
||||
|
@ -9,7 +9,7 @@
|
||||
|
||||
Summary: A fast, lightweight Source Control Management system
|
||||
Name: mercurial
|
||||
Version: 6.2.3
|
||||
Version: 6.3.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
# Release: 1.rc1%%{?dist}
|
||||
@ -273,6 +273,9 @@ pathfix.py -pni "%{python3}" %{buildroot}%{_bindir}/hg-ssh
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 14 2022 Mads Kiilerich <mads@kiilerich.com> - 6.3.0-1
|
||||
- mercurial 6.3.0
|
||||
|
||||
* Tue Oct 04 2022 Mads Kiilerich <mads@kiilerich.com> - 6.2.3-1
|
||||
- mercurial 6.2.3
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mercurial-6.2.3.tar.gz) = 0d82582e6d40ceabcc32419bf0423dd9f49b72b72c91a0f575181f92b355699a88f0426a192c46ca47f3105e47cb45dc3ac1a6499f4c83e01fa31e31c1ffdfbb
|
||||
SHA512 (mercurial-6.3.0.tar.gz) = 17242605f19b49cb962a0f2dbe1cbec01ec25fb4336b055cf7a9d7663c711e9adac29430c594a4f108e03ad11bee5965f82f8081def397d3ac953b86aa16378c
|
||||
|
Loading…
Reference in New Issue
Block a user