Remove obsoleted patches and fix rpmlint complains
This commit is contained in:
parent
fea968b61b
commit
491e6d4c3d
@ -1,25 +0,0 @@
|
|||||||
------------------------
|
|
||||||
diff -r 6c54df68d1de doc/hgmanpage.py
|
|
||||||
--- a/doc/hgmanpage.py Thu Jun 02 08:41:01 2011 -0500
|
|
||||||
+++ b/doc/hgmanpage.py Thu Jun 02 08:45:18 2011 -0500
|
|
||||||
@@ -48,6 +48,7 @@
|
|
||||||
|
|
||||||
from docutils import nodes, writers, languages
|
|
||||||
import roman
|
|
||||||
+import inspect
|
|
||||||
|
|
||||||
FIELD_LIST_INDENT = 7
|
|
||||||
DEFINITION_LIST_INDENT = 7
|
|
||||||
@@ -160,7 +161,11 @@
|
|
||||||
nodes.NodeVisitor.__init__(self, document)
|
|
||||||
self.settings = settings = document.settings
|
|
||||||
lcode = settings.language_code
|
|
||||||
- self.language = languages.get_language(lcode)
|
|
||||||
+ arglen=len(inspect.getargspec(languages.get_language)[0])
|
|
||||||
+ if arglen == 2:
|
|
||||||
+ self.language = languages.get_language(lcode,self.document.reporter)
|
|
||||||
+ else:
|
|
||||||
+ self.language = languages.get_language(lcode)
|
|
||||||
self.head = []
|
|
||||||
self.body = []
|
|
||||||
self.foot = []
|
|
@ -1,19 +0,0 @@
|
|||||||
*** /tmp/ediff2864wKI 2010-10-06 08:30:42.639138469 -0400
|
|
||||||
--- mercurial/i18n.py 2010-10-06 08:29:26.720138409 -0400
|
|
||||||
***************
|
|
||||||
*** 15,21 ****
|
|
||||||
module = __file__
|
|
||||||
|
|
||||||
base = os.path.dirname(module)
|
|
||||||
! for dir in ('.', '..'):
|
|
||||||
localedir = os.path.join(base, dir, 'locale')
|
|
||||||
if os.path.isdir(localedir):
|
|
||||||
break
|
|
||||||
--- 15,21 ----
|
|
||||||
module = __file__
|
|
||||||
|
|
||||||
base = os.path.dirname(module)
|
|
||||||
! for dir in ('.', '..', '/usr/share'):
|
|
||||||
localedir = os.path.join(base, dir, 'locale')
|
|
||||||
if os.path.isdir(localedir):
|
|
||||||
break
|
|
@ -1,35 +0,0 @@
|
|||||||
diff -ruN mercurial-0.9.4.orig/setup.py mercurial-0.9.4.new/setup.py
|
|
||||||
--- mercurial-0.9.4.orig/setup.py 2007-06-25 22:18:18.000000000 -0400
|
|
||||||
+++ mercurial-0.9.4.new/setup.py 2007-08-29 19:17:36.000000000 -0400
|
|
||||||
@@ -54,6 +54,21 @@
|
|
||||||
mercurial.version.remember_version(version)
|
|
||||||
cmdclass = {'install_data': install_package_data}
|
|
||||||
|
|
||||||
+# We want to install the contrib/ directory, but it isn't immediately
|
|
||||||
+# clear where to do that on some platforms. As a temporary expedient,
|
|
||||||
+# assemble that part of the setup manifest only if we are running on
|
|
||||||
+# a posix platform. This is no worse than the current state, and people
|
|
||||||
+# who understand the respective target platforms can improve it over
|
|
||||||
+# time.
|
|
||||||
+
|
|
||||||
+contrib_files = [] # default
|
|
||||||
+if os.name in ['posix']:
|
|
||||||
+ contrib_files = [(os.path.join('/usr/share/mercurial', root),
|
|
||||||
+ [os.path.join(root, file_) for file_ in files])
|
|
||||||
+ for root, dirs, files in os.walk('contrib')]
|
|
||||||
+ contrib_files = contrib_files + [('/usr/share/mercurial/contrib',
|
|
||||||
+ ['hgwebdir.cgi', 'hgweb.cgi'])]
|
|
||||||
+
|
|
||||||
setup(name='mercurial',
|
|
||||||
version=mercurial.version.get_version(),
|
|
||||||
author='Matt Mackall',
|
|
||||||
@@ -67,7 +82,8 @@
|
|
||||||
Extension('mercurial.base85', ['mercurial/base85.c'])],
|
|
||||||
data_files=[(os.path.join('mercurial', root),
|
|
||||||
[os.path.join(root, file_) for file_ in files])
|
|
||||||
- for root, dirs, files in os.walk('templates')],
|
|
||||||
+ for root, dirs, files in os.walk('templates')] +
|
|
||||||
+ contrib_files,
|
|
||||||
cmdclass=cmdclass,
|
|
||||||
scripts=['hg', 'hgmerge'],
|
|
||||||
options=dict(py2exe=dict(packages=['hgext']),
|
|
@ -1,12 +0,0 @@
|
|||||||
--- mercurial-1.1.2/contrib/mergetools.hgrc.orig 2009-02-07 07:14:46.000000000 -0500
|
|
||||||
+++ mercurial-1.1.2/contrib/mergetools.hgrc 2009-02-07 07:14:15.000000000 -0500
|
|
||||||
@@ -46,6 +46,6 @@
|
|
||||||
ecmerge.regkey=Software\Elli\xc3\xa9 Computing\Merge
|
|
||||||
ecmerge.gui=True
|
|
||||||
|
|
||||||
-filemerge.executable=/Developer/Applications/Utilities/FileMerge.app/Contents/MacOS/FileMerge
|
|
||||||
-filemerge.args=-left $other -right $local -ancestor $base -merge $output
|
|
||||||
-filemerge.gui=True
|
|
||||||
+#filemerge.executable=/Developer/Applications/Utilities/FileMerge.app/Contents/MacOS/FileMerge
|
|
||||||
+#filemerge.args=-left $other -right $local -ancestor $base -merge $output
|
|
||||||
+#filemerge.gui=True
|
|
@ -5,19 +5,17 @@ Name: mercurial
|
|||||||
Version: 4.4.2
|
Version: 4.4.2
|
||||||
Release: 6%{?dist}
|
Release: 6%{?dist}
|
||||||
|
|
||||||
# Release: 1.rc1%{?dist}
|
# Release: 1.rc1%%{?dist}
|
||||||
|
|
||||||
#% define upstreamversion %{version}-rc
|
#% define upstreamversion %%{version}-rc
|
||||||
%define upstreamversion %{version}
|
%define upstreamversion %{version}
|
||||||
|
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://www.selenic.com/mercurial/
|
URL: http://www.selenic.com/mercurial/
|
||||||
#Source0: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
|
#Source0: http://www.selenic.com/mercurial/release/%%{name}-%%{version}.tar.gz
|
||||||
Source0: http://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz
|
Source0: http://www.selenic.com/mercurial/release/%{name}-%{upstreamversion}.tar.gz
|
||||||
Source1: mercurial-site-start.el
|
Source1: mercurial-site-start.el
|
||||||
#Patch0: mercurial-i18n.patch
|
|
||||||
#Patch1: docutils-0.8.patch
|
|
||||||
BuildRequires: python2 python2-devel bash-completion
|
BuildRequires: python2 python2-devel bash-completion
|
||||||
BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils
|
BuildRequires: emacs-nox emacs-el pkgconfig gettext python2-docutils
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -39,9 +37,9 @@ Extensions: http://www.selenic.com/mercurial/wiki/index.cgi/CategoryExtension
|
|||||||
# If the emacs-el package has installed a pkgconfig file, use that to determine
|
# If the emacs-el package has installed a pkgconfig file, use that to determine
|
||||||
|
|
||||||
%package hgk
|
%package hgk
|
||||||
Summary: Hgk interface for mercurial
|
Summary: Hgk interface for mercurial
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Requires: hg = %{version}-%{release}, tk
|
Requires: hg = %{version}-%{release}, tk
|
||||||
|
|
||||||
|
|
||||||
%description hgk
|
%description hgk
|
||||||
@ -55,10 +53,7 @@ http://www.selenic.com/mercurial/wiki/index.cgi/UsingHgk for more
|
|||||||
documentation.
|
documentation.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
#%setup -q
|
|
||||||
%setup -q -n %{name}-%{upstreamversion}
|
%setup -q -n %{name}-%{upstreamversion}
|
||||||
#%patch0 -p0
|
|
||||||
#%patch1 -p1
|
|
||||||
# Patch files to use python2 instead of (since lately) non existent python binary.
|
# Patch files to use python2 instead of (since lately) non existent python binary.
|
||||||
sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile
|
sed -i 's|python|python2|' %{_builddir}/%{name}-%{version}/Makefile %{_builddir}/%{name}-%{version}/doc/Makefile
|
||||||
|
|
||||||
@ -149,7 +144,7 @@ grep -v locale %{name}-base.files > %{name}-base-filtered.files
|
|||||||
%{_sysconfdir}/mercurial/hgrc.d/hgk.rc
|
%{_sysconfdir}/mercurial/hgrc.d/hgk.rc
|
||||||
|
|
||||||
##%%check
|
##%%check
|
||||||
##cd tests && %{__python} run-tests.py
|
##cd tests && %%{__python} run-tests.py
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jul 24 2018 Sebastian Kisela <skisela@redhat.com> - 4.4.2-6
|
* Tue Jul 24 2018 Sebastian Kisela <skisela@redhat.com> - 4.4.2-6
|
||||||
|
Loading…
Reference in New Issue
Block a user