mercurial 6.4
This commit is contained in:
parent
d0eb857190
commit
02c76a1b47
1
.gitignore
vendored
1
.gitignore
vendored
@ -91,3 +91,4 @@ mercurial-1.6.2.tar.gz
|
||||
/mercurial-6.3.1.tar.gz
|
||||
/mercurial-6.3.2.tar.gz
|
||||
/mercurial-6.3.3.tar.gz
|
||||
/mercurial-6.4.tar.gz
|
||||
|
@ -1,29 +1,15 @@
|
||||
Patch cargo metadata for Fedora build
|
||||
|
||||
Update zstd to 0.12.0 (upstream is stuck on 0.5 because MSRV)
|
||||
- adapt for breaking changes in zstd 0.10.0
|
||||
Keep using old bytes-cast for now - https://www.mercurial-scm.org/repo/hg/rev/da02e88b4850 indicates that should be ok.
|
||||
|
||||
diff --git a/rust/hg-core/Cargo.toml b/rust/hg-core/Cargo.toml
|
||||
--- a/rust/hg-core/Cargo.toml
|
||||
+++ b/rust/hg-core/Cargo.toml
|
||||
@@ -34,7 +34,7 @@
|
||||
micro-timer = "0.4.0"
|
||||
log = "0.4.8"
|
||||
memmap2 = { version = "0.5.3", features = ["stable_deref_trait"] }
|
||||
-zstd = "0.5.3"
|
||||
+zstd = "0.12"
|
||||
format-bytes = "0.3.0"
|
||||
# once_cell 1.15 uses edition 2021, while the heptapod CI
|
||||
# uses an old version of Cargo that doesn't support it.
|
||||
diff --git a/rust/hg-core/src/revlog/revlog.rs b/rust/hg-core/src/revlog/revlog.rs
|
||||
--- a/rust/hg-core/src/revlog/revlog.rs
|
||||
+++ b/rust/hg-core/src/revlog/revlog.rs
|
||||
@@ -513,7 +513,7 @@ impl<'a> RevlogEntry<'a> {
|
||||
} else {
|
||||
let cap = self.uncompressed_len.max(0) as usize;
|
||||
let mut buf = vec![0; cap];
|
||||
- let len = zstd::block::decompress_to_buffer(self.bytes, &mut buf)
|
||||
+ let len = zstd::bulk::decompress_to_buffer(self.bytes, &mut buf)
|
||||
.map_err(|e| corrupted(e.to_string()))?;
|
||||
if len != self.uncompressed_len as usize {
|
||||
Err(corrupted("uncompressed length does not match"))
|
||||
@@ -10,7 +10,7 @@ name = "hg"
|
||||
|
||||
[dependencies]
|
||||
bitflags = "1.3.2"
|
||||
-bytes-cast = "0.3.0"
|
||||
+bytes-cast = "0.2.0"
|
||||
byteorder = "1.4.3"
|
||||
derive_more = "0.99.17"
|
||||
hashbrown = { version = "0.13.1", features = ["rayon"] }
|
||||
|
@ -9,7 +9,7 @@
|
||||
|
||||
Summary: A fast, lightweight Source Control Management system
|
||||
Name: mercurial
|
||||
Version: 6.3.3
|
||||
Version: 6.4
|
||||
Release: 1%{?dist}
|
||||
|
||||
# Release: 1.rc1%%{?dist}
|
||||
@ -273,6 +273,9 @@ rm -rf %{buildroot}%{python3_sitearch}/mercurial/locale
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 24 2023 Mads Kiilerich <mads@kiilerich.com> - 6.4-1
|
||||
- mercurial 6.4
|
||||
|
||||
* Thu Mar 02 2023 Mads Kiilerich <mads@kiilerich.com> - 6.3.3-1
|
||||
- mercurial 6.3.3
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mercurial-6.3.3.tar.gz) = 2c09ec01857552e92dee2ff946444f6ccd86a7249561d2181f339aa66316e9ce0f19399895782d0b63c1b5fdb6d341f866d166616ae51a78bac7e1bb4128a0fd
|
||||
SHA512 (mercurial-6.4.tar.gz) = a7810eddd0fd2a331215a5f7e9c81df4d860cf695aec3c5e3984821827b5427b5a01b68c07b9711e86db2f9b0ef5b5d3d6251a7dc76f99375c457920ce36c96f
|
||||
|
Loading…
Reference in New Issue
Block a user