f8eb731d4a
Resolves: rhbz#1013110 - Switched to the gcc-34 due to upstream non-compatiblity with the latest gccs (#1013110) - Removed trailing whitespaces from the description
36 lines
973 B
Diff
36 lines
973 B
Diff
diff --git a/Makefile b/Makefile
|
|
index 4b2855b..bd55c1c 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -10,10 +10,10 @@
|
|
FDISK=/dev/fd0
|
|
|
|
AS=as -32
|
|
-CC=gcc
|
|
+CC=gcc34
|
|
|
|
CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
|
|
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
|
|
+ -ffreestanding -fPIC $(SMP_FL)
|
|
|
|
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
|
|
config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
|
|
diff --git a/init.c b/init.c
|
|
index 754b8d7..788c9ce 100644
|
|
--- a/init.c
|
|
+++ b/init.c
|
|
@@ -637,11 +637,11 @@ void smp_default_mode(void)
|
|
for(i = 0; i < 3; i++)
|
|
{
|
|
result = strstr(cpupsn , disabledcpu[i]);
|
|
- if(result != -1) { v->fail_safe |= 0b10; }
|
|
+ if(result != -1) { v->fail_safe |= 2; }
|
|
}
|
|
|
|
// For 5.01 release, SMP disabled by defualt by config.h toggle
|
|
- if(CONSERVATIVE_SMP) { v->fail_safe |= 0b10; }
|
|
+ if(CONSERVATIVE_SMP) { v->fail_safe |= 2; }
|
|
|
|
}
|
|
|