memtest86plus/memtest86+-5.01-gcc34-fix.patch
Jaroslav Škarvada ce9dd1e78c Temporally switched to compat-gcc-34
Resolves: rhbz#1598922
2019-02-05 15:42:20 +01:00

32 lines
942 B
Diff

diff --git a/Makefile b/Makefile
index 7906d50..fb57b1e 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ AS=as -32
CC=gcc
CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
+ -ffreestanding -fPIC $(SMP_FL)
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
diff --git a/init.c b/init.c
index 5bd8b4f..571c11d 100644
--- a/init.c
+++ b/init.c
@@ -639,11 +639,11 @@ void smp_default_mode(void)
for(i = 0; i < 3; i++)
{
result = strstr(cpupsn , disabledcpu[i]);
- if(result != -1) { v->fail_safe |= 0b10; }
+ if(result != -1) { v->fail_safe |= 2; }
}
// For 5.01 release, SMP disabled by defualt by config.h toggle
- if(CONSERVATIVE_SMP) { v->fail_safe |= 0b10; }
+ if(CONSERVATIVE_SMP) { v->fail_safe |= 2; }
}