New version

Resolves: rhbz#1013110
- Switched to the gcc-34 due to upstream non-compatiblity with
  the latest gccs (#1013110)
- Removed trailing whitespaces from the description
This commit is contained in:
Jaroslav Škarvada 2014-02-17 13:33:08 +01:00
parent 722994d9c1
commit f8eb731d4a
5 changed files with 75 additions and 8 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
memtest86+-4.10.tar.gz
/memtest86+-4.20.tar.gz
/memtest86+-5.01.tar.gz

View File

@ -0,0 +1,12 @@
diff --git a/Makefile b/Makefile
index bd55c1c..9909f07 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,6 @@ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
all: clean memtest.bin memtest
- scp memtest.bin root@192.168.0.12:/srv/tftp/mt86plus
# Link it statically once so I know I don't have undefined
# symbols and then link it dynamically so I have full

View File

@ -0,0 +1,35 @@
diff --git a/Makefile b/Makefile
index 4b2855b..bd55c1c 100644
--- a/Makefile
+++ b/Makefile
@@ -10,10 +10,10 @@
FDISK=/dev/fd0
AS=as -32
-CC=gcc
+CC=gcc34
CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
+ -ffreestanding -fPIC $(SMP_FL)
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
diff --git a/init.c b/init.c
index 754b8d7..788c9ce 100644
--- a/init.c
+++ b/init.c
@@ -637,11 +637,11 @@ void smp_default_mode(void)
for(i = 0; i < 3; i++)
{
result = strstr(cpupsn , disabledcpu[i]);
- if(result != -1) { v->fail_safe |= 0b10; }
+ if(result != -1) { v->fail_safe |= 2; }
}
// For 5.01 release, SMP disabled by defualt by config.h toggle
- if(CONSERVATIVE_SMP) { v->fail_safe |= 0b10; }
+ if(CONSERVATIVE_SMP) { v->fail_safe |= 2; }
}

View File

@ -6,8 +6,8 @@
%define debug_package %{nil}
Name: memtest86+
Version: 4.20
Release: 11%{?dist}
Version: 5.01
Release: 1%{?dist}
License: GPLv2
Summary: Stand-alone memory tester for x86 and x86-64 computers
Group: System Environment/Base
@ -16,11 +16,16 @@ Source1: memtest-setup
Source2: new-memtest-pkg
Source3: 20_memtest86+
Patch0: memtest86+-4.20-gcc47-test7-workaround.patch
# workaround wor the rhbz#1013110
Patch1: memtest86+-5.01-use-gcc34.patch
# reported upstream
Patch2: memtest86+-5.01-no-scp.patch
URL: http://www.memtest.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# require glibc-devel.i386 via this file:
BuildRequires: %{_includedir}/gnu/stubs-32.h
# workaround for the rhbz#1013110
BuildRequires: compat-gcc-34
Requires: grubby sed coreutils util-linux
ExclusiveArch: %{ix86} x86_64
@ -41,7 +46,14 @@ to add the %{name} entry to your GRUB boot menu.
%prep
%setup -q
%patch0 -p1 -b .gcc47-test7-workaround
# We do not need this workaround with gcc-3.4
# but letting the patch in the git in case we later
# switch to the up-to-date gcc
#%patch0 -p1 -b .gcc47-test7-workaround
%patch1 -p1 -b .use-gcc34
%patch2 -p1 -b .no-scp
sed -i -e's,0x5000,0x100000,' memtest.lds
%ifarch x86_64
sed -i -e's,$(LD) -s -T memtest.lds,$(LD) -s -T memtest.lds -z max-page-size=0x1000,' Makefile
@ -100,6 +112,13 @@ rm -rf %{buildroot}
%{_sbindir}/memtest-setup
%changelog
* Mon Feb 17 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 5.01-1
- New version
Resolves: rhbz#1013110
- Switched to the gcc-34 due to upstream non-compatiblity with
the latest gccs (#1013110)
- Removed trailing whitespaces from the description
* Mon Sep 16 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 4.20-11
- Fixed grubby requirement
- Fixed bogus dates in changelog (best effort)

View File

@ -1 +1 @@
ef62c2f5be616676c8c62066dedc46b3 memtest86+-4.20.tar.gz
43c5832baa919e1206e251e735cdee2d memtest86+-5.01.tar.gz