New version
Resolves: rhbz#1013110 - Switched to the gcc-34 due to upstream non-compatiblity with the latest gccs (#1013110) - Removed trailing whitespaces from the description
This commit is contained in:
parent
722994d9c1
commit
f8eb731d4a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
memtest86+-4.10.tar.gz
|
memtest86+-4.10.tar.gz
|
||||||
/memtest86+-4.20.tar.gz
|
/memtest86+-4.20.tar.gz
|
||||||
|
/memtest86+-5.01.tar.gz
|
||||||
|
12
memtest86+-5.01-no-scp.patch
Normal file
12
memtest86+-5.01-no-scp.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index bd55c1c..9909f07 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -21,7 +21,6 @@ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
|
||||||
|
|
||||||
|
|
||||||
|
all: clean memtest.bin memtest
|
||||||
|
- scp memtest.bin root@192.168.0.12:/srv/tftp/mt86plus
|
||||||
|
|
||||||
|
# Link it statically once so I know I don't have undefined
|
||||||
|
# symbols and then link it dynamically so I have full
|
35
memtest86+-5.01-use-gcc34.patch
Normal file
35
memtest86+-5.01-use-gcc34.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 4b2855b..bd55c1c 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -10,10 +10,10 @@
|
||||||
|
FDISK=/dev/fd0
|
||||||
|
|
||||||
|
AS=as -32
|
||||||
|
-CC=gcc
|
||||||
|
+CC=gcc34
|
||||||
|
|
||||||
|
CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
|
||||||
|
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
|
||||||
|
+ -ffreestanding -fPIC $(SMP_FL)
|
||||||
|
|
||||||
|
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
|
||||||
|
config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
|
||||||
|
diff --git a/init.c b/init.c
|
||||||
|
index 754b8d7..788c9ce 100644
|
||||||
|
--- a/init.c
|
||||||
|
+++ b/init.c
|
||||||
|
@@ -637,11 +637,11 @@ void smp_default_mode(void)
|
||||||
|
for(i = 0; i < 3; i++)
|
||||||
|
{
|
||||||
|
result = strstr(cpupsn , disabledcpu[i]);
|
||||||
|
- if(result != -1) { v->fail_safe |= 0b10; }
|
||||||
|
+ if(result != -1) { v->fail_safe |= 2; }
|
||||||
|
}
|
||||||
|
|
||||||
|
// For 5.01 release, SMP disabled by defualt by config.h toggle
|
||||||
|
- if(CONSERVATIVE_SMP) { v->fail_safe |= 0b10; }
|
||||||
|
+ if(CONSERVATIVE_SMP) { v->fail_safe |= 2; }
|
||||||
|
|
||||||
|
}
|
||||||
|
|
@ -6,8 +6,8 @@
|
|||||||
%define debug_package %{nil}
|
%define debug_package %{nil}
|
||||||
|
|
||||||
Name: memtest86+
|
Name: memtest86+
|
||||||
Version: 4.20
|
Version: 5.01
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Summary: Stand-alone memory tester for x86 and x86-64 computers
|
Summary: Stand-alone memory tester for x86 and x86-64 computers
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -16,18 +16,23 @@ Source1: memtest-setup
|
|||||||
Source2: new-memtest-pkg
|
Source2: new-memtest-pkg
|
||||||
Source3: 20_memtest86+
|
Source3: 20_memtest86+
|
||||||
Patch0: memtest86+-4.20-gcc47-test7-workaround.patch
|
Patch0: memtest86+-4.20-gcc47-test7-workaround.patch
|
||||||
|
# workaround wor the rhbz#1013110
|
||||||
|
Patch1: memtest86+-5.01-use-gcc34.patch
|
||||||
|
# reported upstream
|
||||||
|
Patch2: memtest86+-5.01-no-scp.patch
|
||||||
URL: http://www.memtest.org
|
URL: http://www.memtest.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
# require glibc-devel.i386 via this file:
|
# require glibc-devel.i386 via this file:
|
||||||
BuildRequires: %{_includedir}/gnu/stubs-32.h
|
BuildRequires: %{_includedir}/gnu/stubs-32.h
|
||||||
|
# workaround for the rhbz#1013110
|
||||||
|
BuildRequires: compat-gcc-34
|
||||||
Requires: grubby sed coreutils util-linux
|
Requires: grubby sed coreutils util-linux
|
||||||
ExclusiveArch: %{ix86} x86_64
|
ExclusiveArch: %{ix86} x86_64
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Memtest86+ is a thorough stand-alone memory test for x86 and x86-64
|
Memtest86+ is a thorough stand-alone memory test for x86 and x86-64
|
||||||
architecture computers. BIOS based memory tests are only a quick
|
architecture computers. BIOS based memory tests are only a quick
|
||||||
check and often miss many of the failures that are detected by
|
check and often miss many of the failures that are detected by
|
||||||
Memtest86+.
|
Memtest86+.
|
||||||
|
|
||||||
The ELF version should be used for booting from grub,
|
The ELF version should be used for booting from grub,
|
||||||
@ -41,7 +46,14 @@ to add the %{name} entry to your GRUB boot menu.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .gcc47-test7-workaround
|
# We do not need this workaround with gcc-3.4
|
||||||
|
# but letting the patch in the git in case we later
|
||||||
|
# switch to the up-to-date gcc
|
||||||
|
#%patch0 -p1 -b .gcc47-test7-workaround
|
||||||
|
|
||||||
|
%patch1 -p1 -b .use-gcc34
|
||||||
|
%patch2 -p1 -b .no-scp
|
||||||
|
|
||||||
sed -i -e's,0x5000,0x100000,' memtest.lds
|
sed -i -e's,0x5000,0x100000,' memtest.lds
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
sed -i -e's,$(LD) -s -T memtest.lds,$(LD) -s -T memtest.lds -z max-page-size=0x1000,' Makefile
|
sed -i -e's,$(LD) -s -T memtest.lds,$(LD) -s -T memtest.lds -z max-page-size=0x1000,' Makefile
|
||||||
@ -100,6 +112,13 @@ rm -rf %{buildroot}
|
|||||||
%{_sbindir}/memtest-setup
|
%{_sbindir}/memtest-setup
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 17 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 5.01-1
|
||||||
|
- New version
|
||||||
|
Resolves: rhbz#1013110
|
||||||
|
- Switched to the gcc-34 due to upstream non-compatiblity with
|
||||||
|
the latest gccs (#1013110)
|
||||||
|
- Removed trailing whitespaces from the description
|
||||||
|
|
||||||
* Mon Sep 16 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 4.20-11
|
* Mon Sep 16 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 4.20-11
|
||||||
- Fixed grubby requirement
|
- Fixed grubby requirement
|
||||||
- Fixed bogus dates in changelog (best effort)
|
- Fixed bogus dates in changelog (best effort)
|
||||||
|
Loading…
Reference in New Issue
Block a user