Temporally switched to compat-gcc-34

Resolves: rhbz#1598922
This commit is contained in:
Jaroslav Škarvada 2019-02-05 15:42:20 +01:00
parent 9ef351ab1e
commit ce9dd1e78c
2 changed files with 41 additions and 4 deletions

View File

@ -0,0 +1,31 @@
diff --git a/Makefile b/Makefile
index 7906d50..fb57b1e 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@ AS=as -32
CC=gcc
CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
+ -ffreestanding -fPIC $(SMP_FL)
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
diff --git a/init.c b/init.c
index 5bd8b4f..571c11d 100644
--- a/init.c
+++ b/init.c
@@ -639,11 +639,11 @@ void smp_default_mode(void)
for(i = 0; i < 3; i++)
{
result = strstr(cpupsn , disabledcpu[i]);
- if(result != -1) { v->fail_safe |= 0b10; }
+ if(result != -1) { v->fail_safe |= 2; }
}
// For 5.01 release, SMP disabled by defualt by config.h toggle
- if(CONSERVATIVE_SMP) { v->fail_safe |= 0b10; }
+ if(CONSERVATIVE_SMP) { v->fail_safe |= 2; }
}

View File

@ -9,7 +9,7 @@
Name: memtest86+ Name: memtest86+
Version: 5.01 Version: 5.01
Release: 23%{?dist} Release: 24%{?dist}
License: GPLv2 License: GPLv2
Summary: Stand-alone memory tester for x86 and x86-64 computers Summary: Stand-alone memory tester for x86 and x86-64 computers
Source0: http://www.memtest.org/download/%{version}/%{name}-%{version}.tar.gz Source0: http://www.memtest.org/download/%{version}/%{name}-%{version}.tar.gz
@ -28,10 +28,11 @@ Patch1: memtest86+-5.01-no-optimization.patch
Patch2: memtest86+-5.01-compile-fix.patch Patch2: memtest86+-5.01-compile-fix.patch
Patch3: memtest86+-5.01-crash-fix.patch Patch3: memtest86+-5.01-crash-fix.patch
Patch4: memtest86+-5.01-fgnu89-inline.patch Patch4: memtest86+-5.01-fgnu89-inline.patch
Patch5: memtest86+-5.01-gcc34-fix.patch
URL: http://www.memtest.org URL: http://www.memtest.org
# require glibc-devel.i386 via this file: # require glibc-devel.i386 via this file:
BuildRequires: %{_includedir}/gnu/stubs-32.h BuildRequires: %{_includedir}/gnu/stubs-32.h
BuildRequires: gcc BuildRequires: compat-gcc-34
Requires: sed coreutils Requires: sed coreutils
ExclusiveArch: %{ix86} x86_64 ExclusiveArch: %{ix86} x86_64
@ -57,7 +58,8 @@ cp -p %{SOURCE5} README.%{readme_suffix}
%patch1 -p1 -b .no-optimization %patch1 -p1 -b .no-optimization
%patch2 -p1 -b .compile-fix %patch2 -p1 -b .compile-fix
%patch3 -p1 -b .crash-fix %patch3 -p1 -b .crash-fix
%patch4 -p1 -b .fgnu89-inline #%patch4 -p1 -b .fgnu89-inline
%patch5 -p1 -b .gcc34-fix
#sed -i -e's,0x10000,0x100000,' memtest.lds #sed -i -e's,0x10000,0x100000,' memtest.lds
%ifarch x86_64 %ifarch x86_64
@ -68,7 +70,7 @@ sed -i -e's,$(LD) -s -T memtest.lds,$(LD) -s -T memtest.lds -z max-page-size=0x1
# Regular build flags not wanted for this binary # Regular build flags not wanted for this binary
# Note: i486 minimum runtime arch # Note: i486 minimum runtime arch
# It makes no sense to use smp flags here. # It makes no sense to use smp flags here.
make make CC=gcc34
%install %install
mkdir -p %{buildroot}/{boot,%{_sbindir}} mkdir -p %{buildroot}/{boot,%{_sbindir}}
@ -111,6 +113,10 @@ install -Dpm 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/memtest86+.conf
%{_mandir}/man8/*.8.gz %{_mandir}/man8/*.8.gz
%changelog %changelog
* Tue Feb 5 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 5.01-24
- Temporally switched to compat-gcc-34
Resolves: rhbz#1598922
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-23 * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.01-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild