2.01 major bugfix release

This commit is contained in:
Warren Togami 2008-02-21 20:15:21 +00:00
parent dfafa9c446
commit 3a08571fc1
5 changed files with 7 additions and 107 deletions

View File

@ -1 +1 @@
memtest86+-2.00.tar.gz memtest86+-2.01.tar.gz

View File

@ -1,41 +0,0 @@
Fix Makefile for x86_64
Tell as to generate 32-bit code.
*.s files are generated from *.S, so clean them too.
diff -up memtest86+-2.00/Makefile.orig memtest86+-2.00/Makefile
--- memtest86+-2.00/Makefile.orig 2008-02-11 14:10:25.000000000 +0100
+++ memtest86+-2.00/Makefile 2008-02-11 14:32:35.000000000 +0100
@@ -8,6 +8,7 @@
#
FDISK=/dev/fd0
+AS=as -32
CC=gcc
CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
@@ -32,6 +33,15 @@ memtest_shared.bin: memtest_shared
memtest: memtest_shared.bin memtest.lds
$(LD) -s -T memtest.lds -b binary memtest_shared.bin -o $@
+head.s: head.S config.h defs.h test.h
+ $(CC) -E -traditional $< -o $@
+
+bootsect.s: bootsect.S config.h defs.h
+ $(CC) -E -traditional $< -o $@
+
+setup.s: setup.S config.h defs.h
+ $(CC) -E -traditional $< -o $@
+
memtest.bin: memtest_shared.bin bootsect.o setup.o memtest.bin.lds
$(LD) -T memtest.bin.lds bootsect.o setup.o -b binary \
memtest_shared.bin -o memtest.bin
@@ -43,7 +53,7 @@ test.o: test.c
$(CC) -c -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding test.c
clean:
- rm -f *.o memtest.bin memtest memtest_shared memtest_shared.bin
+ rm -f *.o *.s memtest.bin memtest memtest_shared memtest_shared.bin
install: all
dd <memtest.bin >$(FDISK) bs=8192

View File

@ -1,55 +0,0 @@
diff -up memtest86+-2.00/setup.S.orig memtest86+-2.00/setup.S
--- memtest86+-2.00/setup.S.orig 2008-02-07 17:27:42.000000000 +0100
+++ memtest86+-2.00/setup.S 2008-02-11 14:56:26.000000000 +0100
@@ -30,6 +30,33 @@ start:
lgdt gdt_48 - start # load gdt with whatever appropriate
# that was painless, now we enable A20
+# start from grub-a20.patch
+ /*
+ * try to switch gateA20 using PORT92, the "Fast A20 and Init"
+ * register
+ */
+ mov $0x92, %dx
+ inb %dx, %al
+ /* skip the port92 code if it's unimplemented (read returns 0xff) */
+ cmpb $0xff, %al
+ jz alt_a20_done
+
+ /* set or clear bit1, the ALT_A20_GATE bit */
+ movb 4(%esp), %ah
+ testb %ah, %ah
+ jz alt_a20_cont1
+ orb $2, %al
+ jmp alt_a20_cont2
+alt_a20_cont1:
+ and $0xfd, %al
+
+ /* clear the INIT_NOW bit; don't accidently reset the machine */
+alt_a20_cont2:
+ and $0xfe, %al
+ outb %al, %dx
+
+alt_a20_done:
+# end from grub-a20.patch
call empty_8042
movb $0xD1, %al # command write
@@ -67,6 +94,9 @@ data32 ljmp $KERNEL_CS, $(TSTLOAD <<4) #
empty_8042:
call delay
inb $0x64, %al # 8042 status port
+ cmpb $0xff, %al # from grub-a20-patch, skip if not impl
+ jz empty_8042_ret
+
testb $1, %al # output buffer?
jz no_output
call delay
@@ -76,6 +106,7 @@ empty_8042:
no_output:
testb $2, %al # is input buffer full?
jnz empty_8042 # yes - loop
+empty_8042_ret:
ret
#
# Delay is needed after doing i/o

View File

@ -5,8 +5,8 @@
Summary: Stand-alone memory tester for x86 and x86-64 computers Summary: Stand-alone memory tester for x86 and x86-64 computers
Name: memtest86+ Name: memtest86+
Version: 2.00 Version: 2.01
Release: 2%{?dist} Release: 1%{?dist}
License: GPLv2 License: GPLv2
ExclusiveArch: %{ix86} x86_64 ExclusiveArch: %{ix86} x86_64
Group: System Environment/Base Group: System Environment/Base
@ -14,8 +14,6 @@ Source0: http://www.memtest.org/download/%{version}/memtest86+-%{version}.tar.gz
URL: http://www.memtest.org URL: http://www.memtest.org
Source1: new-memtest-pkg Source1: new-memtest-pkg
Source2: memtest-setup Source2: memtest-setup
Patch0: memtest-fix-makefile-for-x86_64.diff
Patch1: memtest-intelmac-3.diff
Requires(preun): coreutils Requires(preun): coreutils
# require glibc-devel.i386 via this file: # require glibc-devel.i386 via this file:
BuildRequires: %{_includedir}/gnu/stubs-32.h BuildRequires: %{_includedir}/gnu/stubs-32.h
@ -32,11 +30,6 @@ Run 'memtest-setup' to add to your GRUB or lilo boot menu.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%patch1 -p1
# head.s is a generated file, shouldn't have been in the tarball.
rm head.s
%build %build
# Regular build flags not wanted for this binary # Regular build flags not wanted for this binary
@ -69,6 +62,9 @@ rm -rf $RPM_BUILD_ROOT
/sbin/new-memtest-pkg --remove %{version} /sbin/new-memtest-pkg --remove %{version}
%changelog %changelog
* Thu Feb 21 2008 Warren Togami <wtogami@redhat.com> - 2.01-1
- 2.01 major bugfix release
* Mon Feb 11 2008 Michal Schmidt <mschmidt@redhat.com> - 2.00-2 * Mon Feb 11 2008 Michal Schmidt <mschmidt@redhat.com> - 2.00-2
- forgot to cvs add the compilation patch. - forgot to cvs add the compilation patch.

View File

@ -1 +1 @@
b411671e8b2f52d30705e814a56631cb memtest86+-2.00.tar.gz e849eaf4ff3f6f4d7aff32d3dfa1b32c memtest86+-2.01.tar.gz