81 lines
3.0 KiB
Diff
81 lines
3.0 KiB
Diff
From 0de5d76fa06c027ff17790c871e57c939b14bea4 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <0de5d76fa06c027ff17790c871e57c939b14bea4.1432566145.git.aquini@redhat.com>
|
|
In-Reply-To: <74f8dd6193fe1ae1e475452a76f9c4daaf602a63.1432566145.git.aquini@redhat.com>
|
|
References: <74f8dd6193fe1ae1e475452a76f9c4daaf602a63.1432566145.git.aquini@redhat.com>
|
|
From: Rafael Aquini <aquini@redhat.com>
|
|
Date: Mon, 25 May 2015 10:31:01 -0400
|
|
Subject: [PATCH 2/2] memkind: configure.ac fix obsolete macro usage warnings
|
|
|
|
This patch adjusts memkind's configure.ac file to get rid of the following
|
|
warnings when autotools are executed with '-Wobsolete' flag
|
|
|
|
-- >8 --
|
|
$ ./autogen.sh
|
|
~/rpmbuild/BUILD/memkind-a0dfc8ad94960babcdaf99063164f9b64b1092e4/jemalloc ~/rpmbuild/BUILD/memkind-a0dfc8ad94960babcdaf99063164f9b64b1092e4
|
|
~/rpmbuild/BUILD/memkind-a0dfc8ad94960babcdaf99063164f9b64b1092e4
|
|
configure.ac:140: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
|
|
configure.ac:140: You should run autoupdate.
|
|
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
|
|
configure.ac:140: the top level
|
|
configure.ac:178: warning: AC_OUTPUT should be used without arguments.
|
|
configure.ac:178: You should run autoupdate.
|
|
libtoolize: putting auxiliary files in `.'.
|
|
libtoolize: copying file `./ltmain.sh'
|
|
libtoolize: putting macros in `m4'.
|
|
libtoolize: copying file `m4/libtool.m4'
|
|
libtoolize: copying file `m4/ltoptions.m4'
|
|
libtoolize: copying file `m4/ltsugar.m4'
|
|
libtoolize: copying file `m4/ltversion.m4'
|
|
libtoolize: copying file `m4/lt~obsolete.m4'
|
|
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
|
|
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
|
|
libtoolize: `AC_PROG_RANLIB' is rendered obsolete by `LT_INIT'
|
|
configure.ac:140: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
|
|
configure.ac:140: You should run autoupdate.
|
|
m4/libtool.m4:107: AC_PROG_LIBTOOL is expanded from...
|
|
configure.ac:140: the top level
|
|
configure.ac:178: warning: AC_OUTPUT should be used without arguments.
|
|
configure.ac:178: You should run autoupdate.
|
|
-- 8< --
|
|
|
|
Signed-off-by: Rafael Aquini <aquini@redhat.com>
|
|
---
|
|
configure.ac | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 465eba9..24c7840 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -30,6 +30,7 @@ AC_INIT([memkind],m4_esyscmd([tr -d '\n' < VERSION]),[christopher.m.cantalupo@in
|
|
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects tar-pax])
|
|
AC_CONFIG_HEADERS([config.h])
|
|
AC_CONFIG_HEADERS([config_tls.h])
|
|
+AC_CONFIG_MACRO_DIR([m4])
|
|
|
|
memkind_abi_version=0:1:0
|
|
AC_SUBST(memkind_abi_version)
|
|
@@ -137,8 +138,7 @@ AC_PROG_CPP
|
|
AC_PROG_INSTALL
|
|
AC_PROG_LN_S
|
|
AC_PROG_MAKE_SET
|
|
-AC_PROG_LIBTOOL
|
|
-AC_PROG_RANLIB
|
|
+LT_INIT
|
|
AM_PROG_CC_C_O
|
|
|
|
# Checks for libraries.
|
|
@@ -175,7 +175,8 @@ AC_FUNC_MMAP
|
|
AC_FUNC_REALLOC
|
|
AC_CHECK_FUNCS([gettimeofday memset mkdir munmap setenv strtol strtoul])
|
|
|
|
-AC_OUTPUT(Makefile)
|
|
+AC_CONFIG_FILES([Makefile])
|
|
+AC_OUTPUT
|
|
|
|
# ============================================================================
|
|
# Print out the results of configuration.
|
|
--
|
|
2.1.0
|
|
|