Update memkind source file to 1.10.1 upstream
Signed-off-by: Rafael Aquini <aquini@redhat.com>
This commit is contained in:
parent
2af1b8729c
commit
e75f344455
11
gcc10.patch
11
gcc10.patch
@ -1,11 +0,0 @@
|
||||
diff -Nrup a/include/pmem_allocator.h b/include/pmem_allocator.h
|
||||
--- a/include/pmem_allocator.h 2019-04-08 03:09:06.000000000 -0600
|
||||
+++ b/include/pmem_allocator.h 2019-09-23 16:44:03.513259842 -0600
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <type_traits>
|
||||
#include <atomic>
|
||||
#include <cstddef>
|
||||
+#include <stdexcept>
|
||||
|
||||
#include "memkind.h"
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff --git a/memkind-1.10.0/test/gtest_fused/gtest/gtest-all.cc b/memkind-1.10.0/test/gtest_fused/gtest/gtest-all.cc
|
||||
index 1120ce8..7a2a816 100644
|
||||
--- a/memkind-1.10.0/test/gtest_fused/gtest/gtest-all.cc
|
||||
+++ b/memkind-1.10.0/test/gtest_fused/gtest/gtest-all.cc
|
||||
@@ -7944,7 +7944,7 @@ void StackLowerThanAddress(const void* ptr, bool* result) {
|
||||
// Make sure AddressSanitizer does not tamper with the stack here.
|
||||
GTEST_ATTRIBUTE_NO_SANITIZE_ADDRESS_
|
||||
bool StackGrowsDown() {
|
||||
- int dummy;
|
||||
+ int dummy = 0;
|
||||
bool result;
|
||||
StackLowerThanAddress(&dummy, &result);
|
||||
return result;
|
||||
diff --git a/test/gtest_fused/gtest/gtest-all.cc b/test/gtest_fused/gtest/gtest-all.cc
|
||||
index 1120ce8..7a2a816 100644
|
||||
--- a/test/gtest_fused/gtest/gtest-all.cc
|
||||
+++ b/test/gtest_fused/gtest/gtest-all.cc
|
||||
@@ -7944,7 +7944,7 @@ void StackLowerThanAddress(const void* ptr, bool* result) {
|
||||
// Make sure AddressSanitizer does not tamper with the stack here.
|
||||
GTEST_ATTRIBUTE_NO_SANITIZE_ADDRESS_
|
||||
bool StackGrowsDown() {
|
||||
- int dummy;
|
||||
+ int dummy = 0;
|
||||
bool result;
|
||||
StackLowerThanAddress(&dummy, &result);
|
||||
return result;
|
13
memkind.spec
13
memkind.spec
@ -1,19 +1,18 @@
|
||||
%global gittag0 v1.10.0
|
||||
%global gittag0 v1.10.1
|
||||
|
||||
Name: memkind
|
||||
Summary: User Extensible Heap Manager
|
||||
Version: 1.10.0
|
||||
Release: 3%{?checkout}%{?dist}
|
||||
Version: 1.10.1
|
||||
Release: 1%{?checkout}%{?dist}
|
||||
License: BSD
|
||||
URL: http://memkind.github.io/memkind
|
||||
BuildRequires: automake libtool numactl-devel systemd gcc gcc-c++
|
||||
BuildRequires: automake libtool numactl-devel systemd gcc gcc-c++ daxctl-devel
|
||||
|
||||
# Upstream testing of memkind is done exclusively on x86_64; other archs
|
||||
# are unsupported but may work.
|
||||
ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
||||
Patch0: memkind-gcc11.patch
|
||||
|
||||
%description
|
||||
The memkind library is an user extensible heap manager built on top of
|
||||
@ -45,7 +44,6 @@ alpha release. Feedback on design or implementation is greatly appreciated.
|
||||
|
||||
%prep
|
||||
%setup -q -a 0 -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# It is required that we configure and build the jemalloc subdirectory
|
||||
@ -93,6 +91,9 @@ rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
||||
%{_mandir}/man3/pmemallocator.3.*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 07 2020 Rafael Aquini <aquini@linux.com> - 1.10.1-1
|
||||
- Update memkind source file to 1.10.1 upstream
|
||||
|
||||
* Wed Jul 29 2020 Jeff Law <law@redhat.com> - 1.10.0-3
|
||||
- Avoid uninitialized variable in testsuite
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (memkind-1.10.0.tar.gz) = dab87b51ba9773cc0841b196d87cf73b47bfaa20d1bba1297e4bc05ea2377853001ece92308dcf7285aaafaaeaeaf27d82e6faf9a187c99a2c20e977dd1e7f33
|
||||
SHA512 (memkind-1.10.1.tar.gz) = 9fa2eed4e07d0316ee97fcdb594df4fe2e5cf44a509f658a78986aad9b4f56a9c8fbe281073b93ba3c2870734167ad29b8643d69757733fdce25e45e6f0015a0
|
||||
|
Loading…
Reference in New Issue
Block a user