Fix rpmlint error dir-or-file-in-var-run for /var/run/memkind
Signed-off-by: Rafael Aquini <aquini@redhat.com>
This commit is contained in:
parent
521f6dc363
commit
e1a90f93aa
8
memkind-tmpfiles.d.conf.patch
Normal file
8
memkind-tmpfiles.d.conf.patch
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
diff --git a/memkind.conf b/memkind.conf
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..eb32f3b
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/memkind.conf
|
||||||
|
@@ -0,0 +1,2 @@
|
||||||
|
+d /run/memkind 0775 root root
|
||||||
|
+f /run/memkind/nodes-bandwith 0644 root root
|
29
memkind.spec
29
memkind.spec
@ -3,7 +3,7 @@
|
|||||||
Name: memkind
|
Name: memkind
|
||||||
Summary: User Extensible Heap Manager
|
Summary: User Extensible Heap Manager
|
||||||
Version: 0.3.0
|
Version: 0.3.0
|
||||||
Release: 4%{?checkout}%{?dist}
|
Release: 5%{?checkout}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://memkind.github.io/memkind
|
URL: http://memkind.github.io/memkind
|
||||||
@ -21,6 +21,7 @@ BuildRequires: automake libtool numactl-devel systemd
|
|||||||
ExclusiveArch: x86_64
|
ExclusiveArch: x86_64
|
||||||
|
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# Upstream ordinary fixes to v0.3.0
|
# Upstream ordinary fixes to v0.3.0
|
||||||
Patch0: 0001-Treshold-calculation-fixed.patch
|
Patch0: 0001-Treshold-calculation-fixed.patch
|
||||||
Patch1: 0002-Execute-tests-from-package-installation-directory.patch
|
Patch1: 0002-Execute-tests-from-package-installation-directory.patch
|
||||||
@ -30,6 +31,9 @@ Patch2: 0003-Fixed-memkind_hugetlb_check_available-which-was-retu.patch
|
|||||||
Patch3: systemd-service-backport.patch
|
Patch3: systemd-service-backport.patch
|
||||||
# Build error fixlet
|
# Build error fixlet
|
||||||
Patch4: f24-build-fixlet.patch
|
Patch4: f24-build-fixlet.patch
|
||||||
|
# tmpfiles.d config for /var/run/memkind state dir and contents
|
||||||
|
Patch5: memkind-tmpfiles.d.conf.patch
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The memkind library is an user extensible heap manager built on top of
|
The memkind library is an user extensible heap manager built on top of
|
||||||
@ -67,6 +71,7 @@ alpha release. Feedback on design or implementation is greatly appreciated.
|
|||||||
%patch2 -p1 -b .patch2.bkp
|
%patch2 -p1 -b .patch2.bkp
|
||||||
%patch3 -p1 -b .patch3.bkp
|
%patch3 -p1 -b .patch3.bkp
|
||||||
%patch4 -p1 -b .patch4.bkp
|
%patch4 -p1 -b .patch4.bkp
|
||||||
|
%patch5 -p1 -b .patch5.bkp
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# It is required that we configure and build the jemalloc subdirectory
|
# It is required that we configure and build the jemalloc subdirectory
|
||||||
@ -103,31 +108,28 @@ test -f configure || ./autogen.sh
|
|||||||
cd %{_builddir}/%{name}-%{version}
|
cd %{_builddir}/%{name}-%{version}
|
||||||
make install DESTDIR=%{buildroot} INSTALL='install -p'
|
make install DESTDIR=%{buildroot} INSTALL='install -p'
|
||||||
install -Dpm 644 %{name}.service %{buildroot}/%{_unitdir}/%{name}.service
|
install -Dpm 644 %{name}.service %{buildroot}/%{_unitdir}/%{name}.service
|
||||||
|
install -Dpm 644 %{name}.conf %{buildroot}/%{_tmpfilesdir}/%{name}.conf
|
||||||
mkdir -p %{buildroot}/%{_sysconfdir}/%{name}
|
mkdir -p %{buildroot}/%{_sysconfdir}/%{name}
|
||||||
mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
|
mkdir -p %{buildroot}/run/%{name}
|
||||||
rm -f %{buildroot}/%{_libdir}/lib%{name}.{l,}a
|
rm -f %{buildroot}/%{_libdir}/lib%{name}.{l,}a
|
||||||
rm -f %{buildroot}/%{_libdir}/lib{numakind,autohbw}.*
|
rm -f %{buildroot}/%{_libdir}/lib{numakind,autohbw}.*
|
||||||
rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
||||||
|
|
||||||
%post
|
%post -p /sbin/ldconfig
|
||||||
/sbin/ldconfig
|
|
||||||
touch %{_localstatedir}/run/%{name}/node-bandwidth
|
|
||||||
|
|
||||||
%preun
|
|
||||||
rm -f %{_localstatedir}/run/%{name}/node-bandwidth
|
|
||||||
|
|
||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%license %{_docdir}/%{name}/COPYING
|
|
||||||
%doc %{_docdir}/%{name}/README
|
|
||||||
%dir %{_docdir}/%{name}
|
|
||||||
%ghost %dir %{_localstatedir}/run/%{name}
|
|
||||||
%{_libdir}/lib%{name}.so.*
|
%{_libdir}/lib%{name}.so.*
|
||||||
%{_bindir}/%{name}-hbw-nodes
|
%{_bindir}/%{name}-hbw-nodes
|
||||||
%{_sbindir}/%{name}-pmtt
|
%{_sbindir}/%{name}-pmtt
|
||||||
%{_unitdir}/%{name}.service
|
%{_unitdir}/%{name}.service
|
||||||
|
%{_tmpfilesdir}/%{name}.conf
|
||||||
|
%ghost %dir /run/%{name}
|
||||||
|
%dir %{_docdir}/%{name}
|
||||||
|
%doc %{_docdir}/%{name}/README
|
||||||
|
%license %{_docdir}/%{name}/COPYING
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -138,6 +140,9 @@ rm -f %{_localstatedir}/run/%{name}/node-bandwidth
|
|||||||
%{_mandir}/man3/%{name}*.3.*
|
%{_mandir}/man3/%{name}*.3.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 07 2016 Rafael Aquini <aquini@linux.com> - 0.3.0-5
|
||||||
|
- Fix rpmlint error dir-or-file-in-var-run for /var/run/memkind
|
||||||
|
|
||||||
* Sat Feb 06 2016 Rafael Aquini <aquini@linux.com> - 0.3.0-4
|
* Sat Feb 06 2016 Rafael Aquini <aquini@linux.com> - 0.3.0-4
|
||||||
- Update upstream fixes for memkind-0.3.0
|
- Update upstream fixes for memkind-0.3.0
|
||||||
- Switch old init.d scripts for systemd unit service
|
- Switch old init.d scripts for systemd unit service
|
||||||
|
Loading…
Reference in New Issue
Block a user