Fix build issues after https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
Signed-off-by: Rafael Aquini <aquini@linux.com>
This commit is contained in:
parent
0415781a84
commit
b235cc94fa
17
Makefile.am.patch
Normal file
17
Makefile.am.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 94937c2..f9763c8 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -684,9 +684,11 @@ end
|
||||
endef
|
||||
|
||||
static_lib: libmemkind.la
|
||||
- bash -c "ar -M < <(echo -e '$(ar_prog)')"
|
||||
+ echo -e "$(ar_prog)" > arprog.txt
|
||||
+ ar -M < arprog.txt
|
||||
cp libmemkind.a .libs/
|
||||
rm libmemkind.a
|
||||
+ rm arprog.txt
|
||||
|
||||
JEMALLOC_CONFIG = --enable-autogen @min_lg_align_opt@ --without-export --with-version=5.3.0-0-g54eaed1d8b56b1aa528be3bdd1877e59c56fa90c \
|
||||
@jemalloc_build_type_flags@ @memkind_initial_exec_tls@ --with-jemalloc-prefix=@memkind_prefix@ \
|
17
memkind.spec
17
memkind.spec
@ -1,12 +1,15 @@
|
||||
%global gittag0 v1.14.0
|
||||
# WORKAROUND to avoid breaking the build at the atrocious libtool shell scrip
|
||||
# due to RPM environmental macros being lost for the subshells
|
||||
%undefine _package_note_file
|
||||
|
||||
Name: memkind
|
||||
Summary: User Extensible Heap Manager
|
||||
Version: 1.14.0
|
||||
Release: 2%{?checkout}%{?dist}
|
||||
Release: 3%{?checkout}%{?dist}
|
||||
License: BSD
|
||||
URL: http://memkind.github.io/memkind
|
||||
BuildRequires: make
|
||||
BuildRequires: make patch
|
||||
BuildRequires: automake libtool numactl-devel systemd gcc gcc-c++ daxctl-devel
|
||||
|
||||
# Upstream testing of memkind is done exclusively on x86_64; other archs
|
||||
@ -15,6 +18,10 @@ ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
||||
|
||||
# unbreak the atrocious autotools Makefile.am construction for
|
||||
# libmemkind archive creation target
|
||||
Patch0: Makefile.am.patch
|
||||
|
||||
%description
|
||||
The memkind library is an user extensible heap manager built on top of
|
||||
jemalloc which enables control of memory characteristics and a
|
||||
@ -45,6 +52,7 @@ alpha release. Feedback on design or implementation is greatly appreciated.
|
||||
|
||||
%prep
|
||||
%setup -q -a 0 -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
cd %{_builddir}/%{name}-%{version}
|
||||
@ -54,7 +62,7 @@ test -f configure || ./autogen.sh
|
||||
--includedir=%{_includedir} --sbindir=%{_sbindir} --bindir=%{_bindir} \
|
||||
--mandir=%{_mandir} --docdir=%{_docdir}/%{name} \
|
||||
CFLAGS="$RPM_OPT_FLAGS -std=gnu99" LDFLAGS="%{build_ldflags}"
|
||||
%{__make} V=1 %{?_smp_mflags}
|
||||
%{__make} V=1
|
||||
|
||||
%install
|
||||
cd %{_builddir}/%{name}-%{version}
|
||||
@ -100,6 +108,9 @@ rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
||||
%{_mandir}/man3/libmemtier.3.*
|
||||
|
||||
%changelog
|
||||
* Tue Jan 24 2023 Rafael Aquini <aquini@linux.com> - 1.14.0-3
|
||||
- Fix build issues after https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user