import memkind-1.11.0-2.el9
This commit is contained in:
parent
c216a9a2a5
commit
ac0ef23156
13
SOURCES/configure.ac.patch
Normal file
13
SOURCES/configure.ac.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 0659008..43f79d8 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -136,7 +136,7 @@ fi
|
||||||
|
[enable_secure="1"]
|
||||||
|
)
|
||||||
|
if test "x$enable_secure" = "x1" ; then
|
||||||
|
- CFLAGS="$CFLAGS -fstack-protector"
|
||||||
|
+ CFLAGS="$CFLAGS -fstack-protector-strong -fstack-clash-protection"
|
||||||
|
LDFLAGS="$LDFLAGS -Wl,-z,relro,-z,now"
|
||||||
|
|
||||||
|
if test "$CFLAGS" != "${CFLAGS%-O0*}" ; then # if CFLAGS contains -O0
|
@ -3,7 +3,7 @@
|
|||||||
Name: memkind
|
Name: memkind
|
||||||
Summary: User Extensible Heap Manager
|
Summary: User Extensible Heap Manager
|
||||||
Version: 1.11.0
|
Version: 1.11.0
|
||||||
Release: 1%{?checkout}%{?dist}
|
Release: 2%{?checkout}%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://memkind.github.io/memkind
|
URL: http://memkind.github.io/memkind
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
@ -14,6 +14,7 @@ BuildRequires: automake libtool numactl-devel systemd gcc gcc-c++ daxctl-devel
|
|||||||
ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64
|
ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64
|
||||||
|
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: configure.ac.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The memkind library is an user extensible heap manager built on top of
|
The memkind library is an user extensible heap manager built on top of
|
||||||
@ -44,19 +45,18 @@ pre-alpha: bugs may exist and the interfaces may be subject to change prior to
|
|||||||
alpha release. Feedback on design or implementation is greatly appreciated.
|
alpha release. Feedback on design or implementation is greatly appreciated.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a 0 -n %{name}-%{version}
|
%setup -q -a 0
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# It is required that we configure and build the jemalloc subdirectory
|
|
||||||
# before we configure and start building the top level memkind directory.
|
|
||||||
# To ensure the memkind build step is able to discover the output
|
|
||||||
# of the jemalloc build we must create an 'obj' directory, and build
|
|
||||||
# from within that directory.
|
|
||||||
cd %{_builddir}/%{name}-%{version}
|
cd %{_builddir}/%{name}-%{version}
|
||||||
echo %{version} > %{_builddir}/%{name}-%{version}/VERSION
|
echo %{version} > %{_builddir}/%{name}-%{version}/VERSION
|
||||||
./build.sh --prefix=%{_prefix} --includedir=%{_includedir} --libdir=%{_libdir} \
|
test -f configure || ./autogen.sh
|
||||||
--bindir=%{_bindir} --docdir=%{_docdir}/%{name} --mandir=%{_mandir} \
|
%configure --enable-secure --enable-tls --prefix=%{_prefix} --libdir=%{_libdir} \
|
||||||
--sbindir=%{_sbindir}
|
--includedir=%{_includedir} --sbindir=%{_sbindir} --bindir=%{_bindir} \
|
||||||
|
--mandir=%{_mandir} --docdir=%{_docdir}/%{name} \
|
||||||
|
CFLAGS="$RPM_OPT_FLAGS -std=gnu99" LDFLAGS="%{build_ldflags}"
|
||||||
|
%{__make} V=1 %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
cd %{_builddir}/%{name}-%{version}
|
cd %{_builddir}/%{name}-%{version}
|
||||||
@ -92,6 +92,9 @@ rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
|||||||
%{_mandir}/man3/pmemallocator.3.*
|
%{_mandir}/man3/pmemallocator.3.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 28 2022 Rafael Aquini <aquini@redhat.com> - 1.11.0-2
|
||||||
|
- Fix annocheck pie test failure (2044880)
|
||||||
|
|
||||||
* Fri Oct 08 2021 Rafael Aquini <aquini@redhat.com> - 1.11.0-1
|
* Fri Oct 08 2021 Rafael Aquini <aquini@redhat.com> - 1.11.0-1
|
||||||
- Update memkind source file to 1.11.0 upstream
|
- Update memkind source file to 1.11.0 upstream
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user