memkind package is retired on branch c10s for CS-2314
This commit is contained in:
parent
fb48e01708
commit
2668444e83
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +0,0 @@
|
||||
*.tar.gz
|
@ -1,17 +0,0 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 94937c2..f9763c8 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -684,9 +684,11 @@ end
|
||||
endef
|
||||
|
||||
static_lib: libmemkind.la
|
||||
- bash -c "ar -M < <(echo -e '$(ar_prog)')"
|
||||
+ echo -e "$(ar_prog)" > arprog.txt
|
||||
+ ar -M < arprog.txt
|
||||
cp libmemkind.a .libs/
|
||||
rm libmemkind.a
|
||||
+ rm arprog.txt
|
||||
|
||||
JEMALLOC_CONFIG = --enable-autogen @min_lg_align_opt@ --without-export --with-version=5.3.0-0-g54eaed1d8b56b1aa528be3bdd1877e59c56fa90c \
|
||||
@jemalloc_build_type_flags@ @memkind_initial_exec_tls@ --with-jemalloc-prefix=@memkind_prefix@ \
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
memkind package is retired on branch c10s for CS-2314
|
@ -1,6 +0,0 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-10
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
246
memkind.spec
246
memkind.spec
@ -1,246 +0,0 @@
|
||||
%global gittag0 v1.14.0
|
||||
# WORKAROUND to avoid breaking the build at the atrocious libtool shell scrip
|
||||
# due to RPM environmental macros being lost for the subshells
|
||||
%undefine _package_note_file
|
||||
|
||||
Name: memkind
|
||||
Summary: User Extensible Heap Manager
|
||||
Version: 1.14.0
|
||||
Release: 8%{?checkout}%{?dist}
|
||||
License: BSD-2-Clause
|
||||
URL: http://memkind.github.io/memkind
|
||||
BuildRequires: make patch
|
||||
BuildRequires: automake libtool numactl-devel systemd gcc gcc-c++ daxctl-devel
|
||||
|
||||
# Upstream testing of memkind is done exclusively on x86_64; other archs
|
||||
# are unsupported but may work.
|
||||
ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/%{gittag0}/%{name}-%{version}.tar.gz
|
||||
|
||||
# unbreak the atrocious autotools Makefile.am construction for
|
||||
# libmemkind archive creation target
|
||||
Patch0: Makefile.am.patch
|
||||
|
||||
%description
|
||||
The memkind library is an user extensible heap manager built on top of
|
||||
jemalloc which enables control of memory characteristics and a
|
||||
partitioning of the heap between kinds of memory. The kinds of memory
|
||||
are defined by operating system memory policies that have been applied
|
||||
to virtual address ranges. Memory characteristics supported by
|
||||
memkind without user extension include control of NUMA and page size
|
||||
features. The jemalloc non-standard interface has been extended to
|
||||
enable specialized arenas to make requests for virtual memory from the
|
||||
operating system through the memkind partition interface. Through the
|
||||
other memkind interfaces the user can control and extend memory
|
||||
partition features and allocate memory while selecting enabled
|
||||
features. This software is being made available for early evaluation.
|
||||
Feedback on design or implementation is greatly appreciated.
|
||||
|
||||
%package devel
|
||||
Summary: Memkind User Extensible Heap Manager development lib and tools
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Install header files and development aids to link memkind library
|
||||
into applications. The memkind library is an user extensible heap manager
|
||||
built on top of jemalloc which enables control of memory characteristics and
|
||||
heap partitioning on different kinds of memory. This software is being made
|
||||
available for early evaluation. The memkind library should be considered
|
||||
pre-alpha: bugs may exist and the interfaces may be subject to change prior to
|
||||
alpha release. Feedback on design or implementation is greatly appreciated.
|
||||
|
||||
%prep
|
||||
%setup -q -a 0 -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
cd %{_builddir}/%{name}-%{version}
|
||||
echo %{version} > %{_builddir}/%{name}-%{version}/VERSION
|
||||
test -f configure || ./autogen.sh
|
||||
%configure --enable-secure --enable-tls --prefix=%{_prefix} --libdir=%{_libdir} \
|
||||
--includedir=%{_includedir} --sbindir=%{_sbindir} --bindir=%{_bindir} \
|
||||
--mandir=%{_mandir} --docdir=%{_docdir}/%{name} \
|
||||
CFLAGS="$RPM_OPT_FLAGS -std=gnu99" LDFLAGS="%{build_ldflags}"
|
||||
%{__make} V=1
|
||||
|
||||
%install
|
||||
cd %{_builddir}/%{name}-%{version}
|
||||
make DESTDIR=%{buildroot} INSTALL='install -p' install
|
||||
rm -f %{buildroot}/%{_libdir}/lib%{name}.{l,}a
|
||||
rm -f %{buildroot}/%{_libdir}/libautohbw.{l,}a
|
||||
rm -f %{buildroot}/%{_libdir}/libmemtier.{l,}a
|
||||
rm -f %{buildroot}/%{_docdir}/%{name}/VERSION
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%{_bindir}/memtier
|
||||
%{_libdir}/lib%{name}.so.*
|
||||
%{_libdir}/libautohbw.so.*
|
||||
%{_libdir}/libmemtier.so.*
|
||||
%{_bindir}/%{name}-hbw-nodes
|
||||
%{_bindir}/%{name}-auto-dax-kmem-nodes
|
||||
%{_mandir}/man1/%{name}*.1.*
|
||||
%{_mandir}/man1/memtier.1.*
|
||||
%{_mandir}/man7/autohbw.7.*
|
||||
%{_mandir}/man7/memtier.7.*
|
||||
%{_mandir}/man7/libmemtier.7.*
|
||||
%dir %{_docdir}/%{name}
|
||||
%doc %{_docdir}/%{name}/README
|
||||
%license %{_docdir}/%{name}/COPYING
|
||||
|
||||
%files devel
|
||||
%{_includedir}/%{name}*.h
|
||||
%{_includedir}/hbwmalloc.h
|
||||
%{_includedir}/hbw_allocator.h
|
||||
%{_includedir}/pmem_allocator.h
|
||||
%{_includedir}/fixed_allocator.h
|
||||
%{_libdir}/lib%{name}.so
|
||||
%{_libdir}/libautohbw.so
|
||||
%{_libdir}/libmemtier.so
|
||||
%{_libdir}/pkgconfig/memkind.pc
|
||||
%{_mandir}/man3/%{name}*.3.*
|
||||
%{_mandir}/man3/hbwmalloc.3.*
|
||||
%{_mandir}/man3/hbwallocator.3.*
|
||||
%{_mandir}/man3/pmemallocator.3.*
|
||||
%{_mandir}/man3/fixedallocator.3.*
|
||||
%{_mandir}/man3/libmemtier.3.*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.14.0-8
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Wed Oct 8 2023 Rafael Aquini <aquini@linux.com> - 1.14.0-5
|
||||
- SPDX migration
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Jan 24 2023 Rafael Aquini <aquini@linux.com> - 1.14.0-3
|
||||
- Fix build issues after https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2023 Rafael Aquini <aquini@linux.com> - 1.14.0-1
|
||||
- Update memkind source file to 1.14.0 upstream
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jan 28 2022 Rafael Aquini <aquini@linux.com> - 1.13.0-1
|
||||
- Update memkind source file to 1.13.0 upstream
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Mon Aug 23 2021 Rafael Aquini <aquini@linux.com> - 1.11.0-1
|
||||
- Update memkind source file to 1.11.0 upstream
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Thu Oct 15 2020 Rafael Aquini <aquini@linux.com> - 1.10.1-2
|
||||
- Work around false positive warning with gcc-11
|
||||
|
||||
* Wed Oct 07 2020 Rafael Aquini <aquini@linux.com> - 1.10.1-1
|
||||
- Update memkind source file to 1.10.1 upstream
|
||||
|
||||
* Wed Jul 29 2020 Jeff Law <law@redhat.com> - 1.10.0-3
|
||||
- Avoid uninitialized variable in testsuite
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Feb 01 2020 Rafael Aquini <aquini@linux.com> - 1.10.0-1
|
||||
- Update memkind source file to 1.10.0 upstream
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Dec 14 2019 Jeff Law <law@redhat.com> - 1.9.0-3
|
||||
- Fix missing #include for gcc-10
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.9.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Jul 10 2019 Rafael Aquini <aquini@linux.com> - 1.9.0-1
|
||||
- Update memkind source file to 1.9.0 upstream
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 20 2018 Rafael Aquini <aquini@linux.com> - 1.7.0-3
|
||||
- Rebuild to fix removal of GCC from buildroots (1604813)
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Mar 23 2018 Rafael Aquini <aquini@linux.com> - 1.7.0-1
|
||||
- Update memkind source file to 1.7.0 upstream
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Mar 27 2017 Rafael Aquini <aquini@linux.com> - 1.5.0-1
|
||||
- Update memkind source file to 1.5.0 upstream
|
||||
|
||||
* Fri Feb 17 2017 Rafael Aquini <aquini@linux.com> - 1.4.0-1
|
||||
- Update memkind source file to 1.4.0 upstream
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Nov 16 2016 Rafael Aquini <aquini@linux.com> - 1.3.0-1
|
||||
- Update memkind source file to 1.3.0 upstream
|
||||
|
||||
* Wed Jun 08 2016 Rafael Aquini <aquini@linux.com> - 1.1.0-1
|
||||
- Update memkind source file to 1.1.0 upstream
|
||||
|
||||
* Thu Mar 17 2016 Rafael Aquini <aquini@linux.com> - 1.0.0-1
|
||||
- Update memkind source file to 1.0.0 upstream
|
||||
|
||||
* Sun Feb 07 2016 Rafael Aquini <aquini@linux.com> - 0.3.0-5
|
||||
- Fix rpmlint error dir-or-file-in-var-run for /var/run/memkind
|
||||
|
||||
* Sat Feb 06 2016 Rafael Aquini <aquini@linux.com> - 0.3.0-4
|
||||
- Update upstream fixes for memkind-0.3.0
|
||||
- Switch old init.d scripts for systemd unit service
|
||||
- Fix fc24 build error
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 17 2015 Rafael Aquini <aquini@linux.com> - 0.3.0-2
|
||||
- Minor clean-ups and adjustments required for the RPM
|
||||
|
||||
* Tue Nov 17 2015 Rafael Aquini <aquini@linux.com> - 0.3.0-1
|
||||
- Update memkind source file to 0.3.0 upstream
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-4.20150525git
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon May 25 2015 Rafael Aquini <aquini@linux.com> - 0.2.2-3.20150525git
|
||||
- Get rid of obsolete m4 macros usage on autotool scripts
|
||||
|
||||
* Mon May 18 2015 Rafael Aquini <aquini@linux.com> - 0.2.2-2.20150525git
|
||||
- Fix to BuildRequires and License Text Marker in spec file (1222709#c1)
|
||||
|
||||
* Mon May 18 2015 Rafael Aquini <aquini@linux.com> - 0.2.2-1.20150518git
|
||||
- Initial RPM packaging for Fedora
|
1
sources
1
sources
@ -1 +0,0 @@
|
||||
SHA512 (memkind-1.14.0.tar.gz) = 313c97c28be817abc86929565063859ec475bad31871a8ebed1f6ebca6b1c5f6b8c1d1ae947f694320b4a7c9998755681ac5d13a865ec8993440fcd8b32d7b94
|
@ -1,9 +0,0 @@
|
||||
#!/bin/bash -x
|
||||
|
||||
WORKDIR="${1}"
|
||||
|
||||
rpmbuild -bp $WORKDIR/*.spec --nodeps --define "_sourcedir $WORKDIR" --define "_builddir $WORKDIR/source"
|
||||
mkdir $WORKDIR/temp
|
||||
mv $WORKDIR/source/*/* $WORKDIR/temp/
|
||||
rm -rf $WORKDIR/source/*
|
||||
mv $WORKDIR/temp/* $WORKDIR/source/
|
@ -1,26 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
RETCODE=0
|
||||
TMPTESTSFILE=/tmp/memkind-tests.log
|
||||
TMPBUILDFILE=/tmp/memkind-build.log
|
||||
|
||||
# re-play the build
|
||||
pushd source
|
||||
./build.sh &> $TMPBUILDFILE
|
||||
RETCODE=$?
|
||||
if [ $RETCODE != 0 ]; then
|
||||
cat $TMPBUILDFILE
|
||||
exit $RETCODE
|
||||
fi
|
||||
|
||||
pushd test
|
||||
|
||||
# run all tests filtering out those that are not meant
|
||||
# to pass on a small VM
|
||||
./all_tests --gtest_filter=-BATest.test_TC_MEMKIND_hbwmalloc_Pref_CheckAvailable:DlopenTest.*:HbwVerifyFunctionTest.*:NegativeTestHuge.test_TC_MEMKIND_hbwmalloc_memalign_psize_Interleave_Policy_PAGE_SIZE_2MB:HBW*.*:BATest.test_TC_MEMKIND_free_ext_MEMKIND_GBTLB_4096_bytes &> $TMPTESTSFILE
|
||||
RETCODE=$?
|
||||
if [ $RETCODE != 0 ]; then
|
||||
cat $TMPTESTSFILE
|
||||
fi
|
||||
exit $RETCODE
|
||||
|
@ -1,5 +0,0 @@
|
||||
---
|
||||
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
m: 4G
|
@ -1,38 +0,0 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
tags:
|
||||
- classic
|
||||
vars:
|
||||
# standard-test-basic directory for tests are relative to {{ tenv_workdir }}
|
||||
tenv_workdir: /var/str
|
||||
pre_tasks:
|
||||
- import_role:
|
||||
name: standard-test-source
|
||||
vars:
|
||||
fetch_only: True
|
||||
- name: Copy files including source to test environment
|
||||
synchronize:
|
||||
src: "{{ playbook_dir }}/.."
|
||||
dest: "{{ tenv_workdir }}"
|
||||
mode: push
|
||||
ssh_args: "-o UserKnownHostsFile=/dev/null"
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
required_packages:
|
||||
- automake
|
||||
- libtool
|
||||
- numactl-devel
|
||||
- systemd
|
||||
- gcc
|
||||
- gcc-c++
|
||||
- make
|
||||
- gawk
|
||||
- python3
|
||||
- rpm-build
|
||||
tests:
|
||||
- prepare-source:
|
||||
dir: ./
|
||||
run: ./memkind-prepsource.sh "{{tenv_workdir}}"
|
||||
- memkind_test:
|
||||
dir: ./
|
||||
run: ./memkind-test.sh
|
Loading…
Reference in New Issue
Block a user