import meanwhile-1.1.0-23.el8

This commit is contained in:
CentOS Sources 2020-08-31 18:26:18 +00:00 committed by Andrew Lukoshko
commit 06c8c8b55a
8 changed files with 527 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/meanwhile-1.1.0.tar.gz

1
.meanwhile.metadata Normal file
View File

@ -0,0 +1 @@
e0e82449ecde20e7499b56ac04eeaf6a2156c1ce SOURCES/meanwhile-1.1.0.tar.gz

View File

@ -0,0 +1,13 @@
--- src/st_list.c.orig 2008-08-27 11:32:47.000000000 +1000
+++ src/st_list.c 2008-08-27 10:24:34.000000000 +1000
@@ -662,7 +662,9 @@
g_return_if_fail(b != NULL);
mwString_get(b, &str);
- list_get(str, l);
- g_free(str);
+ if (str) {
+ list_get(str, l);
+ g_free(str);
+ }
}

View File

@ -0,0 +1,21 @@
# User Mikael Berthe <mikael.berthe@lilotux.net>
# Date 1194544713 -3600
Fix file transfers with recent Sametime servers
It seems that the last guint32_get() fails when Meanwhile receives
the FT offer.
I think we can skip it -- works for me but I can't check it with an
older server.
diff -r 4aabc56c0e5f src/srvc_ft.c
--- a/src/srvc_ft.c Tue Nov 06 11:46:26 2007 +0100
+++ b/src/srvc_ft.c Thu Nov 08 18:58:33 2007 +0100
@@ -142,7 +142,7 @@ static void recv_channelCreate(struct mw
mwString_get(b, &fnm); /* offered filename */
mwString_get(b, &txt); /* offering message */
guint32_get(b, &size); /* size of offered file */
- guint32_get(b, &junk); /* unknown */
+ /* guint32_get(b, &junk); */ /* unknown */
/* and we just skip an unknown guint16 at the end */
b_err = mwGetBuffer_error(b);

View File

@ -0,0 +1,279 @@
Index: meanwhile-1.1.0/samples/logging_proxy.c
===================================================================
--- meanwhile-1.1.0.orig/samples/logging_proxy.c
+++ meanwhile-1.1.0/samples/logging_proxy.c
@@ -25,7 +25,6 @@
#include <unistd.h>
#include <glib.h>
-#include <glib/glist.h>
#include <mw_cipher.h>
#include <mw_common.h>
Index: meanwhile-1.1.0/samples/login_server.c
===================================================================
--- meanwhile-1.1.0.orig/samples/login_server.c
+++ meanwhile-1.1.0/samples/login_server.c
@@ -19,7 +19,6 @@
#include <unistd.h>
#include <glib.h>
-#include <glib/glist.h>
#include <mw_cipher.h>
#include <mw_common.h>
Index: meanwhile-1.1.0/samples/nocipher_proxy.c
===================================================================
--- meanwhile-1.1.0.orig/samples/nocipher_proxy.c
+++ meanwhile-1.1.0/samples/nocipher_proxy.c
@@ -29,7 +29,6 @@
#include <unistd.h>
#include <glib.h>
-#include <glib/glist.h>
#include <mw_common.h>
#include <mw_message.h>
Index: meanwhile-1.1.0/samples/redirect_server.c
===================================================================
--- meanwhile-1.1.0.orig/samples/redirect_server.c
+++ meanwhile-1.1.0/samples/redirect_server.c
@@ -22,7 +22,6 @@
#include <unistd.h>
#include <glib.h>
-#include <glib/glist.h>
#include <mw_common.h>
#include <mw_message.h>
Index: meanwhile-1.1.0/src/channel.c
===================================================================
--- meanwhile-1.1.0.orig/src/channel.c
+++ meanwhile-1.1.0/src/channel.c
@@ -19,8 +19,6 @@
*/
#include <glib.h>
-#include <glib/ghash.h>
-#include <glib/glist.h>
#include <string.h>
#include "mw_channel.h"
Index: meanwhile-1.1.0/src/mw_debug.c
===================================================================
--- meanwhile-1.1.0.orig/src/mw_debug.c
+++ meanwhile-1.1.0/src/mw_debug.c
@@ -19,7 +19,7 @@
*/
-#include <glib/gstring.h>
+#include <glib.h>
#include "mw_debug.h"
Index: meanwhile-1.1.0/src/mw_message.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_message.h
+++ meanwhile-1.1.0/src/mw_message.h
@@ -22,7 +22,7 @@
#define _MW_MESSAGE_H
-#include <glib/glist.h>
+#include <glib.h>
#include "mw_common.h"
Index: meanwhile-1.1.0/src/mw_srvc_conf.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_srvc_conf.h
+++ meanwhile-1.1.0/src/mw_srvc_conf.h
@@ -22,7 +22,7 @@
#define _MW_SRVC_CONF_H
-#include <glib/glist.h>
+#include <glib.h>
#include "mw_common.h"
Index: meanwhile-1.1.0/src/mw_srvc_dir.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_srvc_dir.h
+++ meanwhile-1.1.0/src/mw_srvc_dir.h
@@ -22,7 +22,6 @@
#include <glib.h>
-#include <glib/glist.h>
#ifdef __cplusplus
Index: meanwhile-1.1.0/src/mw_srvc_place.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_srvc_place.h
+++ meanwhile-1.1.0/src/mw_srvc_place.h
@@ -22,7 +22,7 @@
#define _MW_SRVC_PLACE_H
-#include <glib/glist.h>
+#include <glib.h>
#include "mw_common.h"
Index: meanwhile-1.1.0/src/mw_srvc_resolve.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_srvc_resolve.h
+++ meanwhile-1.1.0/src/mw_srvc_resolve.h
@@ -23,7 +23,6 @@
#include <glib.h>
-#include <glib/glist.h>
#ifdef __cplusplus
Index: meanwhile-1.1.0/src/mw_st_list.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_st_list.h
+++ meanwhile-1.1.0/src/mw_st_list.h
@@ -30,7 +30,6 @@
#include <glib.h>
-#include <glib/glist.h>
#include "mw_common.h"
Index: meanwhile-1.1.0/src/mw_util.h
===================================================================
--- meanwhile-1.1.0.orig/src/mw_util.h
+++ meanwhile-1.1.0/src/mw_util.h
@@ -23,9 +23,6 @@
#include <glib.h>
-#include <glib/ghash.h>
-#include <glib/glist.h>
-
#define map_guint_new() \
g_hash_table_new(g_direct_hash, g_direct_equal)
Index: meanwhile-1.1.0/src/srvc_aware.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_aware.c
+++ meanwhile-1.1.0/src/srvc_aware.c
@@ -19,8 +19,6 @@
*/
#include <glib.h>
-#include <glib/ghash.h>
-#include <glib/glist.h>
#include <string.h>
#include "mw_channel.h"
Index: meanwhile-1.1.0/src/srvc_conf.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_conf.c
+++ meanwhile-1.1.0/src/srvc_conf.c
@@ -19,8 +19,6 @@
*/
#include <glib.h>
-#include <glib/ghash.h>
-#include <glib/glist.h>
#include <stdio.h>
#include <stdlib.h>
Index: meanwhile-1.1.0/src/srvc_dir.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_dir.c
+++ meanwhile-1.1.0/src/srvc_dir.c
@@ -18,7 +18,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <glib/ghash.h>
+#include <glib.h>
#include "mw_channel.h"
#include "mw_common.h"
Index: meanwhile-1.1.0/src/srvc_ft.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_ft.c
+++ meanwhile-1.1.0/src/srvc_ft.c
@@ -19,7 +19,7 @@
*/
-#include <glib/glist.h>
+#include <glib.h>
#include "mw_channel.h"
#include "mw_common.h"
Index: meanwhile-1.1.0/src/srvc_im.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_im.c
+++ meanwhile-1.1.0/src/srvc_im.c
@@ -19,7 +19,6 @@
*/
#include <glib.h>
-#include <glib/glist.h>
#include <string.h>
#include "mw_channel.h"
Index: meanwhile-1.1.0/src/srvc_place.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_place.c
+++ meanwhile-1.1.0/src/srvc_place.c
@@ -19,8 +19,6 @@
*/
#include <glib.h>
-#include <glib/ghash.h>
-#include <glib/glist.h>
#include <stdio.h>
#include <stdlib.h>
Index: meanwhile-1.1.0/src/srvc_resolve.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_resolve.c
+++ meanwhile-1.1.0/src/srvc_resolve.c
@@ -18,7 +18,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <glib/ghash.h>
+#include <glib.h>
#include "mw_channel.h"
#include "mw_common.h"
Index: meanwhile-1.1.0/src/srvc_store.c
===================================================================
--- meanwhile-1.1.0.orig/src/srvc_store.c
+++ meanwhile-1.1.0/src/srvc_store.c
@@ -18,7 +18,7 @@
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-#include <glib/glist.h>
+#include <glib.h>
#include "mw_channel.h"
#include "mw_debug.h"
Index: meanwhile-1.1.0/src/st_list.c
===================================================================
--- meanwhile-1.1.0.orig/src/st_list.c
+++ meanwhile-1.1.0/src/st_list.c
@@ -20,7 +20,7 @@
#include <stdio.h>
#include <string.h>
-#include <glib/gstring.h>
+#include <glib.h>
#include "mw_debug.h"
#include "mw_util.h"

View File

@ -0,0 +1,21 @@
diff -purN meanwhile-1.1.0.orig/src/mw_debug.c meanwhile-1.1.0/src/mw_debug.c
--- meanwhile-1.1.0.orig/src/mw_debug.c 2013-12-03 14:32:31.828241985 +1100
+++ meanwhile-1.1.0/src/mw_debug.c 2013-12-03 14:34:30.152967856 +1100
@@ -92,7 +92,7 @@ void mw_debug_datav(const guchar *buf, g
}
pretty_print(str, buf, len);
- g_debug(str->str);
+ g_debug("%s", str->str);
g_string_free(str, TRUE);
}
@@ -149,7 +149,7 @@ void mw_mailme_datav(const guchar *buf,
g_string_append(str, MW_MAILME_CUT_STOP);
- g_debug(str->str);
+ g_debug("%s", str->str);
g_string_free(str, TRUE);
#else

View File

@ -0,0 +1,21 @@
# User Mikael Berthe <mikael.berthe@lilotux.net>
# Date 1195749751 -3600
Fix Awareness status timestamps with recent Sametime clients
For some reason the status timestamps I receive from people with a recent
Sametime client make no sense. This patch simply sets the timestamp to 0,
as I have no idea how to interpret these time values.
diff -r 17977a4e7da1 -r e7601af90b31 src/common.c
--- a/src/common.c Thu Nov 08 18:58:33 2007 +0100
+++ b/src/common.c Thu Nov 22 17:42:31 2007 +0100
@@ -688,6 +688,9 @@ void mwUserStatus_get(struct mwGetBuffer
guint16_get(b, &stat->status);
guint32_get(b, &stat->time);
mwString_get(b, &stat->desc);
+
+ // Quick'n ugly hack for recent Sametime clients
+ stat->time = 0;
}

170
SPECS/meanwhile.spec Normal file
View File

@ -0,0 +1,170 @@
Name: meanwhile
Version: 1.1.0
Release: 23%{?dist}
Summary: Lotus Sametime Community Client library
License: LGPLv2+
URL: http://%{name}.sourceforge.net
# The source for this package was pulled from upstream's vcs. Use the following commands to generate the tarball:
# cvs -d:pserver:anonymous@meanwhile.cvs.sourceforge.net:/cvsroot/meanwhile co -d meanwhile-1.1.0 -r meanwhile_v1_1_0 meanwhile
# tar -cvzf meanwhile-1.1.0.tar.gz meanwhile-1.1.0
Source: %{name}-%{version}.tar.gz
Patch0: %{name}-crash.patch
Patch1: %{name}-fix-glib-headers.patch
Patch2: %{name}-file-transfer.patch
Patch3: %{name}-status-timestamp-workaround.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1037196
Patch4: %{name}-format-security-fix.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: glib2-devel
BuildRequires: doxygen
BuildRequires: libtool
%description
The heart of the %{name} Project is the %{name} library, providing the basic
Lotus Sametime session functionality along with the core services; Presence
Awareness, Instant Messaging, Multi-user Conferencing, Preferences Storage,
Identity Resolution, and File Transfer.
%package devel
Summary: Header files, libraries and development documentation for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: glib2-devel
%description devel
This package contains the header files, static libraries and development
documentation for %{name}. If you like to develop programs using %{name}, you
will need to install %{name}-devel.
%package doc
Summary: Documentation for the %{name} library
License: GFDL
BuildArch: noarch
Provides: meanwhile-docs = %{version}-%{release}
Obsoletes: meanwhile-docs < 1.1.10-11
%description doc
Documentation for the %{name} library.
%prep
%setup -q
%patch0 -p0 -b .crash
%patch1 -p1 -b .fix-glib-headers
%patch2 -p1 -b .file-transfer
%patch3 -p1 -b .status-timestamp-workaround
%patch4 -p1 -b .format-security-fix
%build
export CFLAGS="%{optflags} -fno-tree-vrp"
autoreconf -vif
%configure --enable-doxygen
make %{?_smp_mflags}
%install
make install DESTDIR=%{buildroot} INSTALL="install -p"
find %{buildroot} -name '*.la' -delete
find %{buildroot} -name '*.a' -delete
# Prepare documents for inclusion through %%doc in the %%files section
mkdir docs
mv %{buildroot}%{_datadir}/doc/%{name}-doc-%{version}/{html,samples} docs
rm -rf %{buildroot}%{_datadir}/doc/%{name}-doc-%{version}/
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc AUTHORS ChangeLog COPYING README TODO LICENSE
%{_libdir}/lib%{name}.so.*
%files devel
%{_includedir}/%{name}/
%{_libdir}/lib%{name}.so
%{_libdir}/pkgconfig/%{name}.pc
%files doc
%doc docs/*
%changelog
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed May 27 2015 Simone Caronni <negativo17@gmail.com> - 1.1.0-17
- Fix for failed login (#1171300). Thanks Gustavo Luiz Darte.
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Thu Jan 16 2014 Ville Skyttä <ville.skytta@iki.fi> - 1.1.0-14
- Drop empty NEWS from docs, escape macros in %%changelog.
* Tue Dec 03 2013 Tony Breeds <tony@bakeyournoodle.com> - 1.1.0-13
- Closes #1037196
* Thu Aug 08 2013 Simone Caronni <negativo17@gmail.com> - 1.1.0-12
- Fix documentation generation.
- SPEC file cleanup.
- Documentation is now noarch.
- Run autotools on source; remove aarch64 patch.
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Tue Mar 26 2013 Simone Caronni <negativo17@gmail.com> - 1.1.0-10
- Added aarch64 patch.
* Tue Mar 26 2013 Simone Caronni <negativo17@gmail.com> - 1.1.0-9
- Added patches for file transfer and status time workaround:
http://www.lilotux.net/~mikael/pub/meanwhile/
- Spec file formatting.
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Fri Nov 18 2011 Josh Boyer <jwboyer@gmail.com> 1.1.0-5
- Fix glib.h build issues (rhbz 750023)
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Fri Jan 29 2010 Josh Boyer <jwboyer@gmail.com> - 1.1.0-4
- Remove lib%%{name}.a (#556084)
* Tue Jan 12 2010 Dan Winship <danw@redhat.com> - 1.1.0-3
- Fix Source tag to indicate a CVS snapshot build.
- Resolves: #554446
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Fri Mar 13 2009 Josh Boyer <jwboyer@gmail.com> - 1.1.0-1
- Update to %%{name}_v1_1_0 branch from upstream CVS. Fixes bug 490088