mc/mc-extensions.patch
Jindrich Novy 909e46b454 - update bindings
- attempt to fcntl() descriptors appropriatelly so that subshell doesn't
    leave them open while execve()ing commands (#217027)
- more general fix for #215909
2006-12-04 12:37:46 +00:00

207 lines
5.2 KiB
Diff

--- mc-2006-11-14-16/configure.ac.extensions 2006-11-14 17:05:09.000000000 +0100
+++ mc-2006-11-14-16/configure.ac 2006-12-04 12:53:03.000000000 +0100
@@ -83,7 +83,7 @@
AC_CHECK_TOOL(AR, ar, ar)
dnl Only list browsers here that can be run in background (i.e. with `&')
-AC_CHECK_PROGS(X11_WWW, [gnome-moz-remote mozilla konqueror opera netscape])
+AC_CHECK_PROGS(X11_WWW, [firefox gnome-moz-remote mozilla konqueror opera netscape])
dnl
dnl Ovverriding mmap support. This has to be before AC_FUNC_MMAP is used.
--- mc-2006-11-14-16/configure.extensions 2006-11-14 17:05:25.000000000 +0100
+++ mc-2006-11-14-16/configure 2006-12-04 12:53:03.000000000 +0100
@@ -5767,7 +5767,7 @@
fi
-for ac_prog in gnome-moz-remote mozilla konqueror opera netscape
+for ac_prog in firefox gnome-moz-remote mozilla konqueror opera netscape
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
--- mc-2006-11-14-16/lib/mc.ext.in.extensions 2006-06-22 15:40:51.000000000 +0200
+++ mc-2006-11-14-16/lib/mc.ext.in 2006-12-04 13:07:36.000000000 +0100
@@ -220,14 +220,25 @@
# C
shell/.c
- Open=%var{EDITOR:vi} %f
+ Include=editor
# Fortran
shell/.f
- Open=%var{EDITOR:vi} %f
+ Include=editor
# Header
regex/\.(h|hpp)$
+ Include=editor
+
+# Asm
+regex/\.([Ss]|[Aa]sm|ASM)$
+ Include=editor
+
+# C++
+regex/\.(C|cc|[Cc]pp|CPP)$
+ Include=editor
+
+include/editor
Open=%var{EDITOR:vi} %f
# Object
@@ -251,10 +262,12 @@
# GNU Info page
type/^Info\ text
- Open=info -f %f
+ #Open=info -f %f
+ Open=pinfo %f
shell/.info
- Open=info -f %f
+ #Open=info -f %f
+ Open=pinfo %f
# Manual page
# Exception - .so libraries are not manual pages
@@ -328,18 +342,24 @@
type/^Netpbm
Include=image
+type/^JNG
+ Include=image
+
+type/^MNG
+ Include=image
+
shell/.xcf
Open=(gimp %f &)
shell/.xbm
- Open=bitmap %f
+ Include=image
shell/.xpm
Include=image
View=sxpm %f
include/image
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (display %f &); fi
View=%view{ascii} identify %f
#View=%view{ascii} asciiview %f
@@ -357,8 +377,12 @@
Open=vplay -s 22 %f
regex/\.([mM][pP]3)$
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+ Include=audio
+ #Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
+ #View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+
+regex/\.([mM][kK][aA])$
+ Include=audio
regex/\.([oO][gG][gG])$
Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f &); fi
@@ -371,6 +395,9 @@
Open=mplayer -vo null %f
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
+include/audio
+ Open=mplayer %f
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
### Play lists ###
@@ -395,20 +422,27 @@
regex/\.([mM][pP]4|[mM][pP][eE]?[gG])$
Include=video
+regex/\.([mM][kK][vV])$
+ Include=video
+
regex/\.([vV][oO][bB])$
Include=video
regex/\.([wW][mM][vV])$
Include=video
+regex/\.([fF][lL][iIcC])$
+ Include=video
+
regex/\.([oO][gG][mM])$
Include=video
regex/\.([rR][aA]?[mM])$
- Open=(realplay %f >/dev/null 2>&1 &)
+ Include=video
include/video
Open=(mplayer %f >/dev/null 2>&1 &)
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
#Open=(gtv %f >/dev/null 2>&1 &)
#Open=(xanim %f >/dev/null 2>&1 &)
@@ -417,12 +451,13 @@
# Postscript
type/^PostScript
- Open=(gv %f &)
+ Open=(evince %f >/dev/null 2>&1 &)
View=%view{ascii} ps2ascii %f
# PDF
type/^PDF
- Open=(xpdf %f &)
+ Open=(evince %f >/dev/null 2>&1 &)
+ #Open=(xpdf %f >/dev/null 2>&1 &)
#Open=(acroread %f &)
#Open=(ghostview %f &)
View=%view{ascii} pdftotext %f -
@@ -433,7 +468,7 @@
# html
regex/\.([hH][tT][mM][lL]?)$
Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
- View=%view{ascii} lynx -dump -force_html %f
+ View=%view{ascii} links -dump %f
# StarOffice 5.2
shell/.sdw
@@ -450,22 +485,27 @@
# Microsoft Word Document
regex/\.([Dd][oO][cCtT]|[Ww][rR][iI])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(ooffice %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} catdoc -w %f || word2x -f text %f - || strings %f
type/^Microsoft\ Word
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(ooffice %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} catdoc -w %f || word2x -f text %f - || strings %f
# RTF document
regex/\.([rR][tT][fF])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(ooffice %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
# Microsoft Excel Worksheet
regex/\.([xX][lL][sSwW])$
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(ooffice %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
type/^Microsoft\ Excel
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(ooffice %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
# Use OpenOffice.org to open any MS Office documents