mc-4.8.28-2.fc37
- fix file sort by version - Resolves: #2091504 Signed-off-by: Jindrich Novy <jnovy@redhat.com>
This commit is contained in:
parent
19c3f66511
commit
f31bb80b8b
31
34d3726b79d35481e96f5fabe8e34e3439e6d9d9.patch
Normal file
31
34d3726b79d35481e96f5fabe8e34e3439e6d9d9.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From db109be8a28f1556495979ee7d1967e982cca6fd Mon Sep 17 00:00:00 2001
|
||||||
|
From: Andrew Borodin <aborodin@vmail.ru>
|
||||||
|
Date: Mon, 23 May 2022 20:52:30 +0300
|
||||||
|
Subject: [PATCH] Ticket #4374: fix file sort by version.
|
||||||
|
|
||||||
|
Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
|
||||||
|
---
|
||||||
|
src/filemanager/dir.c | 10 +++++++++-
|
||||||
|
1 file changed, 9 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/filemanager/dir.c b/src/filemanager/dir.c
|
||||||
|
index 5862da6f9c..65a80cf12f 100644
|
||||||
|
--- a/src/filemanager/dir.c
|
||||||
|
+++ b/src/filemanager/dir.c
|
||||||
|
@@ -358,7 +358,15 @@ sort_vers (file_entry_t * a, file_entry_t * b)
|
||||||
|
int bd = MY_ISDIR (b);
|
||||||
|
|
||||||
|
if (ad == bd || panels_options.mix_all_files)
|
||||||
|
- return filevercmp (a->fname->str, b->fname->str) * reverse;
|
||||||
|
+ {
|
||||||
|
+ int result;
|
||||||
|
+
|
||||||
|
+ result = filevercmp (a->fname->str, b->fname->str);
|
||||||
|
+ if (result != 0)
|
||||||
|
+ return result * reverse;
|
||||||
|
+
|
||||||
|
+ return sort_name (a, b);
|
||||||
|
+ }
|
||||||
|
|
||||||
|
return bd - ad;
|
||||||
|
}
|
7
mc.spec
7
mc.spec
@ -4,7 +4,7 @@ Summary: User-friendly text console file manager and visual shell
|
|||||||
Name: mc
|
Name: mc
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.28
|
Version: 4.8.28
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.midnight-commander.org/
|
URL: http://www.midnight-commander.org/
|
||||||
Source0: https://github.com/MidnightCommander/mc/archive/%{version}.tar.gz
|
Source0: https://github.com/MidnightCommander/mc/archive/%{version}.tar.gz
|
||||||
@ -12,6 +12,7 @@ Patch1: %{name}-spec.syntax.patch
|
|||||||
Patch3: %{name}-python3.patch
|
Patch3: %{name}-python3.patch
|
||||||
Patch4: %{name}-default_setup.patch
|
Patch4: %{name}-default_setup.patch
|
||||||
Patch5: %{name}-tmpdir.patch
|
Patch5: %{name}-tmpdir.patch
|
||||||
|
Patch6: https://github.com/MidnightCommander/mc/commit/34d3726b79d35481e96f5fabe8e34e3439e6d9d9.patch
|
||||||
# deps for autogen.sh
|
# deps for autogen.sh
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
@ -103,6 +104,10 @@ sed -i "s,PREV_MC_VERSION=\"unknown\",PREV_MC_VERSION=\"%{version}\"," version.s
|
|||||||
%{_libexecdir}/mc/extfs.d/{s3+,uc1541}
|
%{_libexecdir}/mc/extfs.d/{s3+,uc1541}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 30 2022 Jindrich Novy <jnovy@redhat.com> - 1:4.8.28-2
|
||||||
|
- fix file sort by version
|
||||||
|
- Resolves: #2091504
|
||||||
|
|
||||||
* Fri Apr 29 2022 Jindrich Novy <jnovy@redhat.com> - 1:4.8.28-1
|
* Fri Apr 29 2022 Jindrich Novy <jnovy@redhat.com> - 1:4.8.28-1
|
||||||
- update to https://github.com/MidnightCommander/mc/releases/tag/v4.8.28
|
- update to https://github.com/MidnightCommander/mc/releases/tag/v4.8.28
|
||||||
- Related: #1993686
|
- Related: #1993686
|
||||||
|
Loading…
Reference in New Issue
Block a user